aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-18 07:48:01 +0800
committereadler <eadler@FreeBSD.org>2013-03-18 07:48:01 +0800
commit8b55744c287a71848ab69e11d5b5e7344ce00abc (patch)
tree52e42dac631812481cbe2f1415ead443f237a8a0
parente3803ed562efa4d684d823cd2de56f9f6fd1a61f (diff)
downloadfreebsd-ports-gnome-8b55744c287a71848ab69e11d5b5e7344ce00abc.tar.gz
freebsd-ports-gnome-8b55744c287a71848ab69e11d5b5e7344ce00abc.tar.zst
freebsd-ports-gnome-8b55744c287a71848ab69e11d5b5e7344ce00abc.zip
Simplify port:
- remove inert code that attempted to remove a ./configure file - convert to OptionsNG
-rw-r--r--x11/vdesk/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/x11/vdesk/Makefile b/x11/vdesk/Makefile
index ef973f48a07c..6e9d3ca62f9c 100644
--- a/x11/vdesk/Makefile
+++ b/x11/vdesk/Makefile
@@ -13,7 +13,9 @@ COMMENT= Command-line utility for setting up and using virtual desktops
DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
PLIST_DIRS= share/doc/vdesk
PLIST_FILES= bin/vdesk
-.if !defined(NOPORTDOCS)
+
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MDOCS}
.for ii in ${DOCS}
PLIST_FILES+= share/doc/vdesk/${ii}
.endfor
@@ -21,13 +23,9 @@ PLIST_FILES+= share/doc/vdesk/${ii}
USE_AUTOTOOLS= autoconf
USE_XORG= x11
-post-extract:
-# Avoid having to read this lengthy file.
- ${RM} ${WRKSRC}/configure
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vdesk ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for ii in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}