aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2016-08-18 00:22:50 +0800
committergerald <gerald@FreeBSD.org>2016-08-18 00:22:50 +0800
commit8c5b3b13145c067f4a974e1fdaa33ed8fe40c994 (patch)
tree90b34eea685cc32357f75b98315f9effd94925e0
parent31d4d23fe03503433b06bc4c34b97119d8661efa (diff)
downloadfreebsd-ports-gnome-8c5b3b13145c067f4a974e1fdaa33ed8fe40c994.tar.gz
freebsd-ports-gnome-8c5b3b13145c067f4a974e1fdaa33ed8fe40c994.tar.zst
freebsd-ports-gnome-8c5b3b13145c067f4a974e1fdaa33ed8fe40c994.zip
Backport the following from lang/gcc5-devel:
GCC uses an AWK script to generate source code that helps process command-line options. According to POSIX, string comparisons (and hence sorting) are to be performed based on the locale's collating order. Alas GNU AWK only does so in POSIX mode, whereas starting with FreeBSD 11 we do so by default, running into a bug (or false assumption) with that script used by GCC. Setting MAKE_ARGS such that AWK is always invoked in the C locale works around this bug. PR: 210122, 211742 Submitted by: jkim
-rw-r--r--lang/gcc5/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index 960527691a84..6ea575d350bc 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -103,7 +103,10 @@ CONFIGURE_ARGS+=--disable-nls \
${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
+# On FreeBSD 11 and above AWK uses the locale's collating order which
+# runs into a bug in GCC (PR 211742).
+MAKE_ARGS+= MAKEINFOFLAGS="--no-split" \
+ AWK="${SETENV} LC_ALL=C ${AWK:Q}"
USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VERSION=${GCC_VERSION} \
GNU_HOST=${CONFIGURE_TARGET} \