aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-08 18:15:18 +0800
committerpav <pav@FreeBSD.org>2009-01-08 18:15:18 +0800
commit8ca2ff783ef42a966c8afb9cfc8b2b30cef5700f (patch)
tree487fd51f911ed1ea34e73ebb3051f9beecbc250d
parenta68d2ed8dc5e1dba8d725f32599b44c9cb2a3350 (diff)
downloadfreebsd-ports-gnome-8ca2ff783ef42a966c8afb9cfc8b2b30cef5700f.tar.gz
freebsd-ports-gnome-8ca2ff783ef42a966c8afb9cfc8b2b30cef5700f.tar.zst
freebsd-ports-gnome-8ca2ff783ef42a966c8afb9cfc8b2b30cef5700f.zip
- Remove checks for python < 2.0
Suggested by: Alex Kozlov <spam@rm-rf.kiev.ua>
-rw-r--r--devel/py-grouch/Makefile3
-rw-r--r--devel/py-grouch/pkg-req17
-rw-r--r--textproc/py-asv/Makefile3
-rw-r--r--textproc/py-asv/pkg-req17
4 files changed, 0 insertions, 40 deletions
diff --git a/devel/py-grouch/Makefile b/devel/py-grouch/Makefile
index e1e54b91498c..c0049441c9ae 100644
--- a/devel/py-grouch/Makefile
+++ b/devel/py-grouch/Makefile
@@ -26,9 +26,6 @@ PYDISTUTILS_PKGNAME= Grouch
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/compiler/__init__.py:${PORTSDIR}/lang/py-compiler
.endif
-pre-install:
- @ ${SH} ${PKGREQ} INSTALL
-
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
diff --git a/devel/py-grouch/pkg-req b/devel/py-grouch/pkg-req
deleted file mode 100644
index 49ee2f57973e..000000000000
--- a/devel/py-grouch/pkg-req
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-
-PATH=$PATH:/usr/local/bin
-
-if [ "x$1" = "xINSTALL" -o "x$2" = "xINSTALL" ]; then
- PYTHON_GT=`python -c 'import string, sys; \
- print string.split(sys.version)[0] >= "2.0" and 1'`
- if [ "x${PYTHON_GT}" = "x1" ]; then
- exit 0
- else
- echo "-----------------------------------------------------------"
- echo "Grouch requires Python version 2.0 or greater - "
- echo " please update your Python installation before proceeding."
- echo "-----------------------------------------------------------"
- exit 1
- fi
-fi
diff --git a/textproc/py-asv/Makefile b/textproc/py-asv/Makefile
index a50f2e6769a9..616a558046c4 100644
--- a/textproc/py-asv/Makefile
+++ b/textproc/py-asv/Makefile
@@ -27,9 +27,6 @@ do-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
-pre-install:
- @ ${SH} ${PKGREQ} INSTALL
-
do-install:
@printf '#!/bin/sh\n${PYTHON_CMD} ${PYTHONPREFIX_SITELIBDIR}/ASV.py "$$@"\n' \
> ${WRKDIR}/asv.sh
diff --git a/textproc/py-asv/pkg-req b/textproc/py-asv/pkg-req
deleted file mode 100644
index e4fcd712858b..000000000000
--- a/textproc/py-asv/pkg-req
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-
-PATH=$PATH:/usr/local/bin
-
-if [ "x$1" = "xINSTALL" -o "x$2" = "xINSTALL" ]; then
- PYTHON_GT=`python -c 'import string, sys; \
- print string.split(sys.version)[0] >= "2.0" and 1'`
- if [ "x${PYTHON_GT}" = "x1" ]; then
- exit 0
- else
- echo "-----------------------------------------------------------"
- echo "ASV requires Python version 2.0 or greater -"
- echo " please update your Python installation before proceeding."
- echo "-----------------------------------------------------------"
- exit 1
- fi
-fi