aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-16 22:08:27 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-16 22:08:27 +0800
commit8d2d62c87cf14d16284b220fccb7bc53ae205f70 (patch)
tree5dcba390333ad8ea4b6f6c244a096709cf385ff0
parent9da155d872ffdd565be5b48e0283674d05f22401 (diff)
downloadfreebsd-ports-gnome-8d2d62c87cf14d16284b220fccb7bc53ae205f70.tar.gz
freebsd-ports-gnome-8d2d62c87cf14d16284b220fccb7bc53ae205f70.tar.zst
freebsd-ports-gnome-8d2d62c87cf14d16284b220fccb7bc53ae205f70.zip
- Add LICENSE
- Strip library
-rw-r--r--devel/py-pqueue/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/py-pqueue/Makefile b/devel/py-pqueue/Makefile
index 43a360a0474b..916fee873f91 100644
--- a/devel/py-pqueue/Makefile
+++ b/devel/py-pqueue/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pqueue
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://www.csse.monash.edu.au/hons/projects/1999/Andrew.Snare/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,9 @@ DISTNAME= PQueue-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fibonacci-Heap based Priority-Queue Extension for Python
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= python tar:bzip2
USE_PYTHON= distutils autoplist
@@ -19,4 +23,7 @@ WRKSRC= ${WRKDIR}/PQueue
post-patch:
${CP} ${FILESDIR}/setup.py ${WRKSRC}
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pqueue.so
+
.include <bsd.port.mk>