aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-06-06 06:06:01 +0800
committermiwi <miwi@FreeBSD.org>2010-06-06 06:06:01 +0800
commit8e7137fd34dfae5dbe14b5a27d33f6d5a4e727e5 (patch)
tree33bbc130f12458f0b7f40ffd617be680a00f8f34
parent4bcbdd2c9437d2daac76a81d24e30609f07238d1 (diff)
downloadfreebsd-ports-gnome-8e7137fd34dfae5dbe14b5a27d33f6d5a4e727e5.tar.gz
freebsd-ports-gnome-8e7137fd34dfae5dbe14b5a27d33f6d5a4e727e5.tar.zst
freebsd-ports-gnome-8e7137fd34dfae5dbe14b5a27d33f6d5a4e727e5.zip
POE::Component::IRC::Plugin::Blowfish is a POE::Component::IRC plugin
that provides blowfish encryption. WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-Blowfish/ PR: ports/147508 Submitted by: Jase Thew <freebsd at beardz.net>
-rw-r--r--irc/Makefile1
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile35
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/distinfo3
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-descr4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist13
5 files changed, 56 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 4416f131d6c7..08108ad6a2a0 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -87,6 +87,7 @@
SUBDIR += p5-IRC-Bot-Hangman
SUBDIR += p5-POE-Component-IRC
SUBDIR += p5-POE-Component-IRC-Object
+ SUBDIR += p5-POE-Component-IRC-Plugin-Blowfish
SUBDIR += p5-POE-Component-IRC-Plugin-Bollocks
SUBDIR += p5-POE-Component-IRC-Plugin-CoreList
SUBDIR += p5-POE-Component-IRC-Plugin-POE-Knee
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
new file mode 100644
index 000000000000..a193d5d0e08a
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: POE-Component-IRC-Plugin-Blowfish
+# Date created: June 05 2010
+# Whom: Jase Thew <freebsd@beardz.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC-Plugin-Blowfish
+PORTVERSION= 0.01
+CATEGORIES= irc perl5 devel
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsd@beardz.net
+COMMENT= A POE::Component::IRC plugin tthat provides blowfish encryption
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ ${SITE_PERL}/Crypt/Blowfish_PP.pm:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
+RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ ${SITE_PERL}/Crypt/Blowfish_PP.pm:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::IRC::Plugin::Blowfish.3
+
+post-install:
+.ifndef(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/distinfo b/irc/p5-POE-Component-IRC-Plugin-Blowfish/distinfo
new file mode 100644
index 000000000000..21888f202a65
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-IRC-Plugin-Blowfish-0.01.tar.gz) = 0f1af95cfd118a8bd8bc9b272ca1798e
+SHA256 (POE-Component-IRC-Plugin-Blowfish-0.01.tar.gz) = 3e29da8aa01f51a56a79a8c5c3a434e3c3ab105d6b77f902b257f75b7093014d
+SIZE (POE-Component-IRC-Plugin-Blowfish-0.01.tar.gz) = 15453
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-descr b/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-descr
new file mode 100644
index 000000000000..c25d92971d73
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-descr
@@ -0,0 +1,4 @@
+POE::Component::IRC::Plugin::Blowfish is a POE::Component::IRC plugin
+that provides blowfish encryption.
+
+WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-Blowfish/
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist
new file mode 100644
index 000000000000..ab02c204d75e
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/POE/Component/IRC/Plugin/Blowfish.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/Blowfish/.packlist
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/Blowfish
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE