aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-11-20 08:06:14 +0800
committermarino <marino@FreeBSD.org>2016-11-20 08:06:14 +0800
commit8f3ae9d4438cb58d4b9aa275fcabde897b5724f2 (patch)
treefdffa21d11fc10ef0bc72638b7119fe480a3839a
parent58a9fac1d9d2fdebd0c8b9284811dba351445572 (diff)
downloadfreebsd-ports-gnome-8f3ae9d4438cb58d4b9aa275fcabde897b5724f2.tar.gz
freebsd-ports-gnome-8f3ae9d4438cb58d4b9aa275fcabde897b5724f2.tar.zst
freebsd-ports-gnome-8f3ae9d4438cb58d4b9aa275fcabde897b5724f2.zip
lang/seed7: Fix ports ncurses header inclusion
seed7 can only find the base ncurses headers, so augment the CFLAGS so it can find the headers for the ncurses library it uses. Approved by: ncurses blanket
-rw-r--r--lang/seed7/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 14b6dca1600a..6ab683032b5a 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -42,7 +42,9 @@ PORTDOCS= *
MAKEFILE= mk_freebsd.mk
post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;' ${WRKSRC}/${MAKEFILE}
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;' \
+ -e 's|^CFLAGS = |CFLAGS = -I${NCURSESINC} |' \
+ ${WRKSRC}/${MAKEFILE}
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} depend