aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-03-03 07:24:40 +0800
committerflz <flz@FreeBSD.org>2005-03-03 07:24:40 +0800
commit8f8177c0d01bafb9745f143c60cd318b351c58de (patch)
tree7c78485f4c5de6a33a897b2e87143799f4c336c2
parent5bfdf13569bc129447b3be3d28ee95affdc2cf56 (diff)
downloadfreebsd-ports-gnome-8f8177c0d01bafb9745f143c60cd318b351c58de.tar.gz
freebsd-ports-gnome-8f8177c0d01bafb9745f143c60cd318b351c58de.tar.zst
freebsd-ports-gnome-8f8177c0d01bafb9745f143c60cd318b351c58de.zip
Add Klibido 0.2.1, a very fast and efficient KDE/QT-based downloader for Usenet binaries.
PR: ports/78247 Submitted by: Conrad J. Sabatier <conrads@cox.net> Reviewed by: lofi Approved by: pav (mentor)
-rw-r--r--news/Makefile1
-rw-r--r--news/klibido/Makefile29
-rw-r--r--news/klibido/distinfo2
-rw-r--r--news/klibido/pkg-descr10
-rw-r--r--news/klibido/pkg-plist31
5 files changed, 73 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index 1e852fcd7d45..c1ddddc2449b 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -38,6 +38,7 @@
SUBDIR += inn
SUBDIR += inn-current
SUBDIR += inn-stable
+ SUBDIR += klibido
SUBDIR += knews
SUBDIR += leafnode
SUBDIR += leafnode+
diff --git a/news/klibido/Makefile b/news/klibido/Makefile
new file mode 100644
index 000000000000..6cdbdbdcdfb3
--- /dev/null
+++ b/news/klibido/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: klibido
+# Date created: 2 December 2004
+# Whom: conrads@cox.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= klibido
+PORTVERSION= 0.2.1
+CATEGORIES= news
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= conrads@cox.net
+COMMENT= A very fast and efficient KDE/QT-based downloader for Usenet binaries
+
+LIB_DEPENDS= uu.3:${PORTSDIR}/converters/uulib \
+ db-4.2.2:${PORTSDIR}/databases/db42
+
+USE_KDELIBS_VER= 3
+USE_XLIB= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include/db42 ${PTHREAD_CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include/db42" \
+ LDFLAGS="-L${LOCALBASE}/lib/db42 ${PTHREAD_LIBS}"
+
+.include <bsd.port.mk>
diff --git a/news/klibido/distinfo b/news/klibido/distinfo
new file mode 100644
index 000000000000..dc4b63d21db4
--- /dev/null
+++ b/news/klibido/distinfo
@@ -0,0 +1,2 @@
+MD5 (klibido-0.2.1.tar.gz) = 8ea87d479e3715b890f2f0bbb21867f5
+SIZE (klibido-0.2.1.tar.gz) = 681562
diff --git a/news/klibido/pkg-descr b/news/klibido/pkg-descr
new file mode 100644
index 000000000000..28c1ce1b1c91
--- /dev/null
+++ b/news/klibido/pkg-descr
@@ -0,0 +1,10 @@
+Klibido is a very fast and efficient KDE/QT-based downloader for Usenet
+binaries. It has a nice, clean user interface, and supports using multiple
+news servers with multiple connections per server. Articles may also be
+viewed within the program, including graphic images.
+
+WWW: http://klibido.sourceforge.net/
+
+--
+Conrad J. Sabatier
+conrads@cox.net
diff --git a/news/klibido/pkg-plist b/news/klibido/pkg-plist
new file mode 100644
index 000000000000..277cf6714520
--- /dev/null
+++ b/news/klibido/pkg-plist
@@ -0,0 +1,31 @@
+bin/klibido
+share/applnk/Utilities/klibido.desktop
+share/apps/klibido/icons/hicolor/16x16/actions/icon_article_new.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_article_read.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_article_unread.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_binary.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_binary_complete.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_binary_incomplete.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_filter_only_attachments.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_filter_only_new.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_newsgroup.png
+share/apps/klibido/icons/hicolor/16x16/actions/icon_server.png
+share/apps/klibido/icons/hicolor/16x16/apps/klibido.png
+share/apps/klibido/icons/hicolor/32x32/actions/decode.png
+share/apps/klibido/icons/hicolor/32x32/apps/klibido.png
+share/apps/klibido/klibidoui.rc
+share/doc/HTML/en/klibido/common
+share/doc/HTML/en/klibido/index.cache.bz2
+share/doc/HTML/en/klibido/index.docbook
+share/icons/hicolor/16x16/apps/klibido.png
+share/icons/hicolor/32x32/apps/klibido.png
+@dirrm share/apps/klibido/icons/hicolor/16x16/actions
+@dirrm share/apps/klibido/icons/hicolor/16x16/apps
+@dirrm share/apps/klibido/icons/hicolor/32x32/actions
+@dirrm share/apps/klibido/icons/hicolor/32x32/apps
+@dirrm share/apps/klibido/icons/hicolor/16x16
+@dirrm share/apps/klibido/icons/hicolor/32x32
+@dirrm share/apps/klibido/icons/hicolor
+@dirrm share/apps/klibido/icons
+@dirrm share/apps/klibido
+@dirrm share/doc/HTML/en/klibido