aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-09-05 03:03:45 +0800
committerpawel <pawel@FreeBSD.org>2012-09-05 03:03:45 +0800
commit907cffefbbb898dd4d3f7c624eb8ba6873a6d6f1 (patch)
tree914f634cd3efcfa4652e5f9699bd31c30a8a2eb5
parent4497d2360782ba3f2f949bced8b7a95910bbb3a8 (diff)
downloadfreebsd-ports-gnome-907cffefbbb898dd4d3f7c624eb8ba6873a6d6f1.tar.gz
freebsd-ports-gnome-907cffefbbb898dd4d3f7c624eb8ba6873a6d6f1.tar.zst
freebsd-ports-gnome-907cffefbbb898dd4d3f7c624eb8ba6873a6d6f1.zip
Add patch to fix uuid_create() namespace clash with libc, this affects
at least multimedia/vlc port (crash while checking upnp devices) Submitted by: nox
-rw-r--r--devel/upnp/Makefile1
-rw-r--r--devel/upnp/files/patch-upnp-src-inc-uuid.h17
2 files changed, 18 insertions, 0 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
index 24ffa14bfde7..5906b783b4a9 100644
--- a/devel/upnp/Makefile
+++ b/devel/upnp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= upnp
PORTVERSION= 1.6.17
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= SF/p${PORTNAME}/p${PORTNAME}/libUPnP%20${PORTVERSION}
diff --git a/devel/upnp/files/patch-upnp-src-inc-uuid.h b/devel/upnp/files/patch-upnp-src-inc-uuid.h
new file mode 100644
index 000000000000..4a01583e7b94
--- /dev/null
+++ b/devel/upnp/files/patch-upnp-src-inc-uuid.h
@@ -0,0 +1,17 @@
+--- upnp/src/inc/uuid.h.orig 2012-02-23 18:48:42.000000000 +0100
++++ upnp/src/inc/uuid.h 2012-09-04 20:09:52.000000000 +0200
+@@ -22,6 +22,14 @@
+
+ #include "sysdep.h"
+
++#ifdef __FreeBSD__
++/* Workaround to avoid picking up different uuid_* fns from FreeBSD's libc */
++#define uuid_create libupnp_uuid_create
++#define uuid_unpack libupnp_uuid_unpack
++#define uuid_create_from_name libupnp_uuid_create_from_name
++#define uuid_compare libupnp_uuid_compare
++#endif
++
+ /*! . */
+ typedef struct _uuid_upnp {
+ /*! . */