aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-05-21 04:36:53 +0800
committermnag <mnag@FreeBSD.org>2006-05-21 04:36:53 +0800
commit910e994c3874b6ba8d2a182d0ca06b68cbe0b696 (patch)
treea7e3982c748629ff86feb8aab05a8217d09e921e
parent50a362030aead36eda6ad89f98becbb9db9b9636 (diff)
downloadfreebsd-ports-gnome-910e994c3874b6ba8d2a182d0ca06b68cbe0b696.tar.gz
freebsd-ports-gnome-910e994c3874b6ba8d2a182d0ca06b68cbe0b696.tar.zst
freebsd-ports-gnome-910e994c3874b6ba8d2a182d0ca06b68cbe0b696.zip
- Update to 0.8.6.20060516
PR: 96595 Submitted by: maintainer
-rw-r--r--www/dillo-i18n/Makefile68
-rw-r--r--www/dillo-i18n/distinfo9
-rw-r--r--www/dillo-i18n/files/enable-ssl.patch10
-rw-r--r--www/dillo-i18n/files/patch-configure112
-rw-r--r--www/dillo-i18n/files/patch-dpi-https.c18
-rw-r--r--www/dillo-i18n/pkg-plist4
6 files changed, 193 insertions, 28 deletions
diff --git a/www/dillo-i18n/Makefile b/www/dillo-i18n/Makefile
index 14553715cb85..3a77d98e7dc8 100644
--- a/www/dillo-i18n/Makefile
+++ b/www/dillo-i18n/Makefile
@@ -5,50 +5,63 @@
# $FreeBSD$
#
# Tunables:
+# WITH_DILLO_SSL: enable experimental SSL support
# WITH_DILLO_META-REFRESH: make dillo accept the meta-refresh tag
# WITHOUT_DILLO_TABS: disable support for tabbed browsing
# WITHOUT_DILLO_ANTIALIAS: disable support for antialiased display
#
-# Please see www/dillo for any general tunables not listed here.
-#
-# XXX:
-# SSL support is currently broken in this version of the i18n patchset:
-# On FreeBSD 4 with OpenSSL 0.9.7d, the configure script refuses to enable
-# ssl at all and on FreeBSD 5 and up, linking is broken.
+# TODO:
+# SSL support is currently partly broken in this version of the i18n dillo:
+# On FreeBSD 4 with OpenSSL 0.9.7d, the configure script uses checks that are
+# too strict. On FreeBSD 5 and 6 it seems to work OK.
-PORTREVISION= 2
+PORTNAME= dillo
+PORTVERSION= ${DILLOVERSION}.${I18NVERSION}
+CATEGORIES= www ipv6
+MASTER_SITES= http://teki.jpn.ph/pc/software/
PKGNAMESUFFIX= -i18n
-
-PATCH_SITES= http://teki.jpn.ph/pc/software/
-PATCHFILES= dillo-0.8.5-i18n-misc-20060105.diff.bz2
-PATCH_DIST_STRIP= -p1
+DISTNAME= ${PORTNAME}-${DILLOVERSION}-i18n-misc-${I18NVERSION}
MAINTAINER= tmseck@netcologne.de
COMMENT= A fast, small graphical Web browser with support for i18n
-MD5_FILE= ${.CURDIR}/distinfo
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
-MASTERDIR= ${.CURDIR}/../../www/dillo
-PKGDIR= ${.CURDIR}
-PLIST_SUB= NLS=""
+DILLOVERSION= 0.8.6
+I18NVERSION= 20060516
+
+USE_BZIP2= yes
+USE_GNOME= gnometarget gtk12
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --enable-cookies --enable-ipv6 --enable-threaded-dns \
+ --disable-dlgui \
+ --libdir=${PREFIX}/libexec
CONFLICTS= dillo-[0-9].[0-9].[0-9]*
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB= NLS=""
+CONFIGURE_ARGS+= --enable-nls
.else
-# Unfortunately, this option does not work yet; the dpi plugins do not
-# build without NLS support anymore.
-# I leave this option in in case anyone really wants to fix this in the
-# i18n patch.
PLIST_SUB= NLS="@comment "
CONFIGURE_ARGS+= --disable-nls
-IGNORE= does not build without NLS support
.endif
.if defined(WITH_DILLO_SSL)
-IGNORE= does not build with SSL support
+# Note: the configure script will deactivate SSL support on 4.x systems.
+# This might get fixed someday so I activate this option unconditionally.
+CONFIGURE_ARGS+= --enable-ssl
+USE_OPENSSL= yes
+.else
+CONFIGURE_ARGS+= --disable-ssl
.endif
.if defined(WITH_DILLO_META-REFRESH)
@@ -70,7 +83,18 @@ CONFIGURE_ARGS+= --enable-anti-alias
CONFIGURE_ARGS+= --disable-anti-alias
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
+ s|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|dillorc|dillorc.sample|g' ${WRKSRC}/Makefile.in
+ @${CP} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.sample
+
pre-configure:
+.if !defined(WITH_DILLO_SSL)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " Set WITH_DILLO_SSL=yes in your make environment or on the"
+ @${ECHO_CMD} " commandline to enable experimental SSL support."
+.endif
.if !defined(WITH_DILLO_META-REFRESH)
@${ECHO_CMD} ""
@${ECHO_CMD} " Set WITH_DILLO_META-REFRESH=yes in your make environment or on the"
@@ -88,4 +112,4 @@ pre-configure:
.endif
@${ECHO_CMD} ""
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/www/dillo-i18n/distinfo b/www/dillo-i18n/distinfo
index cbdbc5920081..57deeafa3ff9 100644
--- a/www/dillo-i18n/distinfo
+++ b/www/dillo-i18n/distinfo
@@ -1,6 +1,3 @@
-MD5 (dillo-0.8.5.tar.bz2) = d0ab7fa1d40b310deb891388604188f8
-SHA256 (dillo-0.8.5.tar.bz2) = 980ccd8e0c0a85e37478e33b5f4f59d2cfda5c16d30af3acad259626d387cd1a
-SIZE (dillo-0.8.5.tar.bz2) = 424795
-MD5 (dillo-0.8.5-i18n-misc-20060105.diff.bz2) = 6e0fa2bc2dbd665799ae7107a22083ab
-SHA256 (dillo-0.8.5-i18n-misc-20060105.diff.bz2) = f2afbec12c2c16284aedc42c9bc89a92455e6f949dfbc83d5f17609cc889be3e
-SIZE (dillo-0.8.5-i18n-misc-20060105.diff.bz2) = 248443
+MD5 (dillo-0.8.6-i18n-misc-20060516.tar.bz2) = f7d498f8631dbb0ea41e6d068a041e0a
+SHA256 (dillo-0.8.6-i18n-misc-20060516.tar.bz2) = 00eee492e80b480376de1a4bd2fb69bb6dd63faff5938ca9f775ee34712997ec
+SIZE (dillo-0.8.6-i18n-misc-20060516.tar.bz2) = 604864
diff --git a/www/dillo-i18n/files/enable-ssl.patch b/www/dillo-i18n/files/enable-ssl.patch
new file mode 100644
index 000000000000..c20ccebf7659
--- /dev/null
+++ b/www/dillo-i18n/files/enable-ssl.patch
@@ -0,0 +1,10 @@
+--- dpi/https.c.orig Sat Mar 25 16:46:48 2006
++++ dpi/https.c Sat Mar 25 16:47:38 2006
+@@ -62,7 +62,6 @@
+ #include "dpiutil.h"
+
+ #define ENABLE_SSL
+-#undef ENABLE_SSL
+ #ifdef ENABLE_SSL
+
+ #include <openssl/ssl.h>
diff --git a/www/dillo-i18n/files/patch-configure b/www/dillo-i18n/files/patch-configure
new file mode 100644
index 000000000000..1e81803f0eab
--- /dev/null
+++ b/www/dillo-i18n/files/patch-configure
@@ -0,0 +1,112 @@
+--- configure.orig Sun May 14 16:44:32 2006
++++ configure Mon May 15 19:32:07 2006
+@@ -309,7 +309,7 @@
+ # include <unistd.h>
+ #endif"
+
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE am__leading_dot DLGUI_TRUE DLGUI_FALSE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB CPP CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE USE_NLS LIBICONV LTLIBICONV INTLLIBS LIBINTL LTLIBINTL POSUB localedir GLIB_CONFIG GLIB_CFLAGS GLIB_LIBS GTK_CONFIG GTK_CFLAGS GTK_LIBS EGREP XFT_CONFIG PKG_CONFIG LIBJPEG_LIBS LIBJPEG_LDFLAGS LIBJPEG_CPPFLAGS LIBPNG_LIBS LIBPNG_CFLAGS LIBZ_LIBS LIBSSL_LIBS LIBPTHREAD_LIBS LIBPTHREAD_LDFLAGS LIBFLTK_CXXFLAGS LIBFLTK_LIBS src doc bin util lib LIBOBJS LTLIBOBJS'
++ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE am__leading_dot DLGUI_TRUE DLGUI_FALSE CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB CPP CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE USE_NLS LIBICONV LTLIBICONV INTLLIBS LIBINTL LTLIBINTL POSUB localedir GLIB_CONFIG GLIB_CFLAGS GLIB_LIBS GTK_CONFIG GTK_CFLAGS GTK_LIBS FLTK2_CONFIG EGREP XFT_CONFIG LIBJPEG_LIBS LIBJPEG_LDFLAGS LIBJPEG_CPPFLAGS LIBPNG_LIBS LIBPNG_CFLAGS LIBZ_LIBS LIBSSL_LIBS LIBPTHREAD_LIBS LIBPTHREAD_LDFLAGS LIBFLTK_CXXFLAGS LIBFLTK_LIBS src doc bin util lib LIBOBJS LTLIBOBJS'
+ ac_subst_files=''
+
+ # Initialize some variables set by options.
+@@ -1952,14 +1952,6 @@
+ fi;
+
+
+-if test x$enable_dlgui = xyes; then
+- DLGUI_TRUE=
+- DLGUI_FALSE='#'
+-else
+- DLGUI_TRUE='#'
+- DLGUI_FALSE=
+-fi
+-
+ # Check whether --enable-meta_refresh or --disable-meta_refresh was given.
+ if test "${enable_meta_refresh+set}" = set; then
+ enableval="$enable_meta_refresh"
+@@ -6792,11 +6784,81 @@
+ rm -f conf.gtktest
+
+
+- echo "$as_me:$LINENO: checking Hackish check for FLTK" >&5
+-echo $ECHO_N "checking Hackish check for FLTK... $ECHO_C" >&6
+- LIBFLTK_CXXFLAGS=`fltk-config --cxxflags`
+- LIBFLTK_LIBS=`fltk-config --ldflags`
++if test "x$enable_dlgui" = "xyes"; then
++ for ac_prog in fltk2-config fltk-config
++do
++ # Extract the first word of "$ac_prog", so it can be a program name with args.
++set dummy $ac_prog; ac_word=$2
++echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
++if test "${ac_cv_path_FLTK2_CONFIG+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ case $FLTK2_CONFIG in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_FLTK2_CONFIG="$FLTK2_CONFIG" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_path_FLTK2_CONFIG="$as_dir/$ac_word$ac_exec_ext"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++
++ ;;
++esac
++fi
++FLTK2_CONFIG=$ac_cv_path_FLTK2_CONFIG
++
++if test -n "$FLTK2_CONFIG"; then
++ echo "$as_me:$LINENO: result: $FLTK2_CONFIG" >&5
++echo "${ECHO_T}$FLTK2_CONFIG" >&6
++else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++
++ test -n "$FLTK2_CONFIG" && break
++done
++test -n "$FLTK2_CONFIG" || FLTK2_CONFIG="NOTFOUND"
+
++ if test "x$FLTK2_CONFIG" != "xNOTFOUND" && test -x "$FLTK2_CONFIG"; then
++ fltk_version=`$FLTK2_CONFIG --version`
++ case "$fltk_version" in
++ 2.*)
++ LIBFLTK_CXXFLAGS=`$FLTK2_CONFIG --cxxflags`
++ LIBFLTK_LIBS=`$FLTK2_CONFIG --ldflags`
++ fltk2_ok="yes"
++ ;;
++ *)
++ echo "$as_me:$LINENO: result: need fltk2 -- disabling fltk support" >&5
++echo "${ECHO_T}need fltk2 -- disabling fltk support" >&6
++ fltk2_ok="no"
++ ;;
++ esac
++ else
++ fltk2_ok="no"
++ fi
++else
++ fltk2_ok="no"
++fi
++
++
++if test x$fltk2_ok = xyes; then
++ DLGUI_TRUE=
++ DLGUI_FALSE='#'
++else
++ DLGUI_TRUE='#'
++ DLGUI_FALSE=
++fi
+
+ if test "x$enable_jpeg" = "xyes"; then
+
diff --git a/www/dillo-i18n/files/patch-dpi-https.c b/www/dillo-i18n/files/patch-dpi-https.c
new file mode 100644
index 000000000000..4fd698b0f55b
--- /dev/null
+++ b/www/dillo-i18n/files/patch-dpi-https.c
@@ -0,0 +1,18 @@
+--- dpi/https.c.orig Sat Mar 25 16:49:59 2006
++++ dpi/https.c Sat Mar 25 16:55:35 2006
+@@ -655,13 +655,8 @@
+ "<b>}</b>\n\n"
+ " <b>*** Dillo's prototype plugin for https support"
+ " is disabled now ***</b>\n\n"
+- " If you want to test this <b>alpha</b> support code, just remove\n"
+- " line 65 from https.c, recompile and reinstall.\n\n"
+- " (beware that this https support is very limited now)\n\n"
+- " To use https and SSL, you must have \n"
+- " the OpenSSL development libraries installed. Check your\n"
+- " O/S distribution provider, or check out\n"
+- " <a href=\"http://www.openssl.org\">www.openssl.org</a>\n\n"
++ " If you want to test this <b>alpha</b> support code, define\n"
++ " WITH_DILLO_SSL in your make environment and rebuild the port.\n\n"
+ " --\n"
+ "</pre></body></html>\n",
+ http_query
diff --git a/www/dillo-i18n/pkg-plist b/www/dillo-i18n/pkg-plist
index e44c54d34d09..6120821b8e4d 100644
--- a/www/dillo-i18n/pkg-plist
+++ b/www/dillo-i18n/pkg-plist
@@ -6,6 +6,8 @@ bin/dpidc
etc/dillorc.sample
etc/dpidrc
libexec/dillo/dpi/bookmarks/bookmarks.dpi
+libexec/dillo/dpi/cookies/cookies.dpi
+libexec/dillo/dpi/datauri/datauri.filter.dpi
libexec/dillo/dpi/downloads/downloads.dpi
libexec/dillo/dpi/file/file.dpi
libexec/dillo/dpi/ftp/ftp.filter.dpi
@@ -19,6 +21,8 @@ libexec/dillo/dpi/https/https.filter.dpi
@dirrm libexec/dillo/dpi/ftp
@dirrm libexec/dillo/dpi/file
@dirrm libexec/dillo/dpi/downloads
+@dirrm libexec/dillo/dpi/datauri
+@dirrm libexec/dillo/dpi/cookies
@dirrm libexec/dillo/dpi/bookmarks
@dirrm libexec/dillo/dpi
@dirrm libexec/dillo