aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-03-22 18:56:44 +0800
committermakc <makc@FreeBSD.org>2009-03-22 18:56:44 +0800
commit9117c92cf5e1682baf065be59984ea4f09a85f67 (patch)
tree671ee17eb5792678859fd226d37fd1dd3c23ee6d
parent922dd7d8f9161178b42d181912ec357b66d040d2 (diff)
downloadfreebsd-ports-gnome-9117c92cf5e1682baf065be59984ea4f09a85f67.tar.gz
freebsd-ports-gnome-9117c92cf5e1682baf065be59984ea4f09a85f67.tar.zst
freebsd-ports-gnome-9117c92cf5e1682baf065be59984ea4f09a85f67.zip
Fix build on 6-STABLE after adding --with-pthread to polish/libgadu
-rw-r--r--polish/ekg/Makefile2
-rw-r--r--polish/ekg2/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index aab292bdb678..6e49c1bf35b2 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ARGS+= --disable-shared \
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lexecinfo"
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lexecinfo ${PTHREAD_LIBS}"
OPTIONS= ASPELL "Build with ASPELL support" off \
OPENSSL "Build with OPENSSL support" on
diff --git a/polish/ekg2/Makefile b/polish/ekg2/Makefile
index a2923e971cae..06f83f063832 100644
--- a/polish/ekg2/Makefile
+++ b/polish/ekg2/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS+= --enable-shared \
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lintl"
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}"
MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
CFLAGS+= -I${LOCALBASE}/include