aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-21 06:34:03 +0800
committerpav <pav@FreeBSD.org>2004-08-21 06:34:03 +0800
commit91515204a23eb8bd0958e102dc638ca91206a10e (patch)
tree43a7f0270c9e45a47164a7fe6beb282329368dd6
parent5b64e4bae111fa10af1af5efb10110a339bfd121 (diff)
downloadfreebsd-ports-gnome-91515204a23eb8bd0958e102dc638ca91206a10e.tar.gz
freebsd-ports-gnome-91515204a23eb8bd0958e102dc638ca91206a10e.tar.zst
freebsd-ports-gnome-91515204a23eb8bd0958e102dc638ca91206a10e.zip
- Use OPTIONS for extra dependencies
PR: ports/70724 Submitted by: Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw>
-rw-r--r--multimedia/fxtv/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/multimedia/fxtv/Makefile b/multimedia/fxtv/Makefile
index d55dadfc45db..299dbecf5b04 100644
--- a/multimedia/fxtv/Makefile
+++ b/multimedia/fxtv/Makefile
@@ -19,22 +19,26 @@ COMMENT= X-based TV Display and Capture Application (for use with bt848 driver)
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
-# This program does not actually require the programs below unless you
-# use audio/video recording and/or playback and save to a non-raw format.
-#RUN_DEPENDS= sox:${PORTSDIR}/audio/sox \
-# mpg123:${PORTSDIR}/audio/mpg123 \
-# mpeg_musicin:${PORTSDIR}/audio/mpegaudio \
-# mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
-# mplex:${PORTSDIR}/multimedia/mplex
-
USE_X_PREFIX= yes
USE_XPM= yes
USE_GMAKE= yes
MAKE_FLAGS= -e
MAN1= fxtv.1
+OPTIONS= EXTRA "Extra programs required to record/playback/save" off
+
.include <bsd.port.pre.mk>
+# This program does not actually require the programs below unless you
+# use audio/video recording and/or playback and save to a non-raw format.
+.if defined(WITH_EXTRA)
+RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ mpeg_musicin:${PORTSDIR}/audio/mpegaudio \
+ mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
+ mplex:${PORTSDIR}/multimedia/mplex
+.endif
+
pre-everything::
.if ${OSVERSION} < 500000
ONLY_FOR_ARCHS= i386