aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2012-12-12 22:47:15 +0800
committermm <mm@FreeBSD.org>2012-12-12 22:47:15 +0800
commit91903ac16b9e21f2d18033f3c606797e58b2a930 (patch)
tree849349aee379f67dfd0312a2c836da934f44fa19
parentcd518fc74b4c4df6f374a80b707885e42976fefd (diff)
downloadfreebsd-ports-gnome-91903ac16b9e21f2d18033f3c606797e58b2a930.tar.gz
freebsd-ports-gnome-91903ac16b9e21f2d18033f3c606797e58b2a930.tar.zst
freebsd-ports-gnome-91903ac16b9e21f2d18033f3c606797e58b2a930.zip
Horde Blowfish Encryption Library
Provides blowfish encryption/decryption for PHP string data. WWW: http://pear.horde.org
-rw-r--r--security/Makefile1
-rw-r--r--security/pear-Horde_Crypt_Blowfish/Makefile34
-rw-r--r--security/pear-Horde_Crypt_Blowfish/distinfo2
-rw-r--r--security/pear-Horde_Crypt_Blowfish/pkg-descr3
4 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index dc20f481a146..b8198a6efdb2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -641,6 +641,7 @@
SUBDIR += pear-HTML_Crypt
SUBDIR += pear-Horde_Auth
SUBDIR += pear-Horde_Crypt
+ SUBDIR += pear-Horde_Crypt_Blowfish
SUBDIR += pear-Horde_Group
SUBDIR += pear-Horde_Oauth
SUBDIR += pear-Horde_Perms
diff --git a/security/pear-Horde_Crypt_Blowfish/Makefile b/security/pear-Horde_Crypt_Blowfish/Makefile
new file mode 100644
index 000000000000..305c7c230feb
--- /dev/null
+++ b/security/pear-Horde_Crypt_Blowfish/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: pear-Horde_Crypt
+# Date created: 12 December 2012
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Horde_Crypt_Blowfish
+PORTVERSION= 1.0.1
+CATEGORIES= security www pear
+PKGNAMEPREFIX= pear-
+
+MAINTAINER= horde@FreeBSD.org
+COMMENT= Horde blowfish encryption for PHP string data
+
+USE_HORDE_RUN= Horde_Exception \
+ Horde_Support
+
+OPTIONS_DEFINE= MHASH OPENSSL
+MHASH_DESC= Depend on mhash PHP extension
+OPENSSL_DESC= Depend on OpenSSL PHP extension
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MMHASH}
+USE_PHP+= mhash
+.endif
+
+.if ${PORT_OPTIONS:MOPENSSL}
+USE_PHP+= openssl
+.endif
+
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Horde_Crypt_Blowfish/distinfo b/security/pear-Horde_Crypt_Blowfish/distinfo
new file mode 100644
index 000000000000..bbadeb0a174c
--- /dev/null
+++ b/security/pear-Horde_Crypt_Blowfish/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde/Horde_Crypt_Blowfish-1.0.1.tgz) = 71da0d9de14fe3e1a9a64d41b7f7f7d863a98eca7cc72576196b833dba285fbf
+SIZE (Horde/Horde_Crypt_Blowfish-1.0.1.tgz) = 24028
diff --git a/security/pear-Horde_Crypt_Blowfish/pkg-descr b/security/pear-Horde_Crypt_Blowfish/pkg-descr
new file mode 100644
index 000000000000..6534fa5dbbae
--- /dev/null
+++ b/security/pear-Horde_Crypt_Blowfish/pkg-descr
@@ -0,0 +1,3 @@
+Horde Blowfish Encryption Library
+
+WWW: http://pear.horde.org