aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-02-11 00:30:33 +0800
committermiwi <miwi@FreeBSD.org>2011-02-11 00:30:33 +0800
commit92f14cdedb2b702fe9697803d74fbf96b5c3fd5b (patch)
treeb6a2dc2cad1479469cfa0abe0e7a819a1d192975
parent43835dfe499137880e757418d6004221eb2d5188 (diff)
downloadfreebsd-ports-gnome-92f14cdedb2b702fe9697803d74fbf96b5c3fd5b.tar.gz
freebsd-ports-gnome-92f14cdedb2b702fe9697803d74fbf96b5c3fd5b.tar.zst
freebsd-ports-gnome-92f14cdedb2b702fe9697803d74fbf96b5c3fd5b.zip
Declare version conflicts for your dist
WWW: http://search.cpan.org/dist/Dist-CheckConflicts/ PR: ports/154626 Submitted by: milki <milki at rescomp.berkeley.edu>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Dist-CheckConflicts/Makefile28
-rw-r--r--devel/p5-Dist-CheckConflicts/distinfo2
-rw-r--r--devel/p5-Dist-CheckConflicts/pkg-descr3
-rw-r--r--devel/p5-Dist-CheckConflicts/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 618664dda583..ee4db02e4065 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1591,6 +1591,7 @@
SUBDIR += p5-Directory-Queue
SUBDIR += p5-Directory-Scratch
SUBDIR += p5-Directory-Scratch-Structured
+ SUBDIR += p5-Dist-CheckConflicts
SUBDIR += p5-Dist-Joseki
SUBDIR += p5-EV
SUBDIR += p5-Env-PS1
diff --git a/devel/p5-Dist-CheckConflicts/Makefile b/devel/p5-Dist-CheckConflicts/Makefile
new file mode 100644
index 000000000000..8bd2e758b183
--- /dev/null
+++ b/devel/p5-Dist-CheckConflicts/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Dist-CheckConflicts
+# Date created: 9 February 2011
+# Whom: milki <milki@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dist-CheckConflicts
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/D/DO/DOY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= Declare version conflicts for your dist
+
+RUN_DEPENDS= p5-List-MoreUtils>=0.12:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+
+TEST_DEPENDS= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
+
+PERL_CONFIGURE= YES
+
+MAN3= Dist::CheckConflicts.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Dist-CheckConflicts/distinfo b/devel/p5-Dist-CheckConflicts/distinfo
new file mode 100644
index 000000000000..78f52d6b8707
--- /dev/null
+++ b/devel/p5-Dist-CheckConflicts/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dist-CheckConflicts-0.02.tar.gz) = b2a4c4c7c4c9cce5441d293a1a67631b6dbf94e5204372a06f04eabd819007d2
+SIZE (Dist-CheckConflicts-0.02.tar.gz) = 15461
diff --git a/devel/p5-Dist-CheckConflicts/pkg-descr b/devel/p5-Dist-CheckConflicts/pkg-descr
new file mode 100644
index 000000000000..40d7e4eaa4cc
--- /dev/null
+++ b/devel/p5-Dist-CheckConflicts/pkg-descr
@@ -0,0 +1,3 @@
+Declare version conflicts for your dist
+
+WWW: http://search.cpan.org/dist/Dist-CheckConflicts/
diff --git a/devel/p5-Dist-CheckConflicts/pkg-plist b/devel/p5-Dist-CheckConflicts/pkg-plist
new file mode 100644
index 000000000000..a09d40092b5b
--- /dev/null
+++ b/devel/p5-Dist-CheckConflicts/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Dist/CheckConflicts.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dist/CheckConflicts/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dist/CheckConflicts
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/Dist