aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-04-11 04:02:24 +0800
committerswills <swills@FreeBSD.org>2011-04-11 04:02:24 +0800
commit98f55067706d27b68f244f598e059cae4063f69d (patch)
treef0bea714abfc0fb8db4cedcd257bb6b22aed079f
parent4d4143b6b52da7b14a834ddd94b6a59608abc18f (diff)
downloadfreebsd-ports-gnome-98f55067706d27b68f244f598e059cae4063f69d.tar.gz
freebsd-ports-gnome-98f55067706d27b68f244f598e059cae4063f69d.tar.zst
freebsd-ports-gnome-98f55067706d27b68f244f598e059cae4063f69d.zip
FileMagic is a Ruby binding to the magic(4) library, which you may
know better as the file(1) command. The file(1) command identifies the type of a file using, among other tests, a test for whether the file begins with a certain magic number. WWW: http://rubygems.org/gems/ruby-filemagic
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-filemagic/Makefile23
-rw-r--r--devel/rubygem-filemagic/distinfo2
-rw-r--r--devel/rubygem-filemagic/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 355eee2ba9b9..1f1943ec8af3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3207,6 +3207,7 @@
SUBDIR += rubygem-fattr
SUBDIR += rubygem-ffi
SUBDIR += rubygem-file-tail
+ SUBDIR += rubygem-filemagic
SUBDIR += rubygem-gdata
SUBDIR += rubygem-gem_plugin
SUBDIR += rubygem-gemcutter
diff --git a/devel/rubygem-filemagic/Makefile b/devel/rubygem-filemagic/Makefile
new file mode 100644
index 000000000000..2c91ac5c9ed0
--- /dev/null
+++ b/devel/rubygem-filemagic/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: filemagic
+# Date created: 2011-04-10
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= filemagic
+PORTVERSION= 0.4.2
+CATEGORIES= devel ruby
+MASTER_SITES= RG
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= A Ruby binding to libmagic(3)
+
+GEM_NAME= ${DISTNAME}
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-filemagic/distinfo b/devel/rubygem-filemagic/distinfo
new file mode 100644
index 000000000000..c363ba4c1414
--- /dev/null
+++ b/devel/rubygem-filemagic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ruby-filemagic-0.4.2.gem) = 977e1fb940c25693c55da7254ca73679fb67f5a7baf264bfb8a4bc2d20d2c179
+SIZE (rubygem/ruby-filemagic-0.4.2.gem) = 14848
diff --git a/devel/rubygem-filemagic/pkg-descr b/devel/rubygem-filemagic/pkg-descr
new file mode 100644
index 000000000000..dc5d5995efc4
--- /dev/null
+++ b/devel/rubygem-filemagic/pkg-descr
@@ -0,0 +1,6 @@
+FileMagic is a Ruby binding to the magic(4) library, which you may
+know better as the file(1) command. The file(1) command identifies
+the type of a file using, among other tests, a test for whether the
+file begins with a certain magic number.
+
+WWW: http://rubygems.org/gems/ruby-filemagic