aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-10-21 04:48:20 +0800
committeralane <alane@FreeBSD.org>2002-10-21 04:48:20 +0800
commit9919c107ff983701d6a84e1ea63e4bb7d907a9d2 (patch)
treeda876aea2d5d996ab93662d94dd4b8203fb5f964
parent1c7ba8f91b734279b89cba59732ad0c85c8cdddb (diff)
downloadfreebsd-ports-gnome-9919c107ff983701d6a84e1ea63e4bb7d907a9d2.tar.gz
freebsd-ports-gnome-9919c107ff983701d6a84e1ea63e4bb7d907a9d2.tar.zst
freebsd-ports-gnome-9919c107ff983701d6a84e1ea63e4bb7d907a9d2.zip
Set CONFIG_SHELL in env so always use /bin/sh. This way results are
at least (closer to) deterministic. PR: 39492 Submitted by: naddy
-rw-r--r--devel/autoconf/Makefile3
-rw-r--r--devel/autoconf213/Makefile3
-rw-r--r--devel/autoconf253/Makefile3
-rw-r--r--devel/autoconf254/Makefile7
-rw-r--r--devel/autoconf257/Makefile7
-rw-r--r--devel/autoconf259/Makefile7
-rw-r--r--devel/autoconf26/Makefile7
-rw-r--r--devel/autoconf261/Makefile7
-rw-r--r--devel/autoconf262/Makefile7
-rw-r--r--devel/autoconf267/Makefile7
-rw-r--r--devel/autoconf268/Makefile7
-rw-r--r--devel/gnu-autoconf/Makefile7
12 files changed, 51 insertions, 21 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index db9669d35b9b..5bbf2dc17867 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
diff --git a/devel/autoconf213/Makefile b/devel/autoconf213/Makefile
index edc4e2abbf9d..8030b0332a4d 100644
--- a/devel/autoconf213/Makefile
+++ b/devel/autoconf213/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=213
WRKSRC= ${WRKDIR}/autoconf
diff --git a/devel/autoconf253/Makefile b/devel/autoconf253/Makefile
index db9669d35b9b..5bbf2dc17867 100644
--- a/devel/autoconf253/Makefile
+++ b/devel/autoconf253/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
diff --git a/devel/autoconf254/Makefile b/devel/autoconf254/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf254/Makefile
+++ b/devel/autoconf254/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \
diff --git a/devel/autoconf257/Makefile b/devel/autoconf257/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf257/Makefile
+++ b/devel/autoconf257/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \
diff --git a/devel/autoconf259/Makefile b/devel/autoconf259/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf259/Makefile
+++ b/devel/autoconf259/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \
diff --git a/devel/autoconf26/Makefile b/devel/autoconf26/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf26/Makefile
+++ b/devel/autoconf26/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \
diff --git a/devel/autoconf261/Makefile b/devel/autoconf261/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf261/Makefile
+++ b/devel/autoconf261/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \
diff --git a/devel/autoconf262/Makefile b/devel/autoconf262/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf262/Makefile
+++ b/devel/autoconf262/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \
diff --git a/devel/autoconf267/Makefile b/devel/autoconf267/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf267/Makefile
+++ b/devel/autoconf267/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \
diff --git a/devel/autoconf268/Makefile b/devel/autoconf268/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf268/Makefile
+++ b/devel/autoconf268/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \
diff --git a/devel/gnu-autoconf/Makefile b/devel/gnu-autoconf/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/gnu-autoconf/Makefile
+++ b/devel/gnu-autoconf/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \