aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-08-26 02:49:34 +0800
committerantoine <antoine@FreeBSD.org>2014-08-26 02:49:34 +0800
commit993a03489b747fb4109adbcdba04d9d73ae39e46 (patch)
treea5afd1c3c107512f4ac9ae85b191cbbe014270ed
parentc181fdb07f59fb59192d6858783b7a5072abcf5a (diff)
downloadfreebsd-ports-gnome-993a03489b747fb4109adbcdba04d9d73ae39e46.tar.gz
freebsd-ports-gnome-993a03489b747fb4109adbcdba04d9d73ae39e46.tar.zst
freebsd-ports-gnome-993a03489b747fb4109adbcdba04d9d73ae39e46.zip
Allow ports using ruby extconf to be built as non root
PR: ports/191313
-rw-r--r--Mk/bsd.ruby.mk1
-rw-r--r--databases/postgresql-plruby/Makefile3
-rw-r--r--databases/ruby-bdb/Makefile2
-rw-r--r--devel/libpafe-ruby/Makefile1
-rw-r--r--graphics/ruby-gd/Makefile2
5 files changed, 2 insertions, 7 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 6db314a46c1d..d9044fc3dbb1 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -522,6 +522,7 @@ USE_RUBY= yes
RUBY_EXTCONF?= extconf.rb
CONFIGURE_ARGS+= --with-opt-dir="${LOCALBASE}"
+CONFIGURE_ENV+= RB_USER_INSTALL=yes
do-configure: ruby-extconf-configure
diff --git a/databases/postgresql-plruby/Makefile b/databases/postgresql-plruby/Makefile
index 0c7f1060c849..68e0e9070efd 100644
--- a/databases/postgresql-plruby/Makefile
+++ b/databases/postgresql-plruby/Makefile
@@ -20,9 +20,8 @@ WANT_PGSQL= server
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_RUBY_RDOC= yes
-NEED_ROOT= yes
-POSTGRESQL_PORT?= databases/postgresql${PGSQL_VER}-server
+POSTGRESQL_PORT?= databases/postgresql${PGSQL_VER_NODOT}-server
PGSQL_PORTDIR?= ${PORTSDIR}/${POSTGRESQL_PORT}
PGSQL_WRKSRC_CMD= cd ${PGSQL_PORTDIR} && ${MAKE} -V WRKSRC
diff --git a/databases/ruby-bdb/Makefile b/databases/ruby-bdb/Makefile
index 88c4a0dd541a..4835b673d61b 100644
--- a/databases/ruby-bdb/Makefile
+++ b/databases/ruby-bdb/Makefile
@@ -56,8 +56,6 @@ SHEBANG_FILES= examples/record.rb \
examples/basic.rb \
examples/lock.rb
-NEED_ROOT= yes
-
.include <bsd.port.pre.mk>
post-patch:
diff --git a/devel/libpafe-ruby/Makefile b/devel/libpafe-ruby/Makefile
index 0357c7dfb39c..8e000b554355 100644
--- a/devel/libpafe-ruby/Makefile
+++ b/devel/libpafe-ruby/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= libpafe.so:${PORTSDIR}/devel/libpafe
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-NEED_ROOT= yes
PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/pasori.so
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index a153b015174c..e7215446cb02 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -17,8 +17,6 @@ COMMENT= Ruby extension library to use Thomas Boutell's gd library
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libgd.so:${PORTSDIR}/graphics/gd
-NEED_ROOT= yes
-
USE_RUBY= yes
USE_RUBY_EXTCONF= yes