aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2011-01-12 19:08:36 +0800
committerskv <skv@FreeBSD.org>2011-01-12 19:08:36 +0800
commit9a93c73f674513f12c8bd7021b9534324c3b295b (patch)
tree6fb86a5b609fb6d470a74708350acd387b318ba8
parent3aa002a40fa0bf76cf97fc1008a5017fdd5a0753 (diff)
downloadfreebsd-ports-gnome-9a93c73f674513f12c8bd7021b9534324c3b295b.tar.gz
freebsd-ports-gnome-9a93c73f674513f12c8bd7021b9534324c3b295b.tar.zst
freebsd-ports-gnome-9a93c73f674513f12c8bd7021b9534324c3b295b.zip
Add p5-XML-Compile-SOAP-AnyEvent 0.01, exchange XML via AnyEvent::HTTP.
Feature safe: yes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-XML-Compile-SOAP-AnyEvent/Makefile29
-rw-r--r--net/p5-XML-Compile-SOAP-AnyEvent/distinfo2
-rw-r--r--net/p5-XML-Compile-SOAP-AnyEvent/pkg-descr8
-rw-r--r--net/p5-XML-Compile-SOAP-AnyEvent/pkg-plist10
5 files changed, 50 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5ee253ca5aac..668dc600fe20 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -734,6 +734,7 @@
SUBDIR += p5-What
SUBDIR += p5-X500-DN
SUBDIR += p5-XML-Compile-SOAP
+ SUBDIR += p5-XML-Compile-SOAP-AnyEvent
SUBDIR += p5-XML-Compile-SOAP-Daemon
SUBDIR += p5-XML-Compile-SOAP-WSA
SUBDIR += p5-XML-RPC
diff --git a/net/p5-XML-Compile-SOAP-AnyEvent/Makefile b/net/p5-XML-Compile-SOAP-AnyEvent/Makefile
new file mode 100644
index 000000000000..4cbecbe43d3f
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-AnyEvent/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: XML-Compile-SOAP-AnyEvent
+# Date created: 12 Jan 2011
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Compile-SOAP-AnyEvent
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Exchange XML via AnyEvent::HTTP
+
+BUILD_DEPENDS= p5-XML-Compile-SOAP>=2.18:${PORTSDIR}/net/p5-XML-Compile-SOAP \
+ p5-AnyEvent-HTTP>=1.46:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-Log-Report>=0.28:${PORTSDIR}/devel/p5-Log-Report
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Compile::Transfer::SOAPHTTP_AnyEvent.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-XML-Compile-SOAP-AnyEvent/distinfo b/net/p5-XML-Compile-SOAP-AnyEvent/distinfo
new file mode 100644
index 000000000000..980ed38f6568
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-AnyEvent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (XML-Compile-SOAP-AnyEvent-0.01.tar.gz) = 3af566053bc91e6e0e024e8cefb662a92a13b1ca4f0b1e908dcbe2cccd34226e
+SIZE (XML-Compile-SOAP-AnyEvent-0.01.tar.gz) = 6140
diff --git a/net/p5-XML-Compile-SOAP-AnyEvent/pkg-descr b/net/p5-XML-Compile-SOAP-AnyEvent/pkg-descr
new file mode 100644
index 000000000000..bbe2604feab2
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-AnyEvent/pkg-descr
@@ -0,0 +1,8 @@
+This module handles the exchange of (XML) messages, according to the
+rules of SOAP (any version). The module does not known how to parse or
+compose XML, but only worries about the HTTP aspects.
+
+In contrairy to XML::Compile::Transport::SOAPHTTP, this implementation
+can be used in various event-driven environments, via AnyEvent::HTTP.
+
+WWW: http://search.cpan.org/dist/XML-Compile-SOAP-AnyEvent/
diff --git a/net/p5-XML-Compile-SOAP-AnyEvent/pkg-plist b/net/p5-XML-Compile-SOAP-AnyEvent/pkg-plist
new file mode 100644
index 000000000000..290bab926786
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-AnyEvent/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/AnyEvent/.packlist
+%%SITE_PERL%%/XML/Compile/Transfer/SOAPHTTP_AnyEvent.pm
+%%SITE_PERL%%/XML/Compile/Transfer/SOAPHTTP_AnyEvent.pod
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/AnyEvent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/Compile/Transfer
+@dirrmtry %%SITE_PERL%%/XML/Compile
+@dirrmtry %%SITE_PERL%%/XML