aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2011-12-02 20:16:26 +0800
committerfjoe <fjoe@FreeBSD.org>2011-12-02 20:16:26 +0800
commit9b5e20d43198c775e84497b21ad5c05a30c34383 (patch)
tree561290307fd38aa9f4578b216c6d9009eab93ea6
parent7cae7648e20d70d061c31646d2bf6894ae520e18 (diff)
downloadfreebsd-ports-gnome-9b5e20d43198c775e84497b21ad5c05a30c34383.tar.gz
freebsd-ports-gnome-9b5e20d43198c775e84497b21ad5c05a30c34383.tar.zst
freebsd-ports-gnome-9b5e20d43198c775e84497b21ad5c05a30c34383.zip
Fix Ctrl-O in xterm: FreeBSD xterm does not define "ti" and "te" but mc
tries to check their existence since 4.7.5.4. PR: 161828 Feature safe: yes
-rw-r--r--misc/mc/Makefile2
-rw-r--r--misc/mc/files/patch-lib-tty-win.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index da71619cf187..f37fbac32287 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mc
PORTVERSION= 4.7.5.5
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= misc shells
MASTER_SITES= http://www.midnight-commander.org/downloads/ \
${MASTER_SITE_SUNSITE}
diff --git a/misc/mc/files/patch-lib-tty-win.c b/misc/mc/files/patch-lib-tty-win.c
new file mode 100644
index 000000000000..c759ff135d19
--- /dev/null
+++ b/misc/mc/files/patch-lib-tty-win.c
@@ -0,0 +1,20 @@
+--- lib/tty/win.c.orig 2011-12-02 18:59:45.000000000 +0700
++++ lib/tty/win.c 2011-12-02 19:00:11.000000000 +0700
+@@ -98,7 +98,7 @@
+ void
+ do_enter_ca_mode (void)
+ {
+- if (xterm_flag && smcup != NULL)
++ if (xterm_flag)
+ {
+ fprintf (stdout, /* ESC_STR ")0" */ ESC_STR "7" ESC_STR "[?47h");
+ fflush (stdout);
+@@ -110,7 +110,7 @@
+ void
+ do_exit_ca_mode (void)
+ {
+- if (xterm_flag && rmcup != NULL)
++ if (xterm_flag)
+ {
+ fprintf (stdout, ESC_STR "[?47l" ESC_STR "8" ESC_STR "[m");
+ fflush (stdout);