aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-23 00:24:11 +0800
committerbapt <bapt@FreeBSD.org>2013-04-23 00:24:11 +0800
commit9ba38ebfeae2e3d6baf3c3d36e6d4e43be558436 (patch)
treeeece2d4a53b30a7503506d0dee2b7f6c53cc8b06
parentb0b0df36edd2b389ca6e24e03e62dbc98e86f661 (diff)
downloadfreebsd-ports-gnome-9ba38ebfeae2e3d6baf3c3d36e6d4e43be558436.tar.gz
freebsd-ports-gnome-9ba38ebfeae2e3d6baf3c3d36e6d4e43be558436.tar.zst
freebsd-ports-gnome-9ba38ebfeae2e3d6baf3c3d36e6d4e43be558436.zip
On all supported version of FreeBSD tar do support rpm as an archive format.
So directly use tar to extract linux* distfiles instead of rpm2cpio.
-rw-r--r--Mk/bsd.linux-rpm.mk10
-rw-r--r--emulators/linux_base-c6/Makefile10
-rw-r--r--emulators/linux_base-f10/Makefile10
3 files changed, 9 insertions, 21 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index f04584eb4c39..43d554e0fca2 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -33,8 +33,6 @@
Linux_RPM_Include_MAINTAINER= emulation@FreeBSD.org
Linux_RPM_Pre_Include= bsd.linux-rpm.mk
-RPM2CPIO?= ${LOCALBASE}/bin/rpm2cpio
-
EXTRACT_SUFX?= .${LINUX_RPM_ARCH}.rpm
SRC_SUFX?= .src.rpm
@@ -133,11 +131,9 @@ MASTER_SITE_SUBDIR+= ${MASTER_SITE_SRC_SUBDIR}
ALWAYS_KEEP_DISTFILES= yes
. endif
-EXTRACT_DEPENDS+= ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
-
-EXTRACT_CMD?= ${RPM2CPIO}
-EXTRACT_BEFORE_ARGS?=
-EXTRACT_AFTER_ARGS?= | ${CPIO} -id --quiet
+EXTRACT_CMD?= ${TAR}
+EXTRACT_BEFORE_ARGS?= -xf
+EXTRACT_AFTER_ARGS?=
DISTINFO_FILE?= ${MASTERDIR}/distinfo.${LINUX_RPM_ARCH}
diff --git a/emulators/linux_base-c6/Makefile b/emulators/linux_base-c6/Makefile
index eaf711f6e4ae..cc89731d6a64 100644
--- a/emulators/linux_base-c6/Makefile
+++ b/emulators/linux_base-c6/Makefile
@@ -114,14 +114,10 @@ PLIST_SUB= GLIBCVER="2.12"
# - research what are the important differences between 2.6.16 and 2.6.18, and
# if we need to add something to the linuxulator
-RPM2CPIO?= ${LOCALBASE}/bin/rpm2cpio
-
-EXTRACT_DEPENDS+= ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
-
EXTRACT_ONLY= ${BIN_DISTFILES}
-EXTRACT_CMD?= ${RPM2CPIO}
-EXTRACT_BEFORE_ARGS?=
-EXTRACT_AFTER_ARGS?= | ${CPIO} -id --quiet
+EXTRACT_CMD?= ${TAR}
+EXTRACT_BEFORE_ARGS?= -xf
+EXTRACT_AFTER_ARGS?=
.include <bsd.port.pre.mk>
diff --git a/emulators/linux_base-f10/Makefile b/emulators/linux_base-f10/Makefile
index 6cc5b877967f..6f73d1e81845 100644
--- a/emulators/linux_base-f10/Makefile
+++ b/emulators/linux_base-f10/Makefile
@@ -110,14 +110,10 @@ NO_WRKSUBDIR= yes
DISTINFO_FILE?= ${MASTERDIR}/distinfo.${LINUX_RPM_ARCH}
PLIST_SUB= GLIBCVER="2.9"
-RPM2CPIO?= ${LOCALBASE}/bin/rpm2cpio
-
-EXTRACT_DEPENDS+= ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
-
EXTRACT_ONLY= ${BIN_DISTFILES}
-EXTRACT_CMD?= ${RPM2CPIO}
-EXTRACT_BEFORE_ARGS?=
-EXTRACT_AFTER_ARGS?= | ${CPIO} -id --quiet
+EXTRACT_CMD?= ${TAR}
+EXTRACT_BEFORE_ARGS?= -xf
+EXTRACT_AFTER_ARGS?=
.include <bsd.port.pre.mk>