aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2009-01-09 08:38:45 +0800
committerlioux <lioux@FreeBSD.org>2009-01-09 08:38:45 +0800
commit9cd57632fcc4e796149c5c6b3085e08a31c933c9 (patch)
tree552b87a1fdcdc3f0c5e85404e918d841941e6426
parent61d9eeb82cea9a8458f88d0ae53f5740a07df26a (diff)
downloadfreebsd-ports-gnome-9cd57632fcc4e796149c5c6b3085e08a31c933c9.tar.gz
freebsd-ports-gnome-9cd57632fcc4e796149c5c6b3085e08a31c933c9.tar.zst
freebsd-ports-gnome-9cd57632fcc4e796149c5c6b3085e08a31c933c9.zip
New port kzip version 20070805: PKZIP-compatible compressor focusing
on space over speed.
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/kzip/Makefile43
-rw-r--r--archivers/kzip/distinfo3
-rw-r--r--archivers/kzip/pkg-descr7
4 files changed, 54 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 6f1ec1855c6a..ee9c76e7548a 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -42,6 +42,7 @@
SUBDIR += jzlib
SUBDIR += kbackup
SUBDIR += kio_p7zip
+ SUBDIR += kzip
SUBDIR += lbrate
SUBDIR += lcab
SUBDIR += lha
diff --git a/archivers/kzip/Makefile b/archivers/kzip/Makefile
new file mode 100644
index 000000000000..c850c9409f31
--- /dev/null
+++ b/archivers/kzip/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: kzip
+# Date created: Thu Jan 8 2009 14:06:34 UTC
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kzip
+DISTVERSION= 20070805
+CATEGORIES= archivers linux
+MASTER_SITES= http://static.jonof.id.au.nyud.net/dl/kenutils/
+DISTNAME= kzipmix-${DISTVERSION}-linux-static
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= PKZIP-compatible compressor focusing on space over speed
+
+NO_CDROM= License does not allow redistribution
+NO_PACKAGE= ${NO_CDROM}
+RESTRICTED= ${NO_CDROM}
+
+ONLY_FOR_ARCHS= i386
+
+USE_LINUX= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/kzipmix-static
+
+FILES= kzip-static
+
+.for file in ${FILES}
+PLIST_FILES+= bin/${file:S/-static$//}
+.endfor
+
+post-extract:
+.for file in ${FILES}
+ @${BRANDELF} -t Linux ${WRKSRC}/${file}
+.endfor
+
+do-install:
+.for file in ${FILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin/${file:S/-static$//}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/archivers/kzip/distinfo b/archivers/kzip/distinfo
new file mode 100644
index 000000000000..a84d2dffb38c
--- /dev/null
+++ b/archivers/kzip/distinfo
@@ -0,0 +1,3 @@
+MD5 (kzipmix-20070805-linux-static.tar.gz) = 35f1c58bbaa90494a8878f1310088673
+SHA256 (kzipmix-20070805-linux-static.tar.gz) = 33d55754a77d5fa83864fa8eb29b56127ed0f5b979ac2189bbb09ed259c80ee1
+SIZE (kzipmix-20070805-linux-static.tar.gz) = 455967
diff --git a/archivers/kzip/pkg-descr b/archivers/kzip/pkg-descr
new file mode 100644
index 000000000000..16565f19f4dc
--- /dev/null
+++ b/archivers/kzip/pkg-descr
@@ -0,0 +1,7 @@
+Linux ports of KZIP and ZIPMIX by Ken Silverman.
+
+A PKZIP-compatible compressor focusing on space over speed. KZIP
+creates smaller .ZIP files than PKZIP with maximum compression
+enabled and even beats 7-Zip most of the time.
+
+WWW: http://www.advsys.net/ken/