aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2011-07-03 23:39:11 +0800
committergerald <gerald@FreeBSD.org>2011-07-03 23:39:11 +0800
commit9e2aeae9e2de0807b14e2dde1c31acad117226ee (patch)
treed1d62cc9bd087ff6e6849be82195a6fe7cb687e6
parentfd21a60add7e4c7064e43f97fdc30d914f01fbae (diff)
downloadfreebsd-ports-gnome-9e2aeae9e2de0807b14e2dde1c31acad117226ee.tar.gz
freebsd-ports-gnome-9e2aeae9e2de0807b14e2dde1c31acad117226ee.tar.zst
freebsd-ports-gnome-9e2aeae9e2de0807b14e2dde1c31acad117226ee.zip
Update to Wine 1.3.22. This includes the following changes:
- Support for Indic text shaping. - Generation of stubless code in the IDL compiler. - Support for X files in D3DX. - 4- and 24-bit bitmap formats in the DIB engine. - Listview performance improvements. - Various bug fixes. No longer set the GNU configure datadir based on our DATADIR. This should enable this port and emulators/wine-gecko to nicely fit together.
-rw-r--r--emulators/wine-devel/Makefile12
-rw-r--r--emulators/wine-devel/distinfo4
-rw-r--r--emulators/wine-devel/pkg-plist99
-rw-r--r--emulators/wine/Makefile12
-rw-r--r--emulators/wine/distinfo4
-rw-r--r--emulators/wine/pkg-plist99
6 files changed, 118 insertions, 112 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index c65eb5ddd974..87e7e06a31ec 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.3.21
+DISTVERSION= 1.3.22
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= emulators
@@ -31,7 +31,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CPPFLAGS= "-I${LOCALBASE}/include"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--datadir=${DATADIR} --verbose --disable-tests \
+CONFIGURE_ARGS+=--verbose --disable-tests \
--with-glu --with-opengl --with-xrandr \
--without-capi --without-gphoto --without-gsm \
--without-mpg123 --with-oss --without-sane \
@@ -134,9 +134,11 @@ post-install:
${MAN1PREFIX}/man/de.UTF-8/man1/wineserver.1 \
${MAN1PREFIX}/man/fr.UTF-8/man1/wine.1 \
${MAN1PREFIX}/man/fr.UTF-8/man1/winemaker.1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1
+ ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1 \
+ ${MAN1PREFIX}/man/pl.UTF-8/man1/wine.1
@-${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8/man1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1
+ ${MAN1PREFIX}/man/fr.UTF-8/man1 \
+ ${MAN1PREFIX}/man/pl.UTF-8/man1
${MV} -f ${WINELIBDIR}/libwine.so.1.0 ${WINELIBDIR}/libwine.so.1
${LN} -sf libwine.so.1 ${WINELIBDIR}/libwine.so
.if !defined(NOPORTDOCS)
@@ -148,8 +150,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${DOCSDIR}/README.winedump
.endif
@${MKDIR} ${DESKTOPDIR}
- ${MV} ${DATADIR}/applications/wine.desktop ${DESKTOPDIR}/
- @${RMDIR} ${DATADIR}/applications
@${ECHO}
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index c76068125406..43fee4a22600 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wine-1.3.21.tar.bz2) = 6c089df0d164c442a5620f7b5eee48ab21fd746a75793731cc3a028b20df57a0
-SIZE (wine-1.3.21.tar.bz2) = 19371426
+SHA256 (wine-1.3.22.tar.bz2) = 87c05c140c7e316f9533f01e888952221880d047be33ca25b4a343c19aa9a586
+SIZE (wine-1.3.22.tar.bz2) = 19393697
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 0d2fc8251701..2d5d2d01b7fa 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -271,6 +271,7 @@ include/wine/windows/exdisp.idl
include/wine/windows/exdispid.h
include/wine/windows/fci.h
include/wine/windows/fdi.h
+include/wine/windows/fltdefs.h
include/wine/windows/fusion.h
include/wine/windows/fusion.idl
include/wine/windows/gameux.h
@@ -303,6 +304,8 @@ include/wine/windows/icftypes.idl
include/wine/windows/icm.h
include/wine/windows/icmpapi.h
include/wine/windows/idispids.h
+include/wine/windows/iextag.h
+include/wine/windows/iextag.idl
include/wine/windows/ifdef.h
include/wine/windows/imagehlp.h
include/wine/windows/imm.h
@@ -1772,60 +1775,60 @@ lib/wine/xinput1_3.dll.so
lib/wine/xinput9_1_0.dll.so
lib/wine/xmllite.dll.so
share/applications/wine.desktop
-%%DATADIR%%/wine/generic.ppd
-%%DATADIR%%/wine/l_intl.nls
-%%DATADIR%%/wine/wine.inf
-%%DATADIR%%/wine/fonts/coue1255.fon
-%%DATADIR%%/wine/fonts/coue1256.fon
-%%DATADIR%%/wine/fonts/coue1257.fon
-%%DATADIR%%/wine/fonts/coure.fon
-%%DATADIR%%/wine/fonts/couree.fon
-%%DATADIR%%/wine/fonts/coureg.fon
-%%DATADIR%%/wine/fonts/courer.fon
-%%DATADIR%%/wine/fonts/couret.fon
-%%DATADIR%%/wine/fonts/cvgasys.fon
-%%DATADIR%%/wine/fonts/hvgasys.fon
-%%DATADIR%%/wine/fonts/jsmalle.fon
-%%DATADIR%%/wine/fonts/jvgasys.fon
-%%DATADIR%%/wine/fonts/marlett.ttf
-%%DATADIR%%/wine/fonts/smae1255.fon
-%%DATADIR%%/wine/fonts/smae1256.fon
-%%DATADIR%%/wine/fonts/smae1257.fon
-%%DATADIR%%/wine/fonts/smalle.fon
-%%DATADIR%%/wine/fonts/smallee.fon
-%%DATADIR%%/wine/fonts/smalleg.fon
-%%DATADIR%%/wine/fonts/smaller.fon
-%%DATADIR%%/wine/fonts/smallet.fon
-%%DATADIR%%/wine/fonts/ssee1255.fon
-%%DATADIR%%/wine/fonts/ssee1256.fon
-%%DATADIR%%/wine/fonts/ssee1257.fon
-%%DATADIR%%/wine/fonts/ssee874.fon
-%%DATADIR%%/wine/fonts/sserife.fon
-%%DATADIR%%/wine/fonts/sserifee.fon
-%%DATADIR%%/wine/fonts/sserifeg.fon
-%%DATADIR%%/wine/fonts/sserifer.fon
-%%DATADIR%%/wine/fonts/sserifet.fon
-%%DATADIR%%/wine/fonts/svgasys.fon
-%%DATADIR%%/wine/fonts/symbol.ttf
-%%DATADIR%%/wine/fonts/tahoma.ttf
-%%DATADIR%%/wine/fonts/tahomabd.ttf
-%%DATADIR%%/wine/fonts/vgas1255.fon
-%%DATADIR%%/wine/fonts/vgas1256.fon
-%%DATADIR%%/wine/fonts/vgas1257.fon
-%%DATADIR%%/wine/fonts/vgas874.fon
-%%DATADIR%%/wine/fonts/vgasys.fon
-%%DATADIR%%/wine/fonts/vgasyse.fon
-%%DATADIR%%/wine/fonts/vgasysg.fon
-%%DATADIR%%/wine/fonts/vgasysr.fon
-%%DATADIR%%/wine/fonts/vgasyst.fon
+%%DATADIR%%/generic.ppd
+%%DATADIR%%/l_intl.nls
+%%DATADIR%%/wine.inf
+%%DATADIR%%/fonts/coue1255.fon
+%%DATADIR%%/fonts/coue1256.fon
+%%DATADIR%%/fonts/coue1257.fon
+%%DATADIR%%/fonts/coure.fon
+%%DATADIR%%/fonts/couree.fon
+%%DATADIR%%/fonts/coureg.fon
+%%DATADIR%%/fonts/courer.fon
+%%DATADIR%%/fonts/couret.fon
+%%DATADIR%%/fonts/cvgasys.fon
+%%DATADIR%%/fonts/hvgasys.fon
+%%DATADIR%%/fonts/jsmalle.fon
+%%DATADIR%%/fonts/jvgasys.fon
+%%DATADIR%%/fonts/marlett.ttf
+%%DATADIR%%/fonts/smae1255.fon
+%%DATADIR%%/fonts/smae1256.fon
+%%DATADIR%%/fonts/smae1257.fon
+%%DATADIR%%/fonts/smalle.fon
+%%DATADIR%%/fonts/smallee.fon
+%%DATADIR%%/fonts/smalleg.fon
+%%DATADIR%%/fonts/smaller.fon
+%%DATADIR%%/fonts/smallet.fon
+%%DATADIR%%/fonts/ssee1255.fon
+%%DATADIR%%/fonts/ssee1256.fon
+%%DATADIR%%/fonts/ssee1257.fon
+%%DATADIR%%/fonts/ssee874.fon
+%%DATADIR%%/fonts/sserife.fon
+%%DATADIR%%/fonts/sserifee.fon
+%%DATADIR%%/fonts/sserifeg.fon
+%%DATADIR%%/fonts/sserifer.fon
+%%DATADIR%%/fonts/sserifet.fon
+%%DATADIR%%/fonts/svgasys.fon
+%%DATADIR%%/fonts/symbol.ttf
+%%DATADIR%%/fonts/tahoma.ttf
+%%DATADIR%%/fonts/tahomabd.ttf
+%%DATADIR%%/fonts/vgas1255.fon
+%%DATADIR%%/fonts/vgas1256.fon
+%%DATADIR%%/fonts/vgas1257.fon
+%%DATADIR%%/fonts/vgas874.fon
+%%DATADIR%%/fonts/vgasys.fon
+%%DATADIR%%/fonts/vgasyse.fon
+%%DATADIR%%/fonts/vgasysg.fon
+%%DATADIR%%/fonts/vgasysr.fon
+%%DATADIR%%/fonts/vgasyst.fon
%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.winedbg
%%PORTDOCS%%%%DOCSDIR%%/README.winedump
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/wine/fonts
-@dirrmtry %%DATADIR%%/wine
+@dirrm %%DATADIR%%/fonts
+@dirrmtry %%DATADIR%%
@dirrmtry %%DATADIR%%/aclocal
@dirrmtry %%DATADIR%%
@dirrmtry share/applications
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index c65eb5ddd974..87e7e06a31ec 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.3.21
+DISTVERSION= 1.3.22
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= emulators
@@ -31,7 +31,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CPPFLAGS= "-I${LOCALBASE}/include"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--datadir=${DATADIR} --verbose --disable-tests \
+CONFIGURE_ARGS+=--verbose --disable-tests \
--with-glu --with-opengl --with-xrandr \
--without-capi --without-gphoto --without-gsm \
--without-mpg123 --with-oss --without-sane \
@@ -134,9 +134,11 @@ post-install:
${MAN1PREFIX}/man/de.UTF-8/man1/wineserver.1 \
${MAN1PREFIX}/man/fr.UTF-8/man1/wine.1 \
${MAN1PREFIX}/man/fr.UTF-8/man1/winemaker.1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1
+ ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1 \
+ ${MAN1PREFIX}/man/pl.UTF-8/man1/wine.1
@-${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8/man1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1
+ ${MAN1PREFIX}/man/fr.UTF-8/man1 \
+ ${MAN1PREFIX}/man/pl.UTF-8/man1
${MV} -f ${WINELIBDIR}/libwine.so.1.0 ${WINELIBDIR}/libwine.so.1
${LN} -sf libwine.so.1 ${WINELIBDIR}/libwine.so
.if !defined(NOPORTDOCS)
@@ -148,8 +150,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${DOCSDIR}/README.winedump
.endif
@${MKDIR} ${DESKTOPDIR}
- ${MV} ${DATADIR}/applications/wine.desktop ${DESKTOPDIR}/
- @${RMDIR} ${DATADIR}/applications
@${ECHO}
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index c76068125406..43fee4a22600 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wine-1.3.21.tar.bz2) = 6c089df0d164c442a5620f7b5eee48ab21fd746a75793731cc3a028b20df57a0
-SIZE (wine-1.3.21.tar.bz2) = 19371426
+SHA256 (wine-1.3.22.tar.bz2) = 87c05c140c7e316f9533f01e888952221880d047be33ca25b4a343c19aa9a586
+SIZE (wine-1.3.22.tar.bz2) = 19393697
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index 0d2fc8251701..2d5d2d01b7fa 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -271,6 +271,7 @@ include/wine/windows/exdisp.idl
include/wine/windows/exdispid.h
include/wine/windows/fci.h
include/wine/windows/fdi.h
+include/wine/windows/fltdefs.h
include/wine/windows/fusion.h
include/wine/windows/fusion.idl
include/wine/windows/gameux.h
@@ -303,6 +304,8 @@ include/wine/windows/icftypes.idl
include/wine/windows/icm.h
include/wine/windows/icmpapi.h
include/wine/windows/idispids.h
+include/wine/windows/iextag.h
+include/wine/windows/iextag.idl
include/wine/windows/ifdef.h
include/wine/windows/imagehlp.h
include/wine/windows/imm.h
@@ -1772,60 +1775,60 @@ lib/wine/xinput1_3.dll.so
lib/wine/xinput9_1_0.dll.so
lib/wine/xmllite.dll.so
share/applications/wine.desktop
-%%DATADIR%%/wine/generic.ppd
-%%DATADIR%%/wine/l_intl.nls
-%%DATADIR%%/wine/wine.inf
-%%DATADIR%%/wine/fonts/coue1255.fon
-%%DATADIR%%/wine/fonts/coue1256.fon
-%%DATADIR%%/wine/fonts/coue1257.fon
-%%DATADIR%%/wine/fonts/coure.fon
-%%DATADIR%%/wine/fonts/couree.fon
-%%DATADIR%%/wine/fonts/coureg.fon
-%%DATADIR%%/wine/fonts/courer.fon
-%%DATADIR%%/wine/fonts/couret.fon
-%%DATADIR%%/wine/fonts/cvgasys.fon
-%%DATADIR%%/wine/fonts/hvgasys.fon
-%%DATADIR%%/wine/fonts/jsmalle.fon
-%%DATADIR%%/wine/fonts/jvgasys.fon
-%%DATADIR%%/wine/fonts/marlett.ttf
-%%DATADIR%%/wine/fonts/smae1255.fon
-%%DATADIR%%/wine/fonts/smae1256.fon
-%%DATADIR%%/wine/fonts/smae1257.fon
-%%DATADIR%%/wine/fonts/smalle.fon
-%%DATADIR%%/wine/fonts/smallee.fon
-%%DATADIR%%/wine/fonts/smalleg.fon
-%%DATADIR%%/wine/fonts/smaller.fon
-%%DATADIR%%/wine/fonts/smallet.fon
-%%DATADIR%%/wine/fonts/ssee1255.fon
-%%DATADIR%%/wine/fonts/ssee1256.fon
-%%DATADIR%%/wine/fonts/ssee1257.fon
-%%DATADIR%%/wine/fonts/ssee874.fon
-%%DATADIR%%/wine/fonts/sserife.fon
-%%DATADIR%%/wine/fonts/sserifee.fon
-%%DATADIR%%/wine/fonts/sserifeg.fon
-%%DATADIR%%/wine/fonts/sserifer.fon
-%%DATADIR%%/wine/fonts/sserifet.fon
-%%DATADIR%%/wine/fonts/svgasys.fon
-%%DATADIR%%/wine/fonts/symbol.ttf
-%%DATADIR%%/wine/fonts/tahoma.ttf
-%%DATADIR%%/wine/fonts/tahomabd.ttf
-%%DATADIR%%/wine/fonts/vgas1255.fon
-%%DATADIR%%/wine/fonts/vgas1256.fon
-%%DATADIR%%/wine/fonts/vgas1257.fon
-%%DATADIR%%/wine/fonts/vgas874.fon
-%%DATADIR%%/wine/fonts/vgasys.fon
-%%DATADIR%%/wine/fonts/vgasyse.fon
-%%DATADIR%%/wine/fonts/vgasysg.fon
-%%DATADIR%%/wine/fonts/vgasysr.fon
-%%DATADIR%%/wine/fonts/vgasyst.fon
+%%DATADIR%%/generic.ppd
+%%DATADIR%%/l_intl.nls
+%%DATADIR%%/wine.inf
+%%DATADIR%%/fonts/coue1255.fon
+%%DATADIR%%/fonts/coue1256.fon
+%%DATADIR%%/fonts/coue1257.fon
+%%DATADIR%%/fonts/coure.fon
+%%DATADIR%%/fonts/couree.fon
+%%DATADIR%%/fonts/coureg.fon
+%%DATADIR%%/fonts/courer.fon
+%%DATADIR%%/fonts/couret.fon
+%%DATADIR%%/fonts/cvgasys.fon
+%%DATADIR%%/fonts/hvgasys.fon
+%%DATADIR%%/fonts/jsmalle.fon
+%%DATADIR%%/fonts/jvgasys.fon
+%%DATADIR%%/fonts/marlett.ttf
+%%DATADIR%%/fonts/smae1255.fon
+%%DATADIR%%/fonts/smae1256.fon
+%%DATADIR%%/fonts/smae1257.fon
+%%DATADIR%%/fonts/smalle.fon
+%%DATADIR%%/fonts/smallee.fon
+%%DATADIR%%/fonts/smalleg.fon
+%%DATADIR%%/fonts/smaller.fon
+%%DATADIR%%/fonts/smallet.fon
+%%DATADIR%%/fonts/ssee1255.fon
+%%DATADIR%%/fonts/ssee1256.fon
+%%DATADIR%%/fonts/ssee1257.fon
+%%DATADIR%%/fonts/ssee874.fon
+%%DATADIR%%/fonts/sserife.fon
+%%DATADIR%%/fonts/sserifee.fon
+%%DATADIR%%/fonts/sserifeg.fon
+%%DATADIR%%/fonts/sserifer.fon
+%%DATADIR%%/fonts/sserifet.fon
+%%DATADIR%%/fonts/svgasys.fon
+%%DATADIR%%/fonts/symbol.ttf
+%%DATADIR%%/fonts/tahoma.ttf
+%%DATADIR%%/fonts/tahomabd.ttf
+%%DATADIR%%/fonts/vgas1255.fon
+%%DATADIR%%/fonts/vgas1256.fon
+%%DATADIR%%/fonts/vgas1257.fon
+%%DATADIR%%/fonts/vgas874.fon
+%%DATADIR%%/fonts/vgasys.fon
+%%DATADIR%%/fonts/vgasyse.fon
+%%DATADIR%%/fonts/vgasysg.fon
+%%DATADIR%%/fonts/vgasysr.fon
+%%DATADIR%%/fonts/vgasyst.fon
%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.winedbg
%%PORTDOCS%%%%DOCSDIR%%/README.winedump
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/wine/fonts
-@dirrmtry %%DATADIR%%/wine
+@dirrm %%DATADIR%%/fonts
+@dirrmtry %%DATADIR%%
@dirrmtry %%DATADIR%%/aclocal
@dirrmtry %%DATADIR%%
@dirrmtry share/applications