aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2013-07-21 19:27:17 +0800
committernox <nox@FreeBSD.org>2013-07-21 19:27:17 +0800
commit9e4d41932efe704cad2836e8052ec36899ca38d6 (patch)
tree266668f8f6f99dc14a22d1e49282582e2fcbba83
parentd553979203398ac601c3724956205e93098d9d4c (diff)
downloadfreebsd-ports-gnome-9e4d41932efe704cad2836e8052ec36899ca38d6.tar.gz
freebsd-ports-gnome-9e4d41932efe704cad2836e8052ec36899ca38d6.tar.zst
freebsd-ports-gnome-9e4d41932efe704cad2836e8052ec36899ca38d6.zip
Set USE_GCC= any on i386 as clang there doesn't like
src/post/deinterlace/plugins/greedy2frame_template_sse2.c . Submitted by: pointyhat via miwi
-rw-r--r--multimedia/libxine/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 9dcc304086b5..8896a721fb0e 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -83,6 +83,20 @@ PATCH_DIST_ARGS= -d ${WRKSRC} -p1 --forward --quiet
.include <bsd.port.options.mk>
+# clang/i386 doesn't like
+# src/post/deinterlace/plugins/greedy2frame_template_sse2.c :
+# [...]
+# ./greedy2frame_template_sse2.c:175:38: error: register %rax is only available in 64-bit mode
+# "movdqa (%3), %%xmm0 \n\t" /* xmm0 = T0 */
+# ^
+#<inline asm>:3:11: note: instantiated into assembly here
+# movdqa (%rax,%esi), %xmm3
+# ^~~~
+# [...]
+.if ${ARCH} == "i386"
+USE_GCC= any
+.endif
+
# Fix build WITH_DEBUG
.if defined(WITH_DEBUG)
DEBUG_FLAGS= -g -O1