aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-12-01 13:30:18 +0800
committerlofi <lofi@FreeBSD.org>2005-12-01 13:30:18 +0800
commit9f975a8f0eb0aeb56449a5a73184519865d64d22 (patch)
treeb20448d9897373de0bc6e32112c3d4d11045568f
parent9bba4d5d3a73850bde869264894ae7d70bc4d0f4 (diff)
downloadfreebsd-ports-gnome-9f975a8f0eb0aeb56449a5a73184519865d64d22.tar.gz
freebsd-ports-gnome-9f975a8f0eb0aeb56449a5a73184519865d64d22.tar.zst
freebsd-ports-gnome-9f975a8f0eb0aeb56449a5a73184519865d64d22.zip
Add a patch to fix KDE Bug 114385 (kdm segfaults on XDMCP request).
-rw-r--r--x11/kde4-baseapps/Makefile1
-rw-r--r--x11/kde4-baseapps/files/patch-kdm_backend-xdmcp.c16
-rw-r--r--x11/kde4-runtime/Makefile1
-rw-r--r--x11/kde4-runtime/files/patch-kdm_backend-xdmcp.c16
-rw-r--r--x11/kde4-workspace/Makefile1
-rw-r--r--x11/kde4-workspace/files/patch-kdm_backend-xdmcp.c16
-rw-r--r--x11/kdebase3/Makefile1
-rw-r--r--x11/kdebase3/files/patch-kdm_backend-xdmcp.c16
-rw-r--r--x11/kdebase4-runtime/Makefile1
-rw-r--r--x11/kdebase4-runtime/files/patch-kdm_backend-xdmcp.c16
-rw-r--r--x11/kdebase4-workspace/Makefile1
-rw-r--r--x11/kdebase4-workspace/files/patch-kdm_backend-xdmcp.c16
-rw-r--r--x11/kdebase4/Makefile1
-rw-r--r--x11/kdebase4/files/patch-kdm_backend-xdmcp.c16
14 files changed, 119 insertions, 0 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index e9dccbcbeb1a..6754486ffd12 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-baseapps/files/patch-kdm_backend-xdmcp.c b/x11/kde4-baseapps/files/patch-kdm_backend-xdmcp.c
new file mode 100644
index 000000000000..79e18a4ea648
--- /dev/null
+++ b/x11/kde4-baseapps/files/patch-kdm_backend-xdmcp.c
@@ -0,0 +1,16 @@
+--- kdm/backend/xdmcp.c 2005/05/04 06:07:06 409205
++++ kdm/backend/xdmcp.c 2005/10/15 09:04:13 470797
+@@ -940,7 +940,12 @@
+ }
+ DisposeProtoDisplay( pdpy );
+ Debug( "starting display %s,%s\n", d->name, d->class2 );
+- StartDisplay( d );
++ if (LoadDisplayResources( d ) < 0) {
++ LogError( "Unable to read configuration for display %s; "
++ "stopping it.\n", d->name );
++ StopDisplay( d );
++ } else
++ StartDisplay( d );
+ CloseGetter();
+ }
+ }
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index e9dccbcbeb1a..6754486ffd12 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-runtime/files/patch-kdm_backend-xdmcp.c b/x11/kde4-runtime/files/patch-kdm_backend-xdmcp.c
new file mode 100644
index 000000000000..79e18a4ea648
--- /dev/null
+++ b/x11/kde4-runtime/files/patch-kdm_backend-xdmcp.c
@@ -0,0 +1,16 @@
+--- kdm/backend/xdmcp.c 2005/05/04 06:07:06 409205
++++ kdm/backend/xdmcp.c 2005/10/15 09:04:13 470797
+@@ -940,7 +940,12 @@
+ }
+ DisposeProtoDisplay( pdpy );
+ Debug( "starting display %s,%s\n", d->name, d->class2 );
+- StartDisplay( d );
++ if (LoadDisplayResources( d ) < 0) {
++ LogError( "Unable to read configuration for display %s; "
++ "stopping it.\n", d->name );
++ StopDisplay( d );
++ } else
++ StartDisplay( d );
+ CloseGetter();
+ }
+ }
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index e9dccbcbeb1a..6754486ffd12 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-workspace/files/patch-kdm_backend-xdmcp.c b/x11/kde4-workspace/files/patch-kdm_backend-xdmcp.c
new file mode 100644
index 000000000000..79e18a4ea648
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kdm_backend-xdmcp.c
@@ -0,0 +1,16 @@
+--- kdm/backend/xdmcp.c 2005/05/04 06:07:06 409205
++++ kdm/backend/xdmcp.c 2005/10/15 09:04:13 470797
+@@ -940,7 +940,12 @@
+ }
+ DisposeProtoDisplay( pdpy );
+ Debug( "starting display %s,%s\n", d->name, d->class2 );
+- StartDisplay( d );
++ if (LoadDisplayResources( d ) < 0) {
++ LogError( "Unable to read configuration for display %s; "
++ "stopping it.\n", d->name );
++ StopDisplay( d );
++ } else
++ StartDisplay( d );
+ CloseGetter();
+ }
+ }
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index e9dccbcbeb1a..6754486ffd12 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase3/files/patch-kdm_backend-xdmcp.c b/x11/kdebase3/files/patch-kdm_backend-xdmcp.c
new file mode 100644
index 000000000000..79e18a4ea648
--- /dev/null
+++ b/x11/kdebase3/files/patch-kdm_backend-xdmcp.c
@@ -0,0 +1,16 @@
+--- kdm/backend/xdmcp.c 2005/05/04 06:07:06 409205
++++ kdm/backend/xdmcp.c 2005/10/15 09:04:13 470797
+@@ -940,7 +940,12 @@
+ }
+ DisposeProtoDisplay( pdpy );
+ Debug( "starting display %s,%s\n", d->name, d->class2 );
+- StartDisplay( d );
++ if (LoadDisplayResources( d ) < 0) {
++ LogError( "Unable to read configuration for display %s; "
++ "stopping it.\n", d->name );
++ StopDisplay( d );
++ } else
++ StartDisplay( d );
+ CloseGetter();
+ }
+ }
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index e9dccbcbeb1a..6754486ffd12 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase4-runtime/files/patch-kdm_backend-xdmcp.c b/x11/kdebase4-runtime/files/patch-kdm_backend-xdmcp.c
new file mode 100644
index 000000000000..79e18a4ea648
--- /dev/null
+++ b/x11/kdebase4-runtime/files/patch-kdm_backend-xdmcp.c
@@ -0,0 +1,16 @@
+--- kdm/backend/xdmcp.c 2005/05/04 06:07:06 409205
++++ kdm/backend/xdmcp.c 2005/10/15 09:04:13 470797
+@@ -940,7 +940,12 @@
+ }
+ DisposeProtoDisplay( pdpy );
+ Debug( "starting display %s,%s\n", d->name, d->class2 );
+- StartDisplay( d );
++ if (LoadDisplayResources( d ) < 0) {
++ LogError( "Unable to read configuration for display %s; "
++ "stopping it.\n", d->name );
++ StopDisplay( d );
++ } else
++ StartDisplay( d );
+ CloseGetter();
+ }
+ }
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index e9dccbcbeb1a..6754486ffd12 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase4-workspace/files/patch-kdm_backend-xdmcp.c b/x11/kdebase4-workspace/files/patch-kdm_backend-xdmcp.c
new file mode 100644
index 000000000000..79e18a4ea648
--- /dev/null
+++ b/x11/kdebase4-workspace/files/patch-kdm_backend-xdmcp.c
@@ -0,0 +1,16 @@
+--- kdm/backend/xdmcp.c 2005/05/04 06:07:06 409205
++++ kdm/backend/xdmcp.c 2005/10/15 09:04:13 470797
+@@ -940,7 +940,12 @@
+ }
+ DisposeProtoDisplay( pdpy );
+ Debug( "starting display %s,%s\n", d->name, d->class2 );
+- StartDisplay( d );
++ if (LoadDisplayResources( d ) < 0) {
++ LogError( "Unable to read configuration for display %s; "
++ "stopping it.\n", d->name );
++ StopDisplay( d );
++ } else
++ StartDisplay( d );
+ CloseGetter();
+ }
+ }
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index e9dccbcbeb1a..6754486ffd12 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase4/files/patch-kdm_backend-xdmcp.c b/x11/kdebase4/files/patch-kdm_backend-xdmcp.c
new file mode 100644
index 000000000000..79e18a4ea648
--- /dev/null
+++ b/x11/kdebase4/files/patch-kdm_backend-xdmcp.c
@@ -0,0 +1,16 @@
+--- kdm/backend/xdmcp.c 2005/05/04 06:07:06 409205
++++ kdm/backend/xdmcp.c 2005/10/15 09:04:13 470797
+@@ -940,7 +940,12 @@
+ }
+ DisposeProtoDisplay( pdpy );
+ Debug( "starting display %s,%s\n", d->name, d->class2 );
+- StartDisplay( d );
++ if (LoadDisplayResources( d ) < 0) {
++ LogError( "Unable to read configuration for display %s; "
++ "stopping it.\n", d->name );
++ StopDisplay( d );
++ } else
++ StartDisplay( d );
+ CloseGetter();
+ }
+ }