aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-11-17 07:30:25 +0800
committerswills <swills@FreeBSD.org>2014-11-17 07:30:25 +0800
commita0123b02e5ce7926ca8c9a133a0a93afc66ef4f9 (patch)
tree03580757369b21ebef1a0631918ec40c63115092
parent80c3a61bef4882d8d70b9d5fd07c1d3563168c8e (diff)
downloadfreebsd-ports-gnome-a0123b02e5ce7926ca8c9a133a0a93afc66ef4f9.tar.gz
freebsd-ports-gnome-a0123b02e5ce7926ca8c9a133a0a93afc66ef4f9.tar.zst
freebsd-ports-gnome-a0123b02e5ce7926ca8c9a133a0a93afc66ef4f9.zip
net/syncthing: update to 0.10.5
-rw-r--r--net/syncthing/Makefile4
-rw-r--r--net/syncthing/distinfo4
-rw-r--r--net/syncthing/files/patch-build.go37
3 files changed, 4 insertions, 41 deletions
diff --git a/net/syncthing/Makefile b/net/syncthing/Makefile
index a9a9aa6e47e9..81aa0aad15f4 100644
--- a/net/syncthing/Makefile
+++ b/net/syncthing/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= syncthing
-PORTVERSION= 0.10.4
+PORTVERSION= 0.10.5
CATEGORIES= net
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/
@@ -26,7 +26,7 @@ post-patch:
do-build:
# timestamp here refers to source, not build time
cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME} ; \
- ${SETENV} GOPATH=${WRKSRC} go run build.go
+ ${SETENV} GOPATH=${WRKSRC} go run build.go -version v${PORTVERSION}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/syncthing \
diff --git a/net/syncthing/distinfo b/net/syncthing/distinfo
index f47bc21fe5bf..362d0860931e 100644
--- a/net/syncthing/distinfo
+++ b/net/syncthing/distinfo
@@ -1,2 +1,2 @@
-SHA256 (syncthing-0.10.4.tar.gz) = aff9a358fd9021254afc5c8ec1fd92618eadf622c9dba240666ff41abba3ec00
-SIZE (syncthing-0.10.4.tar.gz) = 2996470
+SHA256 (syncthing-0.10.5.tar.gz) = adaef4e63916f86f081f68615b740f39a9af08de6d4c5630876665cf229da241
+SIZE (syncthing-0.10.5.tar.gz) = 3013393
diff --git a/net/syncthing/files/patch-build.go b/net/syncthing/files/patch-build.go
deleted file mode 100644
index 92e5db778da6..000000000000
--- a/net/syncthing/files/patch-build.go
+++ /dev/null
@@ -1,37 +0,0 @@
---- build.go.orig 2014-10-24 08:27:14.000000000 +0000
-+++ build.go 2014-10-25 12:42:18.706050568 +0000
-@@ -35,7 +35,6 @@
- "runtime"
- "strconv"
- "strings"
-- "time"
- )
-
- var (
-@@ -302,24 +301,11 @@
- }
-
- func getVersion() string {
-- v, err := runError("git", "describe", "--always", "--dirty")
-- if err != nil {
-- return "unknown-dev"
-- }
-- v = versionRe.ReplaceAllFunc(v, func(s []byte) []byte {
-- s[0] = '+'
-- return s
-- })
-- return string(v)
-+ return string("v0.10.4")
- }
-
- func buildStamp() int64 {
-- bs, err := runError("git", "show", "-s", "--format=%ct")
-- if err != nil {
-- return time.Now().Unix()
-- }
-- s, _ := strconv.ParseInt(string(bs), 10, 64)
-- return s
-+ return 1414418716
- }
-
- func buildUser() string {