aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-05 16:36:14 +0800
committerkris <kris@FreeBSD.org>2004-03-05 16:36:14 +0800
commita111bd2bc78f53eef0b333c119c05b304b755af4 (patch)
treebbbfffa698e6e98c75a80ed575479494aab97214
parentb3e64ba0ff92067d3bdc300adf8fa2aa36d84ff6 (diff)
downloadfreebsd-ports-gnome-a111bd2bc78f53eef0b333c119c05b304b755af4.tar.gz
freebsd-ports-gnome-a111bd2bc78f53eef0b333c119c05b304b755af4.tar.zst
freebsd-ports-gnome-a111bd2bc78f53eef0b333c119c05b304b755af4.zip
BROKEN: Configure fails on !i386 and !alpha
-rw-r--r--devel/libffi-devel/Makefile8
-rw-r--r--devel/libffi/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/devel/libffi-devel/Makefile b/devel/libffi-devel/Makefile
index ed96c25b8f14..d923035e6b4d 100644
--- a/devel/libffi-devel/Makefile
+++ b/devel/libffi-devel/Makefile
@@ -17,4 +17,10 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= # empty
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Configure fails on !i386 and !alpha"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libffi/Makefile b/devel/libffi/Makefile
index ed96c25b8f14..d923035e6b4d 100644
--- a/devel/libffi/Makefile
+++ b/devel/libffi/Makefile
@@ -17,4 +17,10 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= # empty
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Configure fails on !i386 and !alpha"
+.endif
+
+.include <bsd.port.post.mk>