aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-05-05 15:47:27 +0800
committermezz <mezz@FreeBSD.org>2004-05-05 15:47:27 +0800
commita1b51a5f6ff6b640523cf4a13f448d17350a1822 (patch)
treed0994687b9874b5e6031d640a9005050875f14a5
parentcf530537c19dd9ebc570c205ba6f77b3670dfd50 (diff)
downloadfreebsd-ports-gnome-a1b51a5f6ff6b640523cf4a13f448d17350a1822.tar.gz
freebsd-ports-gnome-a1b51a5f6ff6b640523cf4a13f448d17350a1822.tar.zst
freebsd-ports-gnome-a1b51a5f6ff6b640523cf4a13f448d17350a1822.zip
Aop (Ambassador Of Pain) is a curses based arcade game for UNIX with only 64
lines of sourcecode. The goal is to drive the hoovercraft (O) trough the level into the 'at' sign (@) and reach as much points as possible by reducing the number of moves and don't losing any time. Lost lifes (0) can easily be picked up by simply drive over them. WWW: http://aop.raffi.at/ PR: ports/65898 Submitted by: Aaron Zauner <az_mail@gmx.at> Approved by: marcus (backup mentor)
-rw-r--r--games/Makefile1
-rw-r--r--games/aop/Makefile31
-rw-r--r--games/aop/distinfo2
-rw-r--r--games/aop/files/patch-aa11
-rw-r--r--games/aop/pkg-descr10
-rw-r--r--games/aop/pkg-plist16
6 files changed, 71 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 4e9208ab101f..84a0ded1d685 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -30,6 +30,7 @@
SUBDIR += an
SUBDIR += angband
SUBDIR += antipolix
+ SUBDIR += aop
SUBDIR += asc
SUBDIR += atitd
SUBDIR += atlantikdesigner
diff --git a/games/aop/Makefile b/games/aop/Makefile
new file mode 100644
index 000000000000..1dde3fdc4273
--- /dev/null
+++ b/games/aop/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: aop
+# Date created: 22. April 2004
+# Whom: Aaron Zauner <az_mail@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aop
+PORTVERSION= 0.6
+CATEGORIES= games
+MASTER_SITES= http://raffi.at/code/aop/
+
+MAINTAINER= az_mail@gmx.at
+COMMENT= A curses based arcade game with only 64 lines of code
+
+USE_REINPLACE= yes
+DOCS= COPYING README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for ii in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/aop/distinfo b/games/aop/distinfo
new file mode 100644
index 000000000000..bd7daebd07a1
--- /dev/null
+++ b/games/aop/distinfo
@@ -0,0 +1,2 @@
+MD5 (aop-0.6.tar.gz) = 8057b3ec240db608253d653eb692d244
+SIZE (aop-0.6.tar.gz) = 11811
diff --git a/games/aop/files/patch-aa b/games/aop/files/patch-aa
new file mode 100644
index 000000000000..a4c2cb3fc5f1
--- /dev/null
+++ b/games/aop/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile Thu Apr 22 23:03:07 2004
++++ Makefile.orig Thu Apr 22 23:03:03 2004
+@@ -3,6 +3,7 @@
+
+ aop: aop.c
+
++all:
+ install: aop
+ install -d /usr/local/bin
+ install -d /usr/local/share/aop
+
diff --git a/games/aop/pkg-descr b/games/aop/pkg-descr
new file mode 100644
index 000000000000..abce52abec90
--- /dev/null
+++ b/games/aop/pkg-descr
@@ -0,0 +1,10 @@
+Aop (Ambassador Of Pain) is a curses based arcade game for UNIX with only 64
+lines of sourcecode. The goal is to drive the hoovercraft (O) trough the level
+into the 'at' sign (@) and reach as much points as possible by reducing the
+number of moves and don't losing any time. Lost lifes (0) can easily be picked
+up by simply drive over them.
+
+WWW: http://aop.raffi.at/
+
+- Aaron Zauner
+az_mail@gmx.at
diff --git a/games/aop/pkg-plist b/games/aop/pkg-plist
new file mode 100644
index 000000000000..21b75c80fa90
--- /dev/null
+++ b/games/aop/pkg-plist
@@ -0,0 +1,16 @@
+bin/aop
+share/aop/aop-level-01.txt
+share/aop/aop-level-02.txt
+share/aop/aop-level-03.txt
+share/aop/aop-level-04.txt
+share/aop/aop-level-05.txt
+share/aop/aop-level-06.txt
+share/aop/aop-level-07.txt
+share/aop/aop-level-08.txt
+share/aop/aop-level-09.txt
+share/aop/aop-level-10.txt
+share/aop/aop-level-11.txt
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/aop