aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-06-10 02:15:41 +0800
committersem <sem@FreeBSD.org>2005-06-10 02:15:41 +0800
commita24593cd3b934ccd300e4e867e6b354b4d491ffa (patch)
treee05565dea06c61abe60b2742472339ad27befed6
parent31498d487dbc4154713034ec80d7248270b1cdaf (diff)
downloadfreebsd-ports-gnome-a24593cd3b934ccd300e4e867e6b354b4d491ffa.tar.gz
freebsd-ports-gnome-a24593cd3b934ccd300e4e867e6b354b4d491ffa.tar.zst
freebsd-ports-gnome-a24593cd3b934ccd300e4e867e6b354b4d491ffa.zip
Htpdate is an utility to synchronize time using http headers. It can be very
useful in corporate networks, where there is only http proxy, so ntp don't work. PR: ports/82067 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru>
-rw-r--r--net/Makefile1
-rw-r--r--net/htpdate/Makefile29
-rw-r--r--net/htpdate/distinfo2
-rw-r--r--net/htpdate/pkg-descr9
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 704a0bee3d3c..1efe428bf8b9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -226,6 +226,7 @@
SUBDIR += hlmaster
SUBDIR += honeyd
SUBDIR += howl
+ SUBDIR += htpdate
SUBDIR += http_ping
SUBDIR += hx
SUBDIR += i2p
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
new file mode 100644
index 000000000000..aa99b27e91f9
--- /dev/null
+++ b/net/htpdate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: htpdate
+# Date created: 9 Jun 2005
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htpdate
+PORTVERSION= 0.8.1
+CATEGORIES= net
+MASTER_SITES= http://www.clevervest.com/htp/archive/c/
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Time synchronization over http utility
+
+USE_BZIP2= yes
+
+MAN8= htpdate.8
+
+PLIST_FILES= bin/htpdate
+
+post-extract:
+ @${GZIP_CMD} -d ${WRKSRC}/${MAN8}.gz
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/htpdate ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN8} ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/net/htpdate/distinfo b/net/htpdate/distinfo
new file mode 100644
index 000000000000..3e7eef1f1d40
--- /dev/null
+++ b/net/htpdate/distinfo
@@ -0,0 +1,2 @@
+MD5 (htpdate-0.8.1.tar.bz2) = 17e9d66a9eaa4b9bceb5badfed19ce12
+Size (htpdate-0.8.1.tar.bz2) = 10416
diff --git a/net/htpdate/pkg-descr b/net/htpdate/pkg-descr
new file mode 100644
index 000000000000..3f8c4339c00b
--- /dev/null
+++ b/net/htpdate/pkg-descr
@@ -0,0 +1,9 @@
+The HTTP Time Protocol (HTP) is used to synchronize a computer's time
+with web servers as reference time source. Htpdate will synchronize your
+computer's time by extracting timestamps from HTTP headers found
+in web servers responses. Htpdate can be used as a daemon, to keep your
+computer synchronized.
+Accuracy of htpdate is usually better than 0.5 seconds (even better with
+multiple servers). Htpdate can also work through http proxy.
+
+WWW: http://www.clevervest.com/htp/