aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-02-05 21:48:42 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-02-05 21:48:42 +0800
commita3d2e7687f0ea13bd234b5fdbdc2587aa6e656a6 (patch)
tree7cc82f9c20723574ac803fb954ac684efff40298
parent576dd8bfa643e90add157561d8c04acf546cb9f5 (diff)
downloadfreebsd-ports-gnome-a3d2e7687f0ea13bd234b5fdbdc2587aa6e656a6.tar.gz
freebsd-ports-gnome-a3d2e7687f0ea13bd234b5fdbdc2587aa6e656a6.tar.zst
freebsd-ports-gnome-a3d2e7687f0ea13bd234b5fdbdc2587aa6e656a6.zip
This module implements a secure way to encode session data. It is
primarily intended for storing session data in browser cookies, but could be used with other backend storage where security of stored session data is important. WWW: http://search.cpan.org/dist/Session-Storage-Secure/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Session-Storage-Secure/Makefile33
-rw-r--r--www/p5-Session-Storage-Secure/distinfo2
-rw-r--r--www/p5-Session-Storage-Secure/pkg-descr6
-rw-r--r--www/p5-Session-Storage-Secure/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index af1a72e26a7d..ce8eb5df99b9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1162,6 +1162,7 @@
SUBDIR += p5-STF-Dispatcher-PSGI
SUBDIR += p5-SWF-Chart
SUBDIR += p5-Scrappy
+ SUBDIR += p5-Session-Storage-Secure
SUBDIR += p5-Squatting
SUBDIR += p5-Squatting-On-PSGI
SUBDIR += p5-Starlet
diff --git a/www/p5-Session-Storage-Secure/Makefile b/www/p5-Session-Storage-Secure/Makefile
new file mode 100644
index 000000000000..4a2c709ce7ad
--- /dev/null
+++ b/www/p5-Session-Storage-Secure/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= Session-Storage-Secure
+PORTVERSION= 0.005
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DAGOLDEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for encrypted, serialized session data with integrity
+
+RUN_DEPENDS= \
+ p5-Crypt-CBC>0:${PORTSDIR}/security/p5-Crypt-CBC \
+ p5-Crypt-Rijndael>0:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ p5-Crypt-URandom>0:${PORTSDIR}/security/p5-Crypt-URandom \
+ p5-Math-Random-ISAAC-XS>0:${PORTSDIR}/math/p5-Math-Random-ISAAC-XS \
+ p5-Moo>0:${PORTSDIR}/devel/p5-Moo \
+ p5-MooX-Types-MooseLike>0:${PORTSDIR}/devel/p5-MooX-Types-MooseLike \
+ p5-Sereal-Decoder>0:${PORTSDIR}/converters/p5-Sereal-Decoder \
+ p5-Sereal-Encoder>0:${PORTSDIR}/converters/p5-Sereal-Encoder \
+ p5-namespace-clean>0:${PORTSDIR}/devel/p5-namespace-clean
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Test-Deep>0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Number-Tolerant>0:${PORTSDIR}/devel/p5-Number-Tolerant
+
+PERL_CONFIGURE= yes
+
+MAN3= Session::Storage::Secure.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Session-Storage-Secure/distinfo b/www/p5-Session-Storage-Secure/distinfo
new file mode 100644
index 000000000000..9aa26767d543
--- /dev/null
+++ b/www/p5-Session-Storage-Secure/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Session-Storage-Secure-0.005.tar.gz) = c5013dd353ce52921b9d1e1f6935bf4d45e28bc5e57e0977876d0f733996c482
+SIZE (Session-Storage-Secure-0.005.tar.gz) = 19230
diff --git a/www/p5-Session-Storage-Secure/pkg-descr b/www/p5-Session-Storage-Secure/pkg-descr
new file mode 100644
index 000000000000..178c1ca02d6c
--- /dev/null
+++ b/www/p5-Session-Storage-Secure/pkg-descr
@@ -0,0 +1,6 @@
+This module implements a secure way to encode session data. It is
+primarily intended for storing session data in browser cookies, but
+could be used with other backend storage where security of stored
+session data is important.
+
+WWW: http://search.cpan.org/dist/Session-Storage-Secure/
diff --git a/www/p5-Session-Storage-Secure/pkg-plist b/www/p5-Session-Storage-Secure/pkg-plist
new file mode 100644
index 000000000000..131cbebaf9d9
--- /dev/null
+++ b/www/p5-Session-Storage-Secure/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Session/Storage/Secure/.packlist
+%%SITE_PERL%%/Session/Storage/Secure.pm
+@dirrmtry %%SITE_PERL%%/Session/Storage
+@dirrmtry %%SITE_PERL%%/Session
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Session/Storage/Secure
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Session/Storage
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Session