aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-12-05 00:04:25 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-12-05 00:04:25 +0800
commita55cc85903e145eddf3c9d91a70efce197d324fc (patch)
tree9adef991d65376a7c2566ae0bd1548346c000b6e
parentfcbd94ff247a17b8c7b92717f00a9b3600c34e88 (diff)
downloadfreebsd-ports-gnome-a55cc85903e145eddf3c9d91a70efce197d324fc.tar.gz
freebsd-ports-gnome-a55cc85903e145eddf3c9d91a70efce197d324fc.tar.zst
freebsd-ports-gnome-a55cc85903e145eddf3c9d91a70efce197d324fc.zip
- Fix always true conditions
-rw-r--r--emulators/dynamips-devel/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
index f48c8b03ec0a..f5c7e98428f9 100644
--- a/emulators/dynamips-devel/Makefile
+++ b/emulators/dynamips-devel/Makefile
@@ -21,7 +21,8 @@ USES= gmake
ALL_TARGET= ${PORTNAME} nvram_export
MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
- PTHREAD_LIBS=${PTHREAD_LIBS}
+ PTHREAD_LIBS=${PTHREAD_LIBS} \
+ HAS_POSIX_MEMALIGN=1
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/${PORTNAME} bin/nvram_export
@@ -43,19 +44,6 @@ DYNAMIPS_ARCH= "amd64"
DYNAMIPS_ARCH= "nojit"
.endif
-# It required libpcap version 0.9.4 or is higher.
-.if ${OSVERSION} < 700021
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-MAKE_ENV+= PCAP_LIB=${LOCALBASE}/lib/libpcap.a
-#.warning Do not overlook, make libpcap with LIBPCAP_OVERWRITE_BASE parameter, for use with shared library.
-#LIB_DEPENDS+= pcap.\(0.9.\)?[2-9]:${PORTSDIR}/net/libpcap
-#MAKE_ENV+= PCAP_LIB=-lpcap.2
-.endif
-
-.if ${OSVERSION} >= 700013
-MAKE_ENV+= HAS_POSIX_MEMALIGN=1
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/nvram_export ${STAGEDIR}${PREFIX}/bin