aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-24 23:41:52 +0800
committerkrion <krion@FreeBSD.org>2004-06-24 23:41:52 +0800
commita57ccee8002511d1b73033ee6de8ae42a8a02d12 (patch)
tree03121fc0c9020f5d29a77e4677c1c3af8f97b38f
parent8096ba76b0e4bfcc2f74c8b018c66babda99d20f (diff)
downloadfreebsd-ports-gnome-a57ccee8002511d1b73033ee6de8ae42a8a02d12.tar.gz
freebsd-ports-gnome-a57ccee8002511d1b73033ee6de8ae42a8a02d12.tar.zst
freebsd-ports-gnome-a57ccee8002511d1b73033ee6de8ae42a8a02d12.zip
Add beast 0.6.1,
Beast is a powerful music composition and modular synthesis application. It supports a wide range of standards in the field, such as MIDI, WAV/AIFF/MP3/OggVorbis/etc audio files and LADSPA modules. It has excellent technical abilities like multitrack editing, unlimited undo/redo support, real-time synthesis support, 32bit audio rendering, full duplex support, multiprocessor support, precise timing down to sample granularity, on demand loading of partial wave files, on the fly decoding and full scriptability in scheme. The plugins, synthesis core and the user interface are actively being developed and translated into a variety of languages, regularly assimilating user feedback such as from our FeatureRequests page. WWW: http://beast.gtk.org/ PR: ports/68251 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/beast/Makefile46
-rw-r--r--audio/beast/distinfo2
-rw-r--r--audio/beast/files/patch-configure24
-rw-r--r--audio/beast/files/patch-sfi::sfidl.cc11
-rw-r--r--audio/beast/pkg-descr16
-rw-r--r--audio/beast/pkg-plist278
7 files changed, 378 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 81998c14ad31..a8b5683f03a4 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -29,6 +29,7 @@
SUBDIR += autools
SUBDIR += autozen
SUBDIR += baudline
+ SUBDIR += beast
SUBDIR += bebocd
SUBDIR += beep
SUBDIR += bladeenc
diff --git a/audio/beast/Makefile b/audio/beast/Makefile
new file mode 100644
index 000000000000..411e31d82436
--- /dev/null
+++ b/audio/beast/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: BEAST
+# Date created: 23 Jun 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beast
+PORTVERSION= 0.6.1
+CATEGORIES= audio
+MASTER_SITES= ftp://beast.gtk.org/pub/beast/v0.6/ \
+ http://beast.gtk.org/beast-ftp/v0.6/
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A powerful music composition and modular synthesis application
+
+LIB_DEPENDS= vorbisfile:${PORTSDIR}/audio/libvorbis \
+ mad:${PORTSDIR}/audio/libmad \
+ guile:${PORTSDIR}/lang/guile
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GCC= 3.3
+USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomecanvas
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --disable-debug \
+ --enable-osspcm=/dev/dsp \
+ --enable-ossmidi=/dev/midi
+
+MAN1= beast.1 bsesh.1 sfidl.1
+MAN3= beast-gxk.3 bse-procs.3 bse-structs.3 bse.3 sfi.3
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|(bseladspapath=)\$${libdir}/ladspa|\1"${LOCALBASE}/lib/ladspa"|' \
+ -e 's/(FLAGS) (-g.*|-pipe|-O2|-f.*)"/\1"/g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/bse/Makefile.in \
+ ${WRKSRC}/bse/zintern/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/beast/distinfo b/audio/beast/distinfo
new file mode 100644
index 000000000000..5c7248e4d5c3
--- /dev/null
+++ b/audio/beast/distinfo
@@ -0,0 +1,2 @@
+MD5 (beast-0.6.1.tar.gz) = 4c09a330b174d9df2d45a94334f06ff8
+SIZE (beast-0.6.1.tar.gz) = 4591018
diff --git a/audio/beast/files/patch-configure b/audio/beast/files/patch-configure
new file mode 100644
index 000000000000..f059d310df87
--- /dev/null
+++ b/audio/beast/files/patch-configure
@@ -0,0 +1,24 @@
+--- configure.orig Sat Mar 6 18:39:41 2004
++++ configure Wed Jun 23 20:14:12 2004
+@@ -2005,11 +2005,7 @@
+ else
+ DEBUG_FLAGS="-DGTK_NO_CHECK_CASTS"
+ fi fi
+-if test "$cflags_set" = set; then
+- CFLAGS="$CFLAGS -g $DEBUG_FLAGS"
+-else
+- CFLAGS="$DEBUG_FLAGS"
+-fi
++CFLAGS="$CFLAGS $DEBUG_FLAGS"
+
+
+ case "$enable_static" in
+@@ -20267,7 +20263,7 @@
+ if test "x$CATOBJEXT" = "x.mo" ; then
+ beastlocaledir=`eval echo "${libdir}/locale"`
+ else
+- beastlocaledir=`eval echo "${datadir}/locale"`
++ beastlocaledir=`eval echo "${prefix}/share/locale"`
+ fi
+ exec_prefix="$saved_exec_prefix"
+ prefix="$saved_prefix"
diff --git a/audio/beast/files/patch-sfi::sfidl.cc b/audio/beast/files/patch-sfi::sfidl.cc
new file mode 100644
index 000000000000..ecde7d6133dc
--- /dev/null
+++ b/audio/beast/files/patch-sfi::sfidl.cc
@@ -0,0 +1,11 @@
+--- sfi/sfidl.cc.orig Wed Jun 23 17:13:58 2004
++++ sfi/sfidl.cc Wed Jun 23 17:14:18 2004
+@@ -45,7 +45,7 @@
+ return 0;
+ }
+
+- if((argc-optind) != 1)
++ if (argc != 2)
+ {
+ options.printUsage ();
+ return 1;
diff --git a/audio/beast/pkg-descr b/audio/beast/pkg-descr
new file mode 100644
index 000000000000..1657b0941880
--- /dev/null
+++ b/audio/beast/pkg-descr
@@ -0,0 +1,16 @@
+Beast is a powerful music composition and modular synthesis
+application. It supports a wide range of standards in the field, such
+as MIDI, WAV/AIFF/MP3/OggVorbis/etc audio files and LADSPA modules. It
+has excellent technical abilities like multitrack editing, unlimited
+undo/redo support, real-time synthesis support, 32bit audio rendering,
+full duplex support, multiprocessor support, precise timing down to
+sample granularity, on demand loading of partial wave files, on the
+fly decoding and full scriptability in scheme. The plugins, synthesis
+core and the user interface are actively being developed and
+translated into a variety of languages, regularly assimilating user
+feedback such as from our FeatureRequests page.
+
+WWW: http://beast.gtk.org/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/audio/beast/pkg-plist b/audio/beast/pkg-plist
new file mode 100644
index 000000000000..0e75c5b22ed4
--- /dev/null
+++ b/audio/beast/pkg-plist
@@ -0,0 +1,278 @@
+bin/beast
+bin/beast-0.6.1
+bin/bsesh
+bin/bsesh-0.6.1
+bin/sfidl
+include/bse/bse.h
+include/bse/bse.idl
+include/bse/bseamplifier.idl
+include/bse/bsebiquadfilter.h
+include/bse/bsecategories.h
+include/bse/bsecompat.h
+include/bse/bseconfig.h
+include/bse/bseconstant.h
+include/bse/bseconstvalues.h
+include/bse/bsecontainer.h
+include/bse/bsecontextmerger.h
+include/bse/bsecore.idl
+include/bse/bsecsynth.h
+include/bse/bsecxxarg.h
+include/bse/bsecxxbase.h
+include/bse/bsecxxbase.idl
+include/bse/bsecxxclosure.h
+include/bse/bsecxxmodule.h
+include/bse/bsecxxmodule.idl
+include/bse/bsecxxplugin.h
+include/bse/bsecxxutils.h
+include/bse/bsecxxvalue.h
+include/bse/bsedatapocket.h
+include/bse/bsedefs.h
+include/bse/bseeditablesample.h
+include/bse/bseenums.h
+include/bse/bseexports.h
+include/bse/bsegconfig.h
+include/bse/bsegenclosures.h
+include/bse/bsegentypes.h
+include/bse/bseglobals.h
+include/bse/bseglue.h
+include/bse/bsehack.idl
+include/bse/bseincluder.h
+include/bse/bseinstrumentinput.h
+include/bse/bseinstrumentoutput.h
+include/bse/bseitem.h
+include/bse/bsejanitor.h
+include/bse/bseladspa.h
+include/bse/bseladspamodule.h
+include/bse/bsemain.h
+include/bse/bsemath.h
+include/bse/bsemidicontroller.h
+include/bse/bsemididecoder.h
+include/bse/bsemididevice-null.h
+include/bse/bsemididevice-oss.h
+include/bse/bsemididevice.h
+include/bse/bsemidievent.h
+include/bse/bsemidifile.h
+include/bse/bsemidiinput.h
+include/bse/bsemidinotifier.h
+include/bse/bsemidireceiver.h
+include/bse/bsemidisynth.h
+include/bse/bsemidivoice.h
+include/bse/bsenote.h
+include/bse/bseobject.h
+include/bse/bseparam.h
+include/bse/bseparasite.h
+include/bse/bsepart.h
+include/bse/bsepcmdevice-oss.h
+include/bse/bsepcmdevice.h
+include/bse/bsepcminput.h
+include/bse/bsepcmoutput.h
+include/bse/bsepcmwriter.h
+include/bse/bseplugin.h
+include/bse/bseprocedure.h
+include/bse/bseproject.h
+include/bse/bsescripthelper.h
+include/bse/bseserver.h
+include/bse/bsesnet.h
+include/bse/bsesniffer.idl
+include/bse/bsesnooper.h
+include/bse/bsesong.h
+include/bse/bsesource.h
+include/bse/bsessequencer.h
+include/bse/bsestandardosc.h
+include/bse/bsestandardsynths.h
+include/bse/bsestorage.h
+include/bse/bsesubiport.h
+include/bse/bsesuboport.h
+include/bse/bsesubsynth.h
+include/bse/bsesuper.h
+include/bse/bsetrack.h
+include/bse/bsetype.h
+include/bse/bseundostack.h
+include/bse/bseutils.h
+include/bse/bsewave.h
+include/bse/bsewaveosc.h
+include/bse/bsewaverepo.h
+include/bse/gslcommon.h
+include/bse/gslconfig.h
+include/bse/gsldatacache.h
+include/bse/gsldatahandle-mad.h
+include/bse/gsldatahandle-vorbis.h
+include/bse/gsldatahandle.h
+include/bse/gsldatautils.h
+include/bse/gsldefs.h
+include/bse/gslengine.h
+include/bse/gslfft.h
+include/bse/gslfilehash.h
+include/bse/gslfilter.h
+include/bse/gslieee754.h
+include/bse/gslloader.h
+include/bse/gslmagic.h
+include/bse/gslmath.h
+include/bse/gsloscillator.h
+include/bse/gslosctable.h
+include/bse/gslsignal.h
+include/bse/gslvorbis-cutter.h
+include/bse/gslvorbis-enc.h
+include/bse/gslwavechunk.h
+include/bse/gslwaveosc.h
+include/bse/ladspa.h
+include/bsw/bsw.h
+include/bsw/bswgenapi.h
+include/bsw/bswproxy.h
+include/sfi/glib-extra.h
+include/sfi/sfi.h
+include/sfi/sficomport.h
+include/sfi/sficomwire.h
+include/sfi/sficonfig.h
+include/sfi/sficxx.h
+include/sfi/sfifilecrawler.h
+include/sfi/sfiglue.h
+include/sfi/sfigluecodec.h
+include/sfi/sfiglueproxy.h
+include/sfi/sfilog.h
+include/sfi/sfimemory.h
+include/sfi/sfinote.h
+include/sfi/sfiparams.h
+include/sfi/sfiprimitives.h
+include/sfi/sfiserial.h
+include/sfi/sfistore.h
+include/sfi/sfithreads.h
+include/sfi/sfitime.h
+include/sfi/sfitypes.h
+include/sfi/sfiustore.h
+include/sfi/sfivalues.h
+include/sfi/sfivmarshal.h
+lib/bse/v0.6.1/plugins/artscompressor.la
+lib/bse/v0.6.1/plugins/artscompressor.so
+lib/bse/v0.6.1/plugins/bseadder.la
+lib/bse/v0.6.1/plugins/bseadder.so
+lib/bse/v0.6.1/plugins/bseatandistort.la
+lib/bse/v0.6.1/plugins/bseatandistort.so
+lib/bse/v0.6.1/plugins/bsebalance.la
+lib/bse/v0.6.1/plugins/bsebalance.so
+lib/bse/v0.6.1/plugins/bseevaluator.la
+lib/bse/v0.6.1/plugins/bseevaluator.so
+lib/bse/v0.6.1/plugins/bseiirfilter.la
+lib/bse/v0.6.1/plugins/bseiirfilter.so
+lib/bse/v0.6.1/plugins/bsemixer.la
+lib/bse/v0.6.1/plugins/bsemixer.so
+lib/bse/v0.6.1/plugins/bsemult.la
+lib/bse/v0.6.1/plugins/bsemult.so
+lib/bse/v0.6.1/plugins/bsenoise.la
+lib/bse/v0.6.1/plugins/bsenoise.so
+lib/bse/v0.6.1/plugins/bsesequencer.la
+lib/bse/v0.6.1/plugins/bsesequencer.so
+lib/bse/v0.6.1/plugins/bsesimpleadsr.la
+lib/bse/v0.6.1/plugins/bsesimpleadsr.so
+lib/bse/v0.6.1/plugins/davbassfilter.la
+lib/bse/v0.6.1/plugins/davbassfilter.so
+lib/bse/v0.6.1/plugins/davcanyondelay.la
+lib/bse/v0.6.1/plugins/davcanyondelay.so
+lib/bse/v0.6.1/plugins/davchorus.la
+lib/bse/v0.6.1/plugins/davchorus.so
+lib/bse/v0.6.1/plugins/davorgan.la
+lib/bse/v0.6.1/plugins/davorgan.so
+lib/bse/v0.6.1/plugins/davsyndrum.la
+lib/bse/v0.6.1/plugins/davsyndrum.so
+lib/bse/v0.6.1/plugins/davxtalstrings.la
+lib/bse/v0.6.1/plugins/davxtalstrings.so
+lib/bse/v0.6.1/plugins/freeverb.la
+lib/bse/v0.6.1/plugins/freeverb.so
+lib/libbse-0.6.so
+lib/libbse-0.6.so.1
+lib/libbse.la
+lib/libbse.so
+lib/libbsw-0.6.so
+lib/libbsw-0.6.so.1
+lib/libbsw.la
+lib/libbsw.so
+lib/libsfi-0.6.so
+lib/libsfi-0.6.so.1
+lib/libsfi.la
+lib/libsfi.so
+libdata/pkgconfig/bse.pc
+libdata/pkgconfig/sfi.pc
+share/gnome/application-registry/beast.applications
+share/gnome/applications/beast.desktop
+share/gnome/beast/v0.6.1/docs/beast-gxk.3.markup
+share/gnome/beast/v0.6.1/docs/beast-index.markup
+share/gnome/beast/v0.6.1/docs/beast.1.markup
+share/gnome/beast/v0.6.1/docs/bse-procs.3.markup
+share/gnome/beast/v0.6.1/docs/bse-structs.3.markup
+share/gnome/beast/v0.6.1/docs/bse.3.markup
+share/gnome/beast/v0.6.1/docs/bsesh.1.markup
+share/gnome/beast/v0.6.1/docs/engine-mplan.markup
+share/gnome/beast/v0.6.1/docs/faq.markup
+share/gnome/beast/v0.6.1/docs/objdoc.markup
+share/gnome/beast/v0.6.1/docs/plugin-devel.markup
+share/gnome/beast/v0.6.1/docs/quickstart.markup
+share/gnome/beast/v0.6.1/docs/release-news.markup
+share/gnome/beast/v0.6.1/docs/release-notes.markup
+share/gnome/beast/v0.6.1/docs/sfi.3.markup
+share/gnome/beast/v0.6.1/docs/sfidl-manual.markup
+share/gnome/beast/v0.6.1/docs/sfidl.1.markup
+share/gnome/beast/v0.6.1/images/beast-mime.png
+share/gnome/beast/v0.6.1/images/beast-splash.png
+share/gnome/beast/v0.6.1/images/bse-mime.png
+share/gnome/beast/v0.6.1/images/module-voices.png
+share/gnome/beast/v0.6.1/keys/keyrc.de
+share/gnome/beast/v0.6.1/keys/keyrc.us
+share/gnome/beast/v0.6.1/skins/biogreen.skin
+share/gnome/beast/v0.6.1/skins/blueimpress.skin
+share/gnome/beast/v0.6.1/skins/brownforms.skin
+share/gnome/beast/v0.6.1/skins/images/biogreen.jpg
+share/gnome/beast/v0.6.1/skins/images/blueimpress.jpg
+share/gnome/beast/v0.6.1/skins/images/brownforms.jpg
+share/gnome/beast/v0.6.1/skins/images/moonpaper.png
+share/gnome/beast/v0.6.1/skins/images/silvervein.png
+share/gnome/beast/v0.6.1/skins/moonpaper.skin
+share/gnome/beast/v0.6.1/skins/silvervein.skin
+share/gnome/beast/v0.6.1/skins/white.skin
+share/gnome/bse/v0.6.1/demo/partymonster.bse
+share/gnome/bse/v0.6.1/effects/atan-canyon.bse
+share/gnome/bse/v0.6.1/instruments/synth-lead.bse
+share/gnome/bse/v0.6.1/instruments/test-string.bse
+share/gnome/bse/v0.6.1/scripts/bse-scm-glue.boot
+share/gnome/bse/v0.6.1/scripts/modules2grid.scm
+share/gnome/bse/v0.6.1/scripts/part-harmonic-transposer.scm
+share/gnome/bse/v0.6.1/scripts/progressor-example.scm
+share/gnome/bse/v0.6.1/scripts/song-parts-operations.scm
+share/gnome/mime-info/bse.keys
+share/gnome/mime-info/bse.mime
+share/gnome/pixmaps/beast-audio-x-bse.png
+share/gnome/pixmaps/beast.png
+share/locale/az/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/ca/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/cs/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/de/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/el/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/es/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/fr/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/hr/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/mn/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/nl/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/pt/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/ru/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/sq/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/sr/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/sr@Latn/LC_MESSAGES/beast-v0.6.1.mo
+share/locale/sv/LC_MESSAGES/beast-v0.6.1.mo
+@dirrm include/bse
+@dirrm include/bsw
+@dirrm include/sfi
+@dirrm lib/bse/v0.6.1/plugins
+@dirrm lib/bse/v0.6.1
+@dirrm lib/bse
+@dirrm share/gnome/beast/v0.6.1/docs
+@dirrm share/gnome/beast/v0.6.1/images
+@dirrm share/gnome/beast/v0.6.1/keys
+@dirrm share/gnome/beast/v0.6.1/skins/images
+@dirrm share/gnome/beast/v0.6.1/skins
+@dirrm share/gnome/beast/v0.6.1
+@dirrm share/gnome/beast
+@dirrm share/gnome/bse/v0.6.1/demo
+@dirrm share/gnome/bse/v0.6.1/effects
+@dirrm share/gnome/bse/v0.6.1/instruments
+@dirrm share/gnome/bse/v0.6.1/scripts
+@dirrm share/gnome/bse/v0.6.1
+@dirrm share/gnome/bse