aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-27 15:37:12 +0800
committermiwi <miwi@FreeBSD.org>2008-02-27 15:37:12 +0800
commita58fa14afe33d03cbc634035fce0cedf93ba51eb (patch)
tree689002ae023e16fb487373e57fdd44e7295d5100
parent853c3d4d1624d7c37e3c2e4a44b6a67cbd15c533 (diff)
downloadfreebsd-ports-gnome-a58fa14afe33d03cbc634035fce0cedf93ba51eb.tar.gz
freebsd-ports-gnome-a58fa14afe33d03cbc634035fce0cedf93ba51eb.tar.zst
freebsd-ports-gnome-a58fa14afe33d03cbc634035fce0cedf93ba51eb.zip
- Update to 6.1.5
PR: 121091 Submitted by: Ports Fury
-rw-r--r--www/swish++/Makefile6
-rw-r--r--www/swish++/distinfo6
-rw-r--r--www/swish++/files/patch-elements.c11
3 files changed, 5 insertions, 18 deletions
diff --git a/www/swish++/Makefile b/www/swish++/Makefile
index ac94036d2069..6c5cc43b3aee 100644
--- a/www/swish++/Makefile
+++ b/www/swish++/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= swish++
-PORTVERSION= 6.1.4
+PORTVERSION= 6.1.5
CATEGORIES= www textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= swishplusplus
+MASTER_SITES= SF/swishplusplus
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple Web Indexing System for Humans: C++ version
@@ -19,7 +18,6 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_PERL5= yes
USE_GMAKE= yes
-USE_GCC= 3.4+
MAKEFILE= GNUmakefile
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} \
PERL=${PERL} PERL_VER=${PERL_VER}
diff --git a/www/swish++/distinfo b/www/swish++/distinfo
index f0fe8c75ed0b..425890a39bd9 100644
--- a/www/swish++/distinfo
+++ b/www/swish++/distinfo
@@ -1,3 +1,3 @@
-MD5 (swish++-6.1.4.tar.gz) = 08c0eac88e4f08c353037b893e243268
-SHA256 (swish++-6.1.4.tar.gz) = 35e2c3d98a0cfd8c9fac45b7e12d13462e2521f025daac81045e697f403721f7
-SIZE (swish++-6.1.4.tar.gz) = 302123
+MD5 (swish++-6.1.5.tar.gz) = af755e4c7477fd1c05634596d6a9ff00
+SHA256 (swish++-6.1.5.tar.gz) = 497b7d1f5dada146b74d82f787a1767a3713402e018b1e693cb7f6191db88d86
+SIZE (swish++-6.1.5.tar.gz) = 320082
diff --git a/www/swish++/files/patch-elements.c b/www/swish++/files/patch-elements.c
deleted file mode 100644
index ab3bd53c87e5..000000000000
--- a/www/swish++/files/patch-elements.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mod/html/elements.c.orig 2007-07-31 20:12:01.000000000 +0200
-+++ mod/html/elements.c 2007-07-31 20:12:22.000000000 +0200
-@@ -295,7 +295,7 @@
- // become overly pedantic about casting to enums.
- //
- element::end_tag_type const
-- v = (element::end_tag_type const)(int const)(p[1]);
-+ v = (element::end_tag_type const)(intptr_t const)(p[1]);
- element &e = insert( value_type( *p++, element( v ) ) ).first->second;
-
- switch ( v ) {