aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-24 23:21:21 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-24 23:21:21 +0800
commita630ea3db2c8679ce8b2797370b4de3ad784a10c (patch)
tree7f3d1507be8332be476ecf1ca824632313cea356
parent236a914a7e8e6c669261ed6b079476974c73f92f (diff)
downloadfreebsd-ports-gnome-a630ea3db2c8679ce8b2797370b4de3ad784a10c.tar.gz
freebsd-ports-gnome-a630ea3db2c8679ce8b2797370b4de3ad784a10c.tar.zst
freebsd-ports-gnome-a630ea3db2c8679ce8b2797370b4de3ad784a10c.zip
Support staging
-rw-r--r--net/tcping/Makefile14
-rw-r--r--net/tcping/pkg-plist3
2 files changed, 7 insertions, 10 deletions
diff --git a/net/tcping/Makefile b/net/tcping/Makefile
index 1404ae36cdb7..b9732287cd4e 100644
--- a/net/tcping/Makefile
+++ b/net/tcping/Makefile
@@ -10,18 +10,18 @@ MASTER_SITES= http://www.linuxco.de/tcping/ \
MAINTAINER= dryice@dryice.name
COMMENT= Do a TCP connect to the given IP/port combination
-DOCS= README
+PLIST_FILES= bin/tcping
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -DHAVE_HSTRERROR -o tcping tcping.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/tcping ${PREFIX}/bin/tcping
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcping ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net/tcping/pkg-plist b/net/tcping/pkg-plist
deleted file mode 100644
index c7d9a9b1a837..000000000000
--- a/net/tcping/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/tcping
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%