aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-22 09:10:14 +0800
committeraaron <aaron@FreeBSD.org>2006-05-22 09:10:14 +0800
commita6842437ec10b9d14fc0f633f17918b12fec8e40 (patch)
treeb783cad35a4a3ff0794d4410d255a57e7b990e78
parent408e122329a2683ed3131dd5f4e33e93199f9fef (diff)
downloadfreebsd-ports-gnome-a6842437ec10b9d14fc0f633f17918b12fec8e40.tar.gz
freebsd-ports-gnome-a6842437ec10b9d14fc0f633f17918b12fec8e40.tar.zst
freebsd-ports-gnome-a6842437ec10b9d14fc0f633f17918b12fec8e40.zip
Adding port security/p5-Authen-Simple-LDAP, LDAP and ActiveDirectory extension to security/p5-Authen-Simple.
Approved by: tobez (implicit)
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-Simple-LDAP/Makefile32
-rw-r--r--security/p5-Authen-Simple-LDAP/distinfo3
-rw-r--r--security/p5-Authen-Simple-LDAP/pkg-descr4
-rw-r--r--security/p5-Authen-Simple-LDAP/pkg-plist4
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5c34dc949191..a9f690a85e12 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -291,6 +291,7 @@
SUBDIR += p5-Authen-SASL
SUBDIR += p5-Authen-SASL-Cyrus
SUBDIR += p5-Authen-Simple
+ SUBDIR += p5-Authen-Simple-LDAP
SUBDIR += p5-Authen-Smb
SUBDIR += p5-Authen-TacacsPlus
SUBDIR += p5-Authen-Ticket
diff --git a/security/p5-Authen-Simple-LDAP/Makefile b/security/p5-Authen-Simple-LDAP/Makefile
new file mode 100644
index 000000000000..0cb6ef18a97d
--- /dev/null
+++ b/security/p5-Authen-Simple-LDAP/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Authen-Simple-LDAP
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-LDAP
+PORTVERSION= 0.2
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple LDAP authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
+ ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::LDAP.3 Authen::Simple::ActiveDirectory.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple-LDAP/distinfo b/security/p5-Authen-Simple-LDAP/distinfo
new file mode 100644
index 000000000000..486a4ab01493
--- /dev/null
+++ b/security/p5-Authen-Simple-LDAP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-LDAP-0.2.tar.gz) = d9340d8a39b1ef58b3882c6b88362fa3
+SHA256 (Authen-Simple-LDAP-0.2.tar.gz) = 85b0ab52cbc8419c08d096ff625a7cddd8b36bd16095a4f3ae0dc42373d766a0
+SIZE (Authen-Simple-LDAP-0.2.tar.gz) = 4328
diff --git a/security/p5-Authen-Simple-LDAP/pkg-descr b/security/p5-Authen-Simple-LDAP/pkg-descr
new file mode 100644
index 000000000000..762c35cdd947
--- /dev/null
+++ b/security/p5-Authen-Simple-LDAP/pkg-descr
@@ -0,0 +1,4 @@
+Authenticate against an LDAP service.
+
+WWW: http://search.cpan.org/dist/Authen-Simple-LDAP
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple-LDAP/pkg-plist b/security/p5-Authen-Simple-LDAP/pkg-plist
new file mode 100644
index 000000000000..fbc37b3cfde6
--- /dev/null
+++ b/security/p5-Authen-Simple-LDAP/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Authen/Simple/ActiveDirectory.pm
+%%SITE_PERL%%/Authen/Simple/LDAP.pm
+@dirrmtry %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen