aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-06-21 02:02:18 +0800
committerahze <ahze@FreeBSD.org>2005-06-21 02:02:18 +0800
commita6fe3949d508c812750e17a97ca97eeffd7a7485 (patch)
tree19941e23cf202dcc0d389d603c4138574a455f15
parenta2e50fef8932772bf8350ec2ae0e9bdcd28b0038 (diff)
downloadfreebsd-ports-gnome-a6fe3949d508c812750e17a97ca97eeffd7a7485.tar.gz
freebsd-ports-gnome-a6fe3949d508c812750e17a97ca97eeffd7a7485.tar.zst
freebsd-ports-gnome-a6fe3949d508c812750e17a97ca97eeffd7a7485.zip
Add unzoo , a zoo archive extractor.
PR: ports/82449 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/unzoo/Makefile35
-rw-r--r--archivers/unzoo/distinfo2
-rw-r--r--archivers/unzoo/pkg-descr8
4 files changed, 46 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 65bf90ac0d07..b801ff839b9c 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -102,6 +102,7 @@
SUBDIR += unshield
SUBDIR += untar
SUBDIR += unzip
+ SUBDIR += unzoo
SUBDIR += upx
SUBDIR += wzip
SUBDIR += xdms
diff --git a/archivers/unzoo/Makefile b/archivers/unzoo/Makefile
new file mode 100644
index 000000000000..71ebd0fe3e00
--- /dev/null
+++ b/archivers/unzoo/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: unzoo
+# Date created: 20 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unzoo
+DISTVERSION= 4.4
+CATEGORIES= archivers
+MASTER_SITES= http://critical.ch/unzoo/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A zoo archive extractor
+
+EXTRA_DEFINES= -DSYS_IS_UNIX -DSYS_HAS_MKDIR
+
+PLIST_FILES= bin/unzoo
+
+MAN1= unzoo.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+CFLAGS+= -trigraphs
+.endif
+
+do-build:
+ ${CC} ${CFLAGS} ${EXTRA_DEFINES} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/archivers/unzoo/distinfo b/archivers/unzoo/distinfo
new file mode 100644
index 000000000000..fae68430daec
--- /dev/null
+++ b/archivers/unzoo/distinfo
@@ -0,0 +1,2 @@
+MD5 (unzoo-4.4.tar.gz) = 2e73c26188688033b7c2b6c7da32ad39
+SIZE (unzoo-4.4.tar.gz) = 26842
diff --git a/archivers/unzoo/pkg-descr b/archivers/unzoo/pkg-descr
new file mode 100644
index 000000000000..026c53a5cc3e
--- /dev/null
+++ b/archivers/unzoo/pkg-descr
@@ -0,0 +1,8 @@
+Unzoo is a zoo archive extractor written by Martin Schoenert. If unzoo is
+called with no arguments, it will first print a summary of the commands and
+then prompt for command lines interactively.
+
+WWW: http://archives.math.utk.edu/
+
+- ehaupt
+ehaupt@critical.ch