aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-11-01 01:31:43 +0800
committeralepulver <alepulver@FreeBSD.org>2006-11-01 01:31:43 +0800
commita7502c576f5feb85baeeb42ed007c33fea9d99ca (patch)
tree8d6b9579f2fbe63a8f330c51e4c862c04b857038
parentbbb4c67780fe69fce28e3896ed62127a3e054225 (diff)
downloadfreebsd-ports-gnome-a7502c576f5feb85baeeb42ed007c33fea9d99ca.tar.gz
freebsd-ports-gnome-a7502c576f5feb85baeeb42ed007c33fea9d99ca.tar.zst
freebsd-ports-gnome-a7502c576f5feb85baeeb42ed007c33fea9d99ca.zip
Qt3 bindings for the D-BUS interprocess messaging system.
WWW: http://www.freedesktop.org/wiki/Software_2fDBusBindings PR: ports/104547 Submitted by: Maxim Samsonov <xors at sendmail.ru>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/dbus-qt3/Makefile31
-rw-r--r--devel/dbus-qt3/distinfo3
-rw-r--r--devel/dbus-qt3/pkg-descr3
-rw-r--r--devel/dbus-qt3/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index beafaad07f93..d0c788cef447 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -220,6 +220,7 @@
SUBDIR += datadesigner
SUBDIR += dbus
SUBDIR += dbus-glib
+ SUBDIR += dbus-qt3
SUBDIR += dbus-sharp
SUBDIR += ddd
SUBDIR += desktop-file-utils
diff --git a/devel/dbus-qt3/Makefile b/devel/dbus-qt3/Makefile
new file mode 100644
index 000000000000..52aa6fc892cb
--- /dev/null
+++ b/devel/dbus-qt3/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: dbus-qt3
+# Date created: 2006-10-18
+# Whom: Maxim Samsonov <xors@sendmail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbus
+PORTVERSION= 0.70
+CATEGORIES= devel kde
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+PKGNAMESUFFIX= -qt3
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= xors@sendmail.ru
+COMMENT= Qt3 bindings for the D-BUS messaging system
+
+LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus \
+ qt-mt:${PORTSDIR}/x11-toolkits/qt33
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ENV= QTDIR=${X11BASE} CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+PLIST_SUB= VERSION="1.0"
+
+.include <bsd.port.mk>
diff --git a/devel/dbus-qt3/distinfo b/devel/dbus-qt3/distinfo
new file mode 100644
index 000000000000..775058454047
--- /dev/null
+++ b/devel/dbus-qt3/distinfo
@@ -0,0 +1,3 @@
+MD5 (dbus-qt3-0.70.tar.bz2) = 9a8d4a4d560b49fb5ad034abfd3e3db5
+SHA256 (dbus-qt3-0.70.tar.bz2) = d86531f106f8172a635d57ef35b7856cb54885c50f175bd1bff374c0e5a5f5ed
+SIZE (dbus-qt3-0.70.tar.bz2) = 220305
diff --git a/devel/dbus-qt3/pkg-descr b/devel/dbus-qt3/pkg-descr
new file mode 100644
index 000000000000..665080ecf95f
--- /dev/null
+++ b/devel/dbus-qt3/pkg-descr
@@ -0,0 +1,3 @@
+Qt3 bindings for the D-BUS interprocess messaging system.
+
+WWW: http://www.freedesktop.org/wiki/Software_2fDBusBindings
diff --git a/devel/dbus-qt3/pkg-plist b/devel/dbus-qt3/pkg-plist
new file mode 100644
index 000000000000..9fc66062c3ec
--- /dev/null
+++ b/devel/dbus-qt3/pkg-plist
@@ -0,0 +1,8 @@
+include/dbus-%%VERSION%%/dbus/connection.h
+include/dbus-%%VERSION%%/dbus/dbus-qt.h
+include/dbus-%%VERSION%%/dbus/message.h
+include/dbus-%%VERSION%%/dbus/server.h
+lib/libdbus-qt-1.a
+lib/libdbus-qt-1.la
+lib/libdbus-qt-1.so
+lib/libdbus-qt-1.so.1