aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2006-09-21 10:24:31 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2006-09-21 10:24:31 +0800
commita7832c3595e659f5b88b3a9386a0124302a77e4e (patch)
treea2b6b3962097177d7fa804d081143d3df8ec38f1
parente62cecc79e324770c15a65dc38c5d74ea74a9f70 (diff)
downloadfreebsd-ports-gnome-a7832c3595e659f5b88b3a9386a0124302a77e4e.tar.gz
freebsd-ports-gnome-a7832c3595e659f5b88b3a9386a0124302a77e4e.tar.zst
freebsd-ports-gnome-a7832c3595e659f5b88b3a9386a0124302a77e4e.zip
Fix build with latest firefox
Notified by: krismail
-rw-r--r--net/blam/Makefile3
-rw-r--r--net/blam/files/extra-libblam_blam-gecko-utils.cpp11
2 files changed, 14 insertions, 0 deletions
diff --git a/net/blam/Makefile b/net/blam/Makefile
index 36d634569ac7..503fb2f24db9 100644
--- a/net/blam/Makefile
+++ b/net/blam/Makefile
@@ -36,4 +36,7 @@ GCONF_SCHEMAS= blam.schemas
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+.if ${GECKO}!="mozilla"
+EXTRA_PATCHES+= ${PATCHDIR}/extra-libblam_blam-gecko-utils.cpp
+.endif
.include <bsd.port.post.mk>
diff --git a/net/blam/files/extra-libblam_blam-gecko-utils.cpp b/net/blam/files/extra-libblam_blam-gecko-utils.cpp
new file mode 100644
index 000000000000..a9c81ae1978e
--- /dev/null
+++ b/net/blam/files/extra-libblam_blam-gecko-utils.cpp
@@ -0,0 +1,11 @@
+--- libblam/blam-gecko-utils.cpp.orig Fri May 6 04:07:49 2005
++++ libblam/blam-gecko-utils.cpp Wed Sep 20 19:15:58 2006
+@@ -29,6 +29,8 @@
+ #include <nsEmbedString.h>
+ #include <nsIPrefService.h>
+ #include <nsIServiceManager.h>
++#include <nsServiceManagerUtils.h>
++#include <nsCOMPtr.h>
+
+ #if defined (HAVE_CHROME_NSICHROMEREGISTRYSEA_H)
+ #include <chrome/nsIChromeRegistrySea.h>