aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-11-21 22:56:44 +0800
committermiwi <miwi@FreeBSD.org>2007-11-21 22:56:44 +0800
commita8088458d4f2f97157bc026571acbd831e69909f (patch)
tree73f8c02ddac5486778093c0c020c67785db91c9f
parent2729d2ee5d1aba27906cb640f7cf270a5a6fd4cb (diff)
downloadfreebsd-ports-gnome-a8088458d4f2f97157bc026571acbd831e69909f.tar.gz
freebsd-ports-gnome-a8088458d4f2f97157bc026571acbd831e69909f.tar.zst
freebsd-ports-gnome-a8088458d4f2f97157bc026571acbd831e69909f.zip
- Fix build with gcc 4.2
PR: 118084 Submitted by: Pietro Cerutti <gahr@gahr.ch> Approved by: portmgr (pav)
-rw-r--r--graphics/gltt/Makefile8
-rw-r--r--graphics/gltt/files/patch-GLTTGlyphPolygonizerHandler.h10
2 files changed, 11 insertions, 7 deletions
diff --git a/graphics/gltt/Makefile b/graphics/gltt/Makefile
index 47ff3d3b0082..ae6e297460d1 100644
--- a/graphics/gltt/Makefile
+++ b/graphics/gltt/Makefile
@@ -32,10 +32,4 @@ CONFIGURE_ARGS= --with-ttf-includes=${LOCALBASE}/include/freetype1 \
--with-glut-libraries=${X11BASE}/lib
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/gltt/files/patch-GLTTGlyphPolygonizerHandler.h b/graphics/gltt/files/patch-GLTTGlyphPolygonizerHandler.h
new file mode 100644
index 000000000000..7b0ec1051f96
--- /dev/null
+++ b/graphics/gltt/files/patch-GLTTGlyphPolygonizerHandler.h
@@ -0,0 +1,10 @@
+--- GLTTGlyphPolygonizerHandler.h.orig 2007-11-16 11:59:00.000000000 +0100
++++ GLTTGlyphPolygonizerHandler.h 2007-11-16 11:59:58.000000000 +0100
+@@ -28,6 +28,7 @@
+ #include "FTGlyphVectorizer.h"
+ #endif
+
++class GLTTGlyphPolygonizer;
+ /////////////////////////////////////////////////////////////////////////////
+
+ // Mmh, this class name is a bit long... /SR