aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-02-26 00:38:59 +0800
committerade <ade@FreeBSD.org>2000-02-26 00:38:59 +0800
commita9be9f3e46739ccb73d6b8512453f1f70eb00af3 (patch)
tree1584f37a38d0d80322b1cb49f69edf9b8627806f
parent528370885f38fdeac95a5714de9fc2858b60ce35 (diff)
downloadfreebsd-ports-gnome-a9be9f3e46739ccb73d6b8512453f1f70eb00af3.tar.gz
freebsd-ports-gnome-a9be9f3e46739ccb73d6b8512453f1f70eb00af3.tar.zst
freebsd-ports-gnome-a9be9f3e46739ccb73d6b8512453f1f70eb00af3.zip
p5-Net-IPv4Addr provides functions to parse IPv4 addresses both
in traditional address/netmask format and in the new CIDR format. Methods for calculating the network and broadcast address, and also to check if a given address is in a specific network also exist. PR: 16984 Submitted by: Brad Hendrickse <bradh@uunet.co.za>
-rw-r--r--net-mgmt/p5-Net-IPv4Addr/Makefile26
-rw-r--r--net-mgmt/p5-Net-IPv4Addr/distinfo1
-rw-r--r--net-mgmt/p5-Net-IPv4Addr/pkg-comment1
-rw-r--r--net-mgmt/p5-Net-IPv4Addr/pkg-descr10
-rw-r--r--net-mgmt/p5-Net-IPv4Addr/pkg-plist5
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-IPv4Addr/Makefile26
-rw-r--r--net/p5-Net-IPv4Addr/distinfo1
-rw-r--r--net/p5-Net-IPv4Addr/pkg-comment1
-rw-r--r--net/p5-Net-IPv4Addr/pkg-descr10
-rw-r--r--net/p5-Net-IPv4Addr/pkg-plist5
11 files changed, 87 insertions, 0 deletions
diff --git a/net-mgmt/p5-Net-IPv4Addr/Makefile b/net-mgmt/p5-Net-IPv4Addr/Makefile
new file mode 100644
index 000000000000..84681174a0c2
--- /dev/null
+++ b/net-mgmt/p5-Net-IPv4Addr/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-IPv4Addr
+# Version required: 0.08
+# Date created: 25 February 2000
+# Whom: Brad Hendrickse <bradh@uunet.co.za>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Net-IPv4Addr-0.08
+PKGNAME= p5-Net-IPv4Addr-0.08
+CATEGORIES= net perl5
+# not using CPAN due to them messing up the filename and version numbers
+MASTER_SITES= http://indev.insu.com/sources/
+
+MAINTAINER= bradh@uunet.co.za
+
+USE_PERL5= yes
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN1= ipv4calc.1
+MAN3= Net::IPv4Addr.3
+
+do-configure:
+
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Net-IPv4Addr/distinfo b/net-mgmt/p5-Net-IPv4Addr/distinfo
new file mode 100644
index 000000000000..de43ba0e5e0a
--- /dev/null
+++ b/net-mgmt/p5-Net-IPv4Addr/distinfo
@@ -0,0 +1 @@
+MD5 (Net-IPv4Addr-0.08.tar.gz) = e8600b1d64b8dc3e5edc34ac7e197f21
diff --git a/net-mgmt/p5-Net-IPv4Addr/pkg-comment b/net-mgmt/p5-Net-IPv4Addr/pkg-comment
new file mode 100644
index 000000000000..c8377d484065
--- /dev/null
+++ b/net-mgmt/p5-Net-IPv4Addr/pkg-comment
@@ -0,0 +1 @@
+Perl extension for manipulating IPv4 addresses
diff --git a/net-mgmt/p5-Net-IPv4Addr/pkg-descr b/net-mgmt/p5-Net-IPv4Addr/pkg-descr
new file mode 100644
index 000000000000..e65ca924a6c6
--- /dev/null
+++ b/net-mgmt/p5-Net-IPv4Addr/pkg-descr
@@ -0,0 +1,10 @@
+Net::IPv4Addr provides functions to parse IPv4 addresses both
+in traditional address/netmask format and in the new CIDR format.
+Methods for calculating the network and broadcast address, and
+also to check if a given address is in a specific network also exist.
+
+WWW: http://indev.insu.com/
+
+--
+Brad Hendrickse
+bradh@uunet.co.za
diff --git a/net-mgmt/p5-Net-IPv4Addr/pkg-plist b/net-mgmt/p5-Net-IPv4Addr/pkg-plist
new file mode 100644
index 000000000000..997cbc3786b3
--- /dev/null
+++ b/net-mgmt/p5-Net-IPv4Addr/pkg-plist
@@ -0,0 +1,5 @@
+bin/ipv4calc
+lib/perl5/site_perl/%%PERL_VER%%/Net/IPv4Addr.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/IPv4Addr/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/IPv4Addr/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/IPv4Addr
diff --git a/net/Makefile b/net/Makefile
index a0214a653ded..02b32c8594ab 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -133,6 +133,7 @@
SUBDIR += p5-Archie
SUBDIR += p5-Net
SUBDIR += p5-Net-DNS
+ SUBDIR += p5-Net-IPv4Addr
SUBDIR += p5-Net-RawIP
SUBDIR += p5-Net-Telnet
SUBDIR += p5-Net-Whois
diff --git a/net/p5-Net-IPv4Addr/Makefile b/net/p5-Net-IPv4Addr/Makefile
new file mode 100644
index 000000000000..84681174a0c2
--- /dev/null
+++ b/net/p5-Net-IPv4Addr/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-IPv4Addr
+# Version required: 0.08
+# Date created: 25 February 2000
+# Whom: Brad Hendrickse <bradh@uunet.co.za>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Net-IPv4Addr-0.08
+PKGNAME= p5-Net-IPv4Addr-0.08
+CATEGORIES= net perl5
+# not using CPAN due to them messing up the filename and version numbers
+MASTER_SITES= http://indev.insu.com/sources/
+
+MAINTAINER= bradh@uunet.co.za
+
+USE_PERL5= yes
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN1= ipv4calc.1
+MAN3= Net::IPv4Addr.3
+
+do-configure:
+
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-IPv4Addr/distinfo b/net/p5-Net-IPv4Addr/distinfo
new file mode 100644
index 000000000000..de43ba0e5e0a
--- /dev/null
+++ b/net/p5-Net-IPv4Addr/distinfo
@@ -0,0 +1 @@
+MD5 (Net-IPv4Addr-0.08.tar.gz) = e8600b1d64b8dc3e5edc34ac7e197f21
diff --git a/net/p5-Net-IPv4Addr/pkg-comment b/net/p5-Net-IPv4Addr/pkg-comment
new file mode 100644
index 000000000000..c8377d484065
--- /dev/null
+++ b/net/p5-Net-IPv4Addr/pkg-comment
@@ -0,0 +1 @@
+Perl extension for manipulating IPv4 addresses
diff --git a/net/p5-Net-IPv4Addr/pkg-descr b/net/p5-Net-IPv4Addr/pkg-descr
new file mode 100644
index 000000000000..e65ca924a6c6
--- /dev/null
+++ b/net/p5-Net-IPv4Addr/pkg-descr
@@ -0,0 +1,10 @@
+Net::IPv4Addr provides functions to parse IPv4 addresses both
+in traditional address/netmask format and in the new CIDR format.
+Methods for calculating the network and broadcast address, and
+also to check if a given address is in a specific network also exist.
+
+WWW: http://indev.insu.com/
+
+--
+Brad Hendrickse
+bradh@uunet.co.za
diff --git a/net/p5-Net-IPv4Addr/pkg-plist b/net/p5-Net-IPv4Addr/pkg-plist
new file mode 100644
index 000000000000..997cbc3786b3
--- /dev/null
+++ b/net/p5-Net-IPv4Addr/pkg-plist
@@ -0,0 +1,5 @@
+bin/ipv4calc
+lib/perl5/site_perl/%%PERL_VER%%/Net/IPv4Addr.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/IPv4Addr/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/IPv4Addr/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/IPv4Addr