aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-10-07 20:27:42 +0800
committermiwi <miwi@FreeBSD.org>2006-10-07 20:27:42 +0800
commitab3e4b1cd20f77b9be21ba43122471f4ac7186b9 (patch)
tree3181977590bdfca3a4c86eed974aa087a3e45a83
parent7e51896fa8416e80218c6bc8f14f274d63ac5d1e (diff)
downloadfreebsd-ports-gnome-ab3e4b1cd20f77b9be21ba43122471f4ac7186b9.tar.gz
freebsd-ports-gnome-ab3e4b1cd20f77b9be21ba43122471f4ac7186b9.tar.zst
freebsd-ports-gnome-ab3e4b1cd20f77b9be21ba43122471f4ac7186b9.zip
- Fix build with gcc41
PR: ports/104078 Submitted by: trasz
-rw-r--r--graphics/Coin/Makefile4
-rw-r--r--graphics/Coin/distinfo6
-rw-r--r--graphics/Coin/files/patch-configure15
-rw-r--r--graphics/Coin/pkg-plist6
4 files changed, 26 insertions, 5 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index 996b84235411..f0d31309e7e7 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= Coin
-PORTVERSION= 2.4.4
-PORTREVISION= 1
+PORTVERSION= 2.4.5
CATEGORIES= graphics
MASTER_SITES= http://ftp.coin3d.org/coin/src/all/ \
ftp://ftp.coin3d.org/pub/coin/src/all/
@@ -24,6 +23,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-pthread=yes --enable-threadsafe \
--enable-3ds-import --enable-sound
USE_LDCONFIG= yes
+MAKE_ENV= LANG=C
MAN1= coin-config.1
diff --git a/graphics/Coin/distinfo b/graphics/Coin/distinfo
index b066e329867d..7cc7cee28572 100644
--- a/graphics/Coin/distinfo
+++ b/graphics/Coin/distinfo
@@ -1,3 +1,3 @@
-MD5 (Coin-2.4.4.tar.gz) = 7976fcf2d1154bc8574d75b99bab45ee
-SHA256 (Coin-2.4.4.tar.gz) = 398a04c7e5ea6ab9ff1c1ca304edb25c7aeb457872e9546ac2d3476e63e9c589
-SIZE (Coin-2.4.4.tar.gz) = 3784368
+MD5 (Coin-2.4.5.tar.gz) = 99b83c5189c3755fd5f08fcad0994a7b
+SHA256 (Coin-2.4.5.tar.gz) = fc8d7c03b21cd9f12f396d36af35a4bc88aa412b84e671c495a8e3f46fefd4f8
+SIZE (Coin-2.4.5.tar.gz) = 4721898
diff --git a/graphics/Coin/files/patch-configure b/graphics/Coin/files/patch-configure
new file mode 100644
index 000000000000..654d6fad96fb
--- /dev/null
+++ b/graphics/Coin/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig Fri Oct 6 23:42:10 2006
++++ configure Fri Oct 6 23:42:13 2006
+@@ -28865,9 +28865,9 @@
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+
+-cat >>confdefs.h <<\_ACEOF
+-#define HAVE__DUP 1
+-_ACEOF
++#cat >>confdefs.h <<\_ACEOF
++##define HAVE__DUP 1
++#_ACEOF
+
+
+ else
diff --git a/graphics/Coin/pkg-plist b/graphics/Coin/pkg-plist
index bb36e40f6370..34bb2fae8925 100644
--- a/graphics/Coin/pkg-plist
+++ b/graphics/Coin/pkg-plist
@@ -85,6 +85,8 @@ include/Inventor/SoPickedPoint.h
include/Inventor/SoPrimitiveVertex.h
include/Inventor/SoSceneManager.h
include/Inventor/SoType.h
+include/Inventor/oivwin32.h
+include/Inventor/non_winsys.h
include/Inventor/VRMLnodes/SoVRML.h
include/Inventor/VRMLnodes/SoVRMLAnchor.h
include/Inventor/VRMLnodes/SoVRMLAppearance.h
@@ -168,7 +170,9 @@ include/Inventor/actions/SoHandleEventAction.h
include/Inventor/actions/SoLineHighlightRenderAction.h
include/Inventor/actions/SoPickAction.h
include/Inventor/actions/SoRayPickAction.h
+include/Inventor/actions/SoReorganizeAction.h
include/Inventor/actions/SoSearchAction.h
+include/Inventor/actions/SoSimplifyAction.h
include/Inventor/actions/SoSubAction.h
include/Inventor/actions/SoToVRML2Action.h
include/Inventor/actions/SoToVRMLAction.h
@@ -281,6 +285,7 @@ include/Inventor/elements/SoGLTextureEnabledElement.h
include/Inventor/elements/SoGLTextureImageElement.h
include/Inventor/elements/SoGLTextureMatrixElement.h
include/Inventor/elements/SoGLUpdateAreaElement.h
+include/Inventor/elements/SoGLVBOElement.h
include/Inventor/elements/SoGLViewingMatrixElement.h
include/Inventor/elements/SoGLViewportRegionElement.h
include/Inventor/elements/SoInt32Element.h
@@ -421,6 +426,7 @@ include/Inventor/fields/SoMFVec4f.h
include/Inventor/fields/SoMField.h
include/Inventor/fields/SoSFBitMask.h
include/Inventor/fields/SoSFBool.h
+include/Inventor/fields/SoSFBox3f.h
include/Inventor/fields/SoSFBox3s.h
include/Inventor/fields/SoSFColor.h
include/Inventor/fields/SoSFEngine.h