aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-03-08 10:22:52 +0800
committerclsung <clsung@FreeBSD.org>2007-03-08 10:22:52 +0800
commitac4463d8117943c7f7fb7c30a78ea6e35bd421e9 (patch)
treeeff5bacaa7bcc166ac4ca2f81e4871375f16e363
parent51df2afb0a4118da15f234c1af5947b28b73207b (diff)
downloadfreebsd-ports-gnome-ac4463d8117943c7f7fb7c30a78ea6e35bd421e9.tar.gz
freebsd-ports-gnome-ac4463d8117943c7f7fb7c30a78ea6e35bd421e9.tar.zst
freebsd-ports-gnome-ac4463d8117943c7f7fb7c30a78ea6e35bd421e9.zip
Add py-funkload 1.6.0, funkLoad is a functional and load web tester.
PR: ports/109779 Submitted by: Li-Wen Hsu <lwhsu at lwhsu.org>
-rw-r--r--www/Makefile1
-rw-r--r--www/py-funkload/Makefile54
-rw-r--r--www/py-funkload/distinfo3
-rw-r--r--www/py-funkload/files/patch-setup.py11
-rw-r--r--www/py-funkload/pkg-descr15
-rw-r--r--www/py-funkload/pkg-plist39
6 files changed, 123 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index aa3cc85d1ada..a34cb0208ab4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -952,6 +952,7 @@
SUBDIR += py-flup
SUBDIR += py-forgethtml
SUBDIR += py-formencode
+ SUBDIR += py-funkload
SUBDIR += py-htmltestcase
SUBDIR += py-imdbpy
SUBDIR += py-jonpy
diff --git a/www/py-funkload/Makefile b/www/py-funkload/Makefile
new file mode 100644
index 000000000000..b0f3862873d4
--- /dev/null
+++ b/www/py-funkload/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: py-funkload
+# Date created: Mar. 03, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= funkload
+PORTVERSION= 1.6.0
+CATEGORIES= www python
+MASTER_SITES= http://funkload.nuxeo.org/ \
+ http://cheeseshop.python.org/packages/source/f/funkload/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= FunkLoad is a functional and load web tester
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools \
+ ${PYTHON_SITELIBDIR}/docutils/__init__.py:${PORTSDIR}/textproc/py-docutils \
+ ${PYTHON_SITELIBDIR}/gdchart.so:${PORTSDIR}/graphics/py-gdchart \
+ ${PYTHON_SITELIBDIR}/webunit/__init__.py:${PORTSDIR}/www/py-webunit \
+ ${PYXML} \
+ tcpwatch.py:${PORTSDIR}/net/tcpwatch
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+
+PYDISTUTILS_BUILD_TARGET= bdist_egg
+PYDISTUTILS_INSTALL_TARGET= easy_install
+PYDISTUTILS_INSTALLARGS= -O 1 -N -S ${PYTHON_SITELIBDIR} ${WRKSRC}/dist/${PYFUNKLOAD_EGG}
+
+PYFUNKLOAD_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+PLIST_SUB+= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PYFUNKLOAD_EGG=${PYFUNKLOAD_EGG} \
+ PYFUNKLOAD_EGG_VER="${PORTNAME}==${PORTVERSION}"
+
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${TARGETDIR}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/funkload/demo ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/www/py-funkload/distinfo b/www/py-funkload/distinfo
new file mode 100644
index 000000000000..561bc9dcf53c
--- /dev/null
+++ b/www/py-funkload/distinfo
@@ -0,0 +1,3 @@
+MD5 (funkload-1.6.0.tar.gz) = dbc4e568db2f20a1c1bca918a450e153
+SHA256 (funkload-1.6.0.tar.gz) = dca7bffd990fe83144c651e7a623cb685cf11513a67d4a05b3a98c6f6c192509
+SIZE (funkload-1.6.0.tar.gz) = 96725
diff --git a/www/py-funkload/files/patch-setup.py b/www/py-funkload/files/patch-setup.py
new file mode 100644
index 000000000000..18320f2ab1bc
--- /dev/null
+++ b/www/py-funkload/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Sat Mar 3 12:15:17 2007
++++ setup.py Sat Mar 3 12:15:24 2007
+@@ -135,8 +135,6 @@
+ 'Topic :: System :: Monitoring',
+ ],
+ # setuptools specific keywords
+- install_requires = ['webunit == 1.3.8',
+- 'docutils >= 0.3.7'],
+ zip_safe=True,
+ package_data={'funkload': ['data/*',
+ 'demo/simple/*', 'demo/zope/*',
diff --git a/www/py-funkload/pkg-descr b/www/py-funkload/pkg-descr
new file mode 100644
index 000000000000..11e8f182afbf
--- /dev/null
+++ b/www/py-funkload/pkg-descr
@@ -0,0 +1,15 @@
+FunkLoad is a functional and load web tester, written in Python,
+whose main use cases are:
+
+* Functional testing of web projects, and thus regression testing as well.
+* Performance testing: by loading the web application and monitoring your
+ servers it helps you to pinpoint bottlenecks, giving a detailed report of
+ performance measurement.
+* Load testing tool to expose bugs that do not surface in cursory testing,
+ like volume testing or longevity testing.
+* Stress testing tool to overwhelm the web application resources and test the
+ application recoverability.
+* Writing web agents by scripting any web repetitive task, like checking if
+ a site is alive.
+
+WWW: http://funkload.nuxeo.org/
diff --git a/www/py-funkload/pkg-plist b/www/py-funkload/pkg-plist
new file mode 100644
index 000000000000..c8ea4032727e
--- /dev/null
+++ b/www/py-funkload/pkg-plist
@@ -0,0 +1,39 @@
+@unexec %%EASY_INSTALL_CMD%% -q -m -S %D/%%PYTHON_SITELIBDIR%% %%PYFUNKLOAD_EGG_VER%%
+%%PYTHON_SITELIBDIR%%/%%PYFUNKLOAD_EGG%%
+@exec %%EASY_INSTALL_CMD%% -q -N -S %D/%%PYTHON_SITELIBDIR%% %%PYFUNKLOAD_EGG_VER%%
+bin/fl-build-report
+bin/fl-credential-ctl
+bin/fl-import-from-tm-recorder
+bin/fl-install-demo
+bin/fl-monitor-ctl
+bin/fl-record
+bin/fl-run-bench
+bin/fl-run-test
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/demo/README.txt
+%%EXAMPLESDIR%%/demo/cmf/Cmf.conf
+%%EXAMPLESDIR%%/demo/cmf/README.txt
+%%EXAMPLESDIR%%/demo/cmf/credential.conf
+%%EXAMPLESDIR%%/demo/cmf/groups.txt
+%%EXAMPLESDIR%%/demo/cmf/passwords.txt
+%%EXAMPLESDIR%%/demo/cmf/test_Cmf.py
+%%EXAMPLESDIR%%/demo/simple/README.txt
+%%EXAMPLESDIR%%/demo/simple/Simple.conf
+%%EXAMPLESDIR%%/demo/simple/monitor.conf
+%%EXAMPLESDIR%%/demo/simple/test_Simple.py
+%%EXAMPLESDIR%%/demo/xmlrpc/Credential.conf
+%%EXAMPLESDIR%%/demo/xmlrpc/Makefile
+%%EXAMPLESDIR%%/demo/xmlrpc/README.txt
+%%EXAMPLESDIR%%/demo/xmlrpc/cred.conf
+%%EXAMPLESDIR%%/demo/xmlrpc/monitor.conf
+%%EXAMPLESDIR%%/demo/xmlrpc/test_Credential.py
+%%EXAMPLESDIR%%/demo/zope/README.txt
+%%EXAMPLESDIR%%/demo/zope/Zope.conf
+%%EXAMPLESDIR%%/demo/zope/test_Zope.py
+@dirrm %%EXAMPLESDIR%%/demo/zope
+@dirrm %%EXAMPLESDIR%%/demo/xmlrpc
+@dirrm %%EXAMPLESDIR%%/demo/simple
+@dirrm %%EXAMPLESDIR%%/demo/cmf
+@dirrm %%EXAMPLESDIR%%/demo
+@dirrm %%EXAMPLESDIR%%