aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-10-27 09:58:39 +0800
committermarcus <marcus@FreeBSD.org>2003-10-27 09:58:39 +0800
commitac952d7c6e492708dd92846c6e3ce5327056f29b (patch)
treef4236655925642f0eb144b2593a152351985bc5d
parent4b1c9b7823a8d2694d60e04aff3dc9d892b0a87a (diff)
downloadfreebsd-ports-gnome-ac952d7c6e492708dd92846c6e3ce5327056f29b.tar.gz
freebsd-ports-gnome-ac952d7c6e492708dd92846c6e3ce5327056f29b.tar.zst
freebsd-ports-gnome-ac952d7c6e492708dd92846c6e3ce5327056f29b.zip
Recognize .ifndef(NOPORTDOCS) as well as .if !defined(NOPORTDOCS).
Reported by: kris
-rw-r--r--devel/portlint/Makefile1
-rw-r--r--devel/portlint/src/portlint.pl5
-rw-r--r--ports-mgmt/portlint/Makefile1
-rw-r--r--ports-mgmt/portlint/src/portlint.pl5
4 files changed, 8 insertions, 4 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index 7699bd3b4e6c..06b2435281aa 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -9,6 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.4.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/devel/portlint/src/portlint.pl b/devel/portlint/src/portlint.pl
index af650b73252b..8b320ffb29bd 100644
--- a/devel/portlint/src/portlint.pl
+++ b/devel/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.18 2003/10/26 21:24:08 marcus Exp $
+# $Id: portlint.pl,v 1.19 2003/10/27 01:57:35 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -903,7 +903,8 @@ sub checkmakefile {
if ($whole =~ /NOPORTSDOC/) {
&perror("WARN: NOPORTSDOC found. Do you mean NOPORTDOCS?");
}
- if ($sharedocused && $whole !~ /defined\(NOPORTDOCS\)/
+ if ($sharedocused && $whole !~ /defined\s*\(NOPORTDOCS\)/
+ && $whole !~ /def\s*\(NOPORTDOCS\)/
&& $whole !~ m#(\$[\{\(]PREFIX[\}\)]|$localbase)/share/doc#) {
&perror("WARN: use \".if !defined(NOPORTDOCS)\" to wrap ".
"installation of files into $localbase/share/doc.");
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 7699bd3b4e6c..06b2435281aa 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -9,6 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.4.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index af650b73252b..8b320ffb29bd 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.18 2003/10/26 21:24:08 marcus Exp $
+# $Id: portlint.pl,v 1.19 2003/10/27 01:57:35 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -903,7 +903,8 @@ sub checkmakefile {
if ($whole =~ /NOPORTSDOC/) {
&perror("WARN: NOPORTSDOC found. Do you mean NOPORTDOCS?");
}
- if ($sharedocused && $whole !~ /defined\(NOPORTDOCS\)/
+ if ($sharedocused && $whole !~ /defined\s*\(NOPORTDOCS\)/
+ && $whole !~ /def\s*\(NOPORTDOCS\)/
&& $whole !~ m#(\$[\{\(]PREFIX[\}\)]|$localbase)/share/doc#) {
&perror("WARN: use \".if !defined(NOPORTDOCS)\" to wrap ".
"installation of files into $localbase/share/doc.");