aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-02-02 20:34:09 +0800
committerkoobs <koobs@FreeBSD.org>2016-02-02 20:34:09 +0800
commitaeb7cbaa7598661b081ccbcad6bf0e26d5e8996e (patch)
tree622cf2a3c48c9828757df539b2457b1cdd8b0e56
parent02949fbab64471fc0af9021ee537eb5ed9ab2e37 (diff)
downloadfreebsd-ports-gnome-aeb7cbaa7598661b081ccbcad6bf0e26d5e8996e.tar.gz
freebsd-ports-gnome-aeb7cbaa7598661b081ccbcad6bf0e26d5e8996e.tar.zst
freebsd-ports-gnome-aeb7cbaa7598661b081ccbcad6bf0e26d5e8996e.zip
security/py-{letsencrypt,acme}: Update to 0.3.0
Common: - Update PORTVERSION and distinfo checksum (0.3.0) [1] - Use PORTVERSION over DISTVERSION (not necessary at the moment) - Update dependency entries to match those in setup.py - match minimum versions, remove version if not specified there - requests has been removed from letsencrypt, acme depends on it py-letsecnrypt: - Remove setup.py patch (upstreamed) [1] py-acme: - Enable NO_ARCH PR: 206397 Submitted by: pkubaj@anongoth.pl [1] Reviewed by: cpm (maintainer, acme) Approved by: cpm (maintainer, acme)
-rw-r--r--security/py-acme/Makefile12
-rw-r--r--security/py-acme/distinfo4
-rw-r--r--security/py-letsencrypt/Makefile11
-rw-r--r--security/py-letsencrypt/distinfo4
-rw-r--r--security/py-letsencrypt/files/patch-setup.py11
5 files changed, 16 insertions, 26 deletions
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index aca789001cf0..ebf9b381fe3a 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= acme
-DISTVERSION= 0.1.0
+PORTVERSION= 0.3.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,17 +14,19 @@ LICENSE= APACHE20
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>0:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:${PORTSDIR}/security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}ndg_httpsclient>0:${PORTSDIR}/net/py-ndg_httpsclient \
${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock \
- ${PYTHON_PKGNAMEPREFIX}ndg_httpsclient>=0.4.0:${PORTSDIR}/net/py-ndg_httpsclient \
- ${PYTHON_PKGNAMEPREFIX}pyrfc3339>=0.2:${PORTSDIR}/devel/py-pyrfc3339 \
- ${PYTHON_PKGNAMEPREFIX}pytz>=2015.4:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:${PORTSDIR}/devel/py-pyrfc3339 \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
${PYTHON_PKGNAMEPREFIX}six>=1.9.0:${PORTSDIR}/devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}werkzeug>=0.9:${PORTSDIR}/www/py-werkzeug
+ ${PYTHON_PKGNAMEPREFIX}werkzeug>0:${PORTSDIR}/www/py-werkzeug
USES= gmake python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/security/py-acme/distinfo b/security/py-acme/distinfo
index de57931e6eff..f8b8a62b6e88 100644
--- a/security/py-acme/distinfo
+++ b/security/py-acme/distinfo
@@ -1,2 +1,2 @@
-SHA256 (acme-0.1.0.tar.gz) = c3ebbfecd1f787ef6e309ddcc412c65d0eea318d00d0aff610bdb7ff09a8403a
-SIZE (acme-0.1.0.tar.gz) = 82880
+SHA256 (acme-0.3.0.tar.gz) = 7cd1568a28fa5717c6e68eeede835bb6b60a438abdbe1cce2c04dfc4d968cef4
+SIZE (acme-0.3.0.tar.gz) = 87416
diff --git a/security/py-letsencrypt/Makefile b/security/py-letsencrypt/Makefile
index 5271f26c03b8..c9525555333f 100644
--- a/security/py-letsencrypt/Makefile
+++ b/security/py-letsencrypt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= letsencrypt
-DISTVERSION= 0.1.0
+PORTVERSION= 0.3.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,17 +13,16 @@ COMMENT= Let's Encrypt client
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/acme/__init__.py:${PORTSDIR}/security/py-acme \
- ${PYTHON_PKGNAMEPREFIX}configargparse>0:${PORTSDIR}/devel/py-configargparse \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme==${PORTVERSION}:${PORTSDIR}/security/py-acme \
+ ${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:${PORTSDIR}/devel/py-configargparse \
${PYTHON_PKGNAMEPREFIX}configobj>0:${PORTSDIR}/devel/py-configobj \
${PYTHON_PKGNAMEPREFIX}cryptography>=0.7:${PORTSDIR}/security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}parsedatetime>0:${PORTSDIR}/devel/py-parsedatetime \
- ${PYTHON_PKGNAMEPREFIX}psutil>0:${PORTSDIR}/sysutils/py-psutil \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=2.1.0:${PORTSDIR}/sysutils/py-psutil \
${PYTHON_PKGNAMEPREFIX}openssl>0:${PORTSDIR}/security/py-openssl \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:${PORTSDIR}/devel/py-pyrfc3339 \
- ${PYTHON_PKGNAMEPREFIX}python2-pythondialog>0:${PORTSDIR}/devel/py-python2-pythondialog \
+ ${PYTHON_PKGNAMEPREFIX}python2-pythondialog>=3.2.2r1:${PORTSDIR}/devel/py-python2-pythondialog \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
${PYTHON_PKGNAMEPREFIX}zope.component>0:${PORTSDIR}/devel/py-zope.component \
${PYTHON_PKGNAMEPREFIX}zope.interface>0:${PORTSDIR}/devel/py-zope.interface
diff --git a/security/py-letsencrypt/distinfo b/security/py-letsencrypt/distinfo
index 4452ae67dae4..8d6712ba510c 100644
--- a/security/py-letsencrypt/distinfo
+++ b/security/py-letsencrypt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (letsencrypt-0.1.0.tar.gz) = 81f6276176d254b7cf5f95b564700bc71f12b11034d4020389ca4c317e3769fd
-SIZE (letsencrypt-0.1.0.tar.gz) = 167375
+SHA256 (letsencrypt-0.3.0.tar.gz) = 10b58968736f05922a54f2589256bcc972ed5c8b9a9aa01fe9ffd5005bf5e949
+SIZE (letsencrypt-0.3.0.tar.gz) = 169828
diff --git a/security/py-letsencrypt/files/patch-setup.py b/security/py-letsencrypt/files/patch-setup.py
deleted file mode 100644
index 9302c271fddf..000000000000
--- a/security/py-letsencrypt/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2015-11-04 07:35:05 UTC
-+++ setup.py
-@@ -118,8 +118,6 @@ setup(
- 'docs': docs_extras,
- 'testing': testing_extras,
- },
--
-- tests_require=install_requires,
- # to test all packages run "python setup.py test -s
- # {acme,letsencrypt_apache,letsencrypt_nginx}"
- test_suite='letsencrypt',