aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-08-17 17:49:02 +0800
committersobomax <sobomax@FreeBSD.org>2000-08-17 17:49:02 +0800
commitaefee2de28a933e044904059debb663177a2c15c (patch)
tree36fc1443de987a8ce45cfdf33a68465ab2ad3dfb
parent6656bd852556f636e78355d5bdfa642844151536 (diff)
downloadfreebsd-ports-gnome-aefee2de28a933e044904059debb663177a2c15c.tar.gz
freebsd-ports-gnome-aefee2de28a933e044904059debb663177a2c15c.tar.zst
freebsd-ports-gnome-aefee2de28a933e044904059debb663177a2c15c.zip
Update to 0.7.2.
Now the port uses mozilla-embedded port for html rendering by default, but you can override it by defining WITH_FULL_MOZILLA (for example if you are planning to use both mozilla and galeon on the same machine). WARNING! This port requires M17 to work.
-rw-r--r--www/galeon/Makefile26
-rw-r--r--www/galeon/distinfo2
-rw-r--r--www/galeon/files/patch-ab8
-rw-r--r--www/galeon/pkg-plist16
-rw-r--r--www/galeon2/Makefile26
-rw-r--r--www/galeon2/distinfo2
-rw-r--r--www/galeon2/files/patch-ab8
-rw-r--r--www/galeon2/pkg-plist16
8 files changed, 84 insertions, 20 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 3ab307e5bfe8..5e99d7ed99b0 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -6,18 +6,24 @@
#
PORTNAME= galeon
-PORTVERSION= 0.7.1
+PORTVERSION= 0.7.2
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/mozilla:build
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/${MOZILLA}:build
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
glade.4:${PORTSDIR}/devel/libglade
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
- mozilla:${PORTSDIR}/www/mozilla
+ ${X11BASE}/lib/${MOZILLA}:${PORTSDIR}/www/${MOZILLA}
+
+.if !defined(WITH_FULL_MOZILLA)
+MOZILLA= mozilla-embedded
+.else
+MOZILLA= mozilla
+.endif
USE_X_PREFIX= yes
USE_NEWGCC= yes
@@ -36,6 +42,15 @@ CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(WITH_FULL_MOZILLA)
+post-extract:
+ @${ECHO_MSG}
+ @${ECHO_MSG} " By default the port uses mozilla-embedded for html rendering, but if you are"
+ @${ECHO_MSG} " planning to use both Mozilla and Galeon you can instruct it to use mozilla by"
+ @${ECHO_MSG} " defining \"WITH_FULL_MOZILLA\"."
+ @${ECHO_MSG}
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -44,9 +59,10 @@ pre-patch:
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
s|-lpthread|-pthread|g'
-post-patch:
+post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/src/galeon
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%MOZILLA%%|${MOZILLA}|g' ${WRKSRC}/src/galeon
.include <bsd.port.mk>
diff --git a/www/galeon/distinfo b/www/galeon/distinfo
index c322cb1767a4..f3bb1d653e04 100644
--- a/www/galeon/distinfo
+++ b/www/galeon/distinfo
@@ -1 +1 @@
-MD5 (galeon-0.7.1.tar.gz) = d21f940a1fcf385d3dc2a512a7435ed7
+MD5 (galeon-0.7.2.tar.gz) = 279e2123cd747eaf8097ab1d901ac510
diff --git a/www/galeon/files/patch-ab b/www/galeon/files/patch-ab
index 157f691ec8ab..10e821dbedd6 100644
--- a/www/galeon/files/patch-ab
+++ b/www/galeon/files/patch-ab
@@ -14,10 +14,10 @@
- MOZILLA_HOME=/usr/local/mozilla
-elif [ -f /usr/lib/mozilla/libgtkembedmoz.so ]; then
- MOZILLA_HOME=/usr/lib/mozilla
-+elif [ -f %%LOCALBASE%%/lib/mozilla/libgtkembedmoz.so ]; then
-+ MOZILLA_HOME=%%LOCALBASE%%/lib/mozilla
-+elif [ -f %%X11BASE%%/lib/mozilla/libgtkembedmoz.so ]; then
-+ MOZILLA_HOME=%%X11BASE%%/lib/mozilla
++elif [ -f %%LOCALBASE%%/lib/%%MOZILLA%%/libgtkembedmoz.so ]; then
++ MOZILLA_HOME=%%LOCALBASE%%/lib/%%MOZILLA%%
++elif [ -f %%X11BASE%%/lib/%%MOZILLA%%/libgtkembedmoz.so ]; then
++ MOZILLA_HOME=%%X11BASE%%/lib/%%MOZILLA%%
else
echo "Cannot find mozilla installation directory. Please set MOZILLA_FIVE_HOME to your mozilla directory"
exit
diff --git a/www/galeon/pkg-plist b/www/galeon/pkg-plist
index a180f4ef4bd8..26ee789ce5ca 100644
--- a/www/galeon/pkg-plist
+++ b/www/galeon/pkg-plist
@@ -1,6 +1,20 @@
bin/galeon
bin/galeon-bin
share/gnome/apps/Internet/galeon.desktop
+share/gnome/galeon/anim_01.png
+share/gnome/galeon/anim_02.png
+share/gnome/galeon/anim_03.png
+share/gnome/galeon/anim_04.png
+share/gnome/galeon/anim_05.png
+share/gnome/galeon/anim_06.png
+share/gnome/galeon/anim_07.png
+share/gnome/galeon/anim_08.png
+share/gnome/galeon/anim_09.png
+share/gnome/galeon/anim_10.png
+share/gnome/galeon/anim_11.png
+share/gnome/galeon/anim_12.png
+share/gnome/galeon/anim_13.png
+share/gnome/galeon/anim_14.png
share/gnome/galeon/bookmarks.xml
share/gnome/galeon/galeon.glade
share/gnome/galeon/logo.png
@@ -8,6 +22,7 @@ share/gnome/galeon/preferences.xml
share/gnome/pixmaps/galeon.png
share/gnome/pixmaps/galeon/logo.jpg
share/locale/da/LC_MESSAGES/galeon.mo
+share/locale/de/LC_MESSAGES/galeon.mo
share/locale/es/LC_MESSAGES/galeon.mo
share/locale/et/LC_MESSAGES/galeon.mo
share/locale/fr/LC_MESSAGES/galeon.mo
@@ -15,5 +30,6 @@ share/locale/it/LC_MESSAGES/galeon.mo
share/locale/ko/LC_MESSAGES/galeon.mo
share/locale/ru/LC_MESSAGES/galeon.mo
share/locale/sv/LC_MESSAGES/galeon.mo
+share/locale/tr/LC_MESSAGES/galeon.mo
@dirrm share/gnome/pixmaps/galeon
@dirrm share/gnome/galeon
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 3ab307e5bfe8..5e99d7ed99b0 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -6,18 +6,24 @@
#
PORTNAME= galeon
-PORTVERSION= 0.7.1
+PORTVERSION= 0.7.2
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/mozilla:build
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/${MOZILLA}:build
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
glade.4:${PORTSDIR}/devel/libglade
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
- mozilla:${PORTSDIR}/www/mozilla
+ ${X11BASE}/lib/${MOZILLA}:${PORTSDIR}/www/${MOZILLA}
+
+.if !defined(WITH_FULL_MOZILLA)
+MOZILLA= mozilla-embedded
+.else
+MOZILLA= mozilla
+.endif
USE_X_PREFIX= yes
USE_NEWGCC= yes
@@ -36,6 +42,15 @@ CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(WITH_FULL_MOZILLA)
+post-extract:
+ @${ECHO_MSG}
+ @${ECHO_MSG} " By default the port uses mozilla-embedded for html rendering, but if you are"
+ @${ECHO_MSG} " planning to use both Mozilla and Galeon you can instruct it to use mozilla by"
+ @${ECHO_MSG} " defining \"WITH_FULL_MOZILLA\"."
+ @${ECHO_MSG}
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -44,9 +59,10 @@ pre-patch:
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
s|-lpthread|-pthread|g'
-post-patch:
+post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/src/galeon
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%MOZILLA%%|${MOZILLA}|g' ${WRKSRC}/src/galeon
.include <bsd.port.mk>
diff --git a/www/galeon2/distinfo b/www/galeon2/distinfo
index c322cb1767a4..f3bb1d653e04 100644
--- a/www/galeon2/distinfo
+++ b/www/galeon2/distinfo
@@ -1 +1 @@
-MD5 (galeon-0.7.1.tar.gz) = d21f940a1fcf385d3dc2a512a7435ed7
+MD5 (galeon-0.7.2.tar.gz) = 279e2123cd747eaf8097ab1d901ac510
diff --git a/www/galeon2/files/patch-ab b/www/galeon2/files/patch-ab
index 157f691ec8ab..10e821dbedd6 100644
--- a/www/galeon2/files/patch-ab
+++ b/www/galeon2/files/patch-ab
@@ -14,10 +14,10 @@
- MOZILLA_HOME=/usr/local/mozilla
-elif [ -f /usr/lib/mozilla/libgtkembedmoz.so ]; then
- MOZILLA_HOME=/usr/lib/mozilla
-+elif [ -f %%LOCALBASE%%/lib/mozilla/libgtkembedmoz.so ]; then
-+ MOZILLA_HOME=%%LOCALBASE%%/lib/mozilla
-+elif [ -f %%X11BASE%%/lib/mozilla/libgtkembedmoz.so ]; then
-+ MOZILLA_HOME=%%X11BASE%%/lib/mozilla
++elif [ -f %%LOCALBASE%%/lib/%%MOZILLA%%/libgtkembedmoz.so ]; then
++ MOZILLA_HOME=%%LOCALBASE%%/lib/%%MOZILLA%%
++elif [ -f %%X11BASE%%/lib/%%MOZILLA%%/libgtkembedmoz.so ]; then
++ MOZILLA_HOME=%%X11BASE%%/lib/%%MOZILLA%%
else
echo "Cannot find mozilla installation directory. Please set MOZILLA_FIVE_HOME to your mozilla directory"
exit
diff --git a/www/galeon2/pkg-plist b/www/galeon2/pkg-plist
index a180f4ef4bd8..26ee789ce5ca 100644
--- a/www/galeon2/pkg-plist
+++ b/www/galeon2/pkg-plist
@@ -1,6 +1,20 @@
bin/galeon
bin/galeon-bin
share/gnome/apps/Internet/galeon.desktop
+share/gnome/galeon/anim_01.png
+share/gnome/galeon/anim_02.png
+share/gnome/galeon/anim_03.png
+share/gnome/galeon/anim_04.png
+share/gnome/galeon/anim_05.png
+share/gnome/galeon/anim_06.png
+share/gnome/galeon/anim_07.png
+share/gnome/galeon/anim_08.png
+share/gnome/galeon/anim_09.png
+share/gnome/galeon/anim_10.png
+share/gnome/galeon/anim_11.png
+share/gnome/galeon/anim_12.png
+share/gnome/galeon/anim_13.png
+share/gnome/galeon/anim_14.png
share/gnome/galeon/bookmarks.xml
share/gnome/galeon/galeon.glade
share/gnome/galeon/logo.png
@@ -8,6 +22,7 @@ share/gnome/galeon/preferences.xml
share/gnome/pixmaps/galeon.png
share/gnome/pixmaps/galeon/logo.jpg
share/locale/da/LC_MESSAGES/galeon.mo
+share/locale/de/LC_MESSAGES/galeon.mo
share/locale/es/LC_MESSAGES/galeon.mo
share/locale/et/LC_MESSAGES/galeon.mo
share/locale/fr/LC_MESSAGES/galeon.mo
@@ -15,5 +30,6 @@ share/locale/it/LC_MESSAGES/galeon.mo
share/locale/ko/LC_MESSAGES/galeon.mo
share/locale/ru/LC_MESSAGES/galeon.mo
share/locale/sv/LC_MESSAGES/galeon.mo
+share/locale/tr/LC_MESSAGES/galeon.mo
@dirrm share/gnome/pixmaps/galeon
@dirrm share/gnome/galeon