aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-05-19 20:31:05 +0800
committergerald <gerald@FreeBSD.org>2009-05-19 20:31:05 +0800
commitb165c4548f3d982b986103bf99726b7464eaaf43 (patch)
tree6b381cd4d2742f2a481238e5351cdcd1f72a5e33
parentdf933170a928aa01cb24828c8d500f56cd2db387 (diff)
downloadfreebsd-ports-gnome-b165c4548f3d982b986103bf99726b7464eaaf43.tar.gz
freebsd-ports-gnome-b165c4548f3d982b986103bf99726b7464eaaf43.tar.zst
freebsd-ports-gnome-b165c4548f3d982b986103bf99726b7464eaaf43.zip
Make the determination of SUFFIX more general and the one of
CONFIGURE_SCRIPT more robust.
-rw-r--r--lang/gcc/Makefile4
-rw-r--r--lang/gcc45/Makefile4
-rw-r--r--lang/gcc46/Makefile4
-rw-r--r--lang/gcc47/Makefile4
-rw-r--r--lang/gcc48/Makefile4
5 files changed, 10 insertions, 10 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index d1cb6af845f4..4e3c8b147478 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -29,7 +29,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
-SUFFIX= ${PORTVERSION:C/([0-9]).([0-9]).*/\1\2/}
+SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
USE_BISON= build
@@ -41,7 +41,7 @@ MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
+CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
.include <bsd.port.pre.mk>
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index d1cb6af845f4..4e3c8b147478 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -29,7 +29,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
-SUFFIX= ${PORTVERSION:C/([0-9]).([0-9]).*/\1\2/}
+SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
USE_BISON= build
@@ -41,7 +41,7 @@ MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
+CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
.include <bsd.port.pre.mk>
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index d1cb6af845f4..4e3c8b147478 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -29,7 +29,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
-SUFFIX= ${PORTVERSION:C/([0-9]).([0-9]).*/\1\2/}
+SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
USE_BISON= build
@@ -41,7 +41,7 @@ MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
+CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
.include <bsd.port.pre.mk>
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index d1cb6af845f4..4e3c8b147478 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -29,7 +29,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
-SUFFIX= ${PORTVERSION:C/([0-9]).([0-9]).*/\1\2/}
+SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
USE_BISON= build
@@ -41,7 +41,7 @@ MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
+CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
.include <bsd.port.pre.mk>
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index d1cb6af845f4..4e3c8b147478 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -29,7 +29,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
-SUFFIX= ${PORTVERSION:C/([0-9]).([0-9]).*/\1\2/}
+SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
USE_BISON= build
@@ -41,7 +41,7 @@ MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
+CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
.include <bsd.port.pre.mk>