aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-02 02:45:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-02 02:45:15 +0800
commitb3f7e5fb6efb1095b2f3966b0f9f4077f4e8ff88 (patch)
tree130cf998ecc3432460f675eebcfd2cf5403ee991
parente2fbfe0c5e60f738118a7434cef92ff3c9391dad (diff)
downloadfreebsd-ports-gnome-b3f7e5fb6efb1095b2f3966b0f9f4077f4e8ff88.tar.gz
freebsd-ports-gnome-b3f7e5fb6efb1095b2f3966b0f9f4077f4e8ff88.tar.zst
freebsd-ports-gnome-b3f7e5fb6efb1095b2f3966b0f9f4077f4e8ff88.zip
- Update to 0.9.4
- While I'm here: - Add LICENSE - Remove leading indefinite article from COMMENT - Support STAGEDIR Changes: http://pecl.php.net/package-changelog.php?package=xhprof PR: ports/183922 Submitted by: Hung-Yi Chen <gaod@hychen.org> Approved by: maintainer (timeout, 18 days)
-rw-r--r--devel/pecl-xhprof/Makefile8
-rw-r--r--devel/pecl-xhprof/distinfo4
-rw-r--r--devel/pecl-xhprof/files/patch-extension_xhprof.c11
-rw-r--r--devel/pecl-xhprof/files/patch-xhprof.c56
4 files changed, 17 insertions, 62 deletions
diff --git a/devel/pecl-xhprof/Makefile b/devel/pecl-xhprof/Makefile
index 310e1ab444d8..24c6149a2b12 100644
--- a/devel/pecl-xhprof/Makefile
+++ b/devel/pecl-xhprof/Makefile
@@ -2,15 +2,16 @@
# $FreeBSD$
PORTNAME= xhprof
-PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTVERSION= 0.9.4
CATEGORIES= devel pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
EXTRACT_SUFX= .tgz
MAINTAINER= ports@mcdermottroe.com
-COMMENT= A Hierarchical Profiler for PHP
+COMMENT= Hierarchical Profiler for PHP
+
+LICENSE= AL2
WRKSRC= ${WRKDIR}/${DISTNAME}/extension
@@ -19,5 +20,4 @@ USE_PHPIZE= yes
USE_PHPEXT= yes
ONLY_FOR_ARCHS= i386 amd64
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/pecl-xhprof/distinfo b/devel/pecl-xhprof/distinfo
index b3b4c23e4449..44bcaf8042d8 100644
--- a/devel/pecl-xhprof/distinfo
+++ b/devel/pecl-xhprof/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xhprof-0.9.2.tgz) = 5359ea0a1e16ec6c100dd7adb7285bdcc0f931e0b61631ea364f8b06925ea729
-SIZE (xhprof-0.9.2.tgz) = 931660
+SHA256 (xhprof-0.9.4.tgz) = 002a2d4a825d16aeb3017c59f94d8c5e5d06611dd6197acd2f07fce197d3b8f8
+SIZE (xhprof-0.9.4.tgz) = 842077
diff --git a/devel/pecl-xhprof/files/patch-extension_xhprof.c b/devel/pecl-xhprof/files/patch-extension_xhprof.c
new file mode 100644
index 000000000000..a90dcf079493
--- /dev/null
+++ b/devel/pecl-xhprof/files/patch-extension_xhprof.c
@@ -0,0 +1,11 @@
+--- xhprof.c.orig 2013-11-13 18:41:35.000000000 +0800
++++ xhprof.c 2013-11-13 18:43:37.000000000 +0800
+@@ -28,7 +28,7 @@
+ #include "php_ini.h"
+ #include "ext/standard/info.h"
+ #include "php_xhprof.h"
+-#include "zend_extensions.h"
++#include "Zend/zend_extensions.h"
+ #include <sys/time.h>
+ #include <sys/resource.h>
+ #include <stdlib.h>
diff --git a/devel/pecl-xhprof/files/patch-xhprof.c b/devel/pecl-xhprof/files/patch-xhprof.c
deleted file mode 100644
index 3c3f77b8c224..000000000000
--- a/devel/pecl-xhprof/files/patch-xhprof.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- xhprof.c
-+++ xhprof.c
-@@ -28,6 +28,7 @@
- #include "php_ini.h"
- #include "ext/standard/info.h"
- #include "php_xhprof.h"
-+#include "Zend/zend_extensions.h"
- #include <sys/time.h>
- #include <sys/resource.h>
- #include <stdlib.h>
-@@ -898,7 +899,7 @@ static char *hp_get_base_filename(char *filename) {
- static char *hp_get_function_name(zend_op_array *ops TSRMLS_DC) {
- zend_execute_data *data;
- char *func = NULL;
-- char *cls = NULL;
-+ const char *cls = NULL;
- char *ret = NULL;
- int len;
- zend_function *curr_func;
-@@ -942,7 +943,12 @@ static char *hp_get_function_name(zend_op_array *ops TSRMLS_DC) {
- /* we are dealing with a special directive/function like
- * include, eval, etc.
- */
-+#if ZEND_EXTENSION_API_NO >= 220100525
-+ curr_op = data->opline->extended_value;
-+#else
- curr_op = data->opline->op2.u.constant.value.lval;
-+#endif
-+
- switch (curr_op) {
- case ZEND_EVAL:
- func = "eval";
-@@ -1660,13 +1666,22 @@ ZEND_DLEXPORT void hp_execute_internal(zend_execute_data *execute_data,
- if (!_zend_execute_internal) {
- /* no old override to begin with. so invoke the builtin's implementation */
- zend_op *opline = EX(opline);
-+#if ZEND_EXTENSION_API_NO >= 220100525
-+ temp_variable *retvar = &EX_T(opline->result.var);
-+ ((zend_internal_function *) EX(function_state).function)->handler(
-+ opline->extended_value,
-+ retvar->var.ptr,
-+ (EX(function_state).function->common.fn_flags & ZEND_ACC_RETURN_REFERENCE) ?
-+ &retvar->var.ptr:NULL,
-+ EX(object), ret TSRMLS_CC);
-+#else
- ((zend_internal_function *) EX(function_state).function)->handler(
- opline->extended_value,
- EX_T(opline->result.u.var).var.ptr,
- EX(function_state).function->common.return_reference ?
- &EX_T(opline->result.u.var).var.ptr:NULL,
- EX(object), ret TSRMLS_CC);
--
-+#endif
- } else {
- /* call the old override */
- _zend_execute_internal(execute_data, ret TSRMLS_CC);