aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-08-13 23:29:48 +0800
committerzi <zi@FreeBSD.org>2014-08-13 23:29:48 +0800
commitb48e01bc71137f4eff9d7245f011cd8db1222c09 (patch)
treef32b246a3fdd09ce21fd500ae13d225e5cd35672
parentc6a8673391890f6687e3f9f924cc778a28b9d9f8 (diff)
downloadfreebsd-ports-gnome-b48e01bc71137f4eff9d7245f011cd8db1222c09.tar.gz
freebsd-ports-gnome-b48e01bc71137f4eff9d7245f011cd8db1222c09.tar.zst
freebsd-ports-gnome-b48e01bc71137f4eff9d7245f011cd8db1222c09.zip
New port: www/p5-Dancer-Plugin-REST:
This plugin helps you write a RESTful webservice with Dancer. WWW: http://search.cpan.org/dist/Dancer-Plugin-REST/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer-Plugin-REST/Makefile20
-rw-r--r--www/p5-Dancer-Plugin-REST/distinfo2
-rw-r--r--www/p5-Dancer-Plugin-REST/pkg-descr3
-rw-r--r--www/p5-Dancer-Plugin-REST/pkg-plist2
5 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a9a2269c1e8f..a31036e144fe 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -842,6 +842,7 @@
SUBDIR += p5-Dancer-Plugin-ExtDirect
SUBDIR += p5-Dancer-Plugin-Feed
SUBDIR += p5-Dancer-Plugin-Lexicon
+ SUBDIR += p5-Dancer-Plugin-REST
SUBDIR += p5-Dancer-Plugin-SiteMap
SUBDIR += p5-Dancer-Plugin-ValidationClass
SUBDIR += p5-Dancer-Session-Cookie
diff --git a/www/p5-Dancer-Plugin-REST/Makefile b/www/p5-Dancer-Plugin-REST/Makefile
new file mode 100644
index 000000000000..0a58c8d31cde
--- /dev/null
+++ b/www/p5-Dancer-Plugin-REST/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-REST
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:YANICK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Dancer plugin for writing RESTful apps
+
+RUN_DEPENDS= p5-Dancer>0:${PORTSDIR}/www/p5-Dancer
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild run build
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Plugin-REST/distinfo b/www/p5-Dancer-Plugin-REST/distinfo
new file mode 100644
index 000000000000..3ff068674bab
--- /dev/null
+++ b/www/p5-Dancer-Plugin-REST/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-REST-0.11.tar.gz) = 81b8916632ef464c913829fe661eb1a6cecba0f2f9f7e1935db128f2ab4518a8
+SIZE (Dancer-Plugin-REST-0.11.tar.gz) = 19134
diff --git a/www/p5-Dancer-Plugin-REST/pkg-descr b/www/p5-Dancer-Plugin-REST/pkg-descr
new file mode 100644
index 000000000000..03682085276a
--- /dev/null
+++ b/www/p5-Dancer-Plugin-REST/pkg-descr
@@ -0,0 +1,3 @@
+This plugin helps you write a RESTful webservice with Dancer.
+
+WWW: http://search.cpan.org/dist/Dancer-Plugin-REST/
diff --git a/www/p5-Dancer-Plugin-REST/pkg-plist b/www/p5-Dancer-Plugin-REST/pkg-plist
new file mode 100644
index 000000000000..89e239f1b3a9
--- /dev/null
+++ b/www/p5-Dancer-Plugin-REST/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/Dancer::Plugin::REST.3.gz
+%%SITE_PERL%%/Dancer/Plugin/REST.pm