aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-04-24 00:23:44 +0800
committerdinoex <dinoex@FreeBSD.org>2010-04-24 00:23:44 +0800
commitb56cc0a49d1c53b3038ac72eab051825e655cf0c (patch)
treeababe8f3bfc7a87cb8a0973101e07a320d2a2b37
parentcf2eb5378b30a978d40a9698716adc01e92d070b (diff)
downloadfreebsd-ports-gnome-b56cc0a49d1c53b3038ac72eab051825e655cf0c.tar.gz
freebsd-ports-gnome-b56cc0a49d1c53b3038ac72eab051825e655cf0c.tar.zst
freebsd-ports-gnome-b56cc0a49d1c53b3038ac72eab051825e655cf0c.zip
- PHP 5.2 slave port
PR: 145772 Submitted by: Alex Keda
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php52-odbc/Makefile14
-rw-r--r--databases/php52-odbc/files/patch-config.m4119
-rw-r--r--devel/Makefile1
-rw-r--r--devel/php52-pcntl/Makefile14
-rw-r--r--security/Makefile1
-rw-r--r--security/php52-openssl/Makefile14
7 files changed, 164 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 487c2c7f0dd4..852261e94d42 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -525,6 +525,7 @@
SUBDIR += php52-mysqli
SUBDIR += php52-oci8
SUBDIR += php52-odbc
+ SUBDIR += php52-pdo
SUBDIR += phpminiadmin
SUBDIR += phpmyadmin
SUBDIR += phpmyadmin211
diff --git a/databases/php52-odbc/Makefile b/databases/php52-odbc/Makefile
new file mode 100644
index 000000000000..215bdd199154
--- /dev/null
+++ b/databases/php52-odbc/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-odbc
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -odbc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php52-odbc/files/patch-config.m4 b/databases/php52-odbc/files/patch-config.m4
new file mode 100644
index 000000000000..97178e4029c7
--- /dev/null
+++ b/databases/php52-odbc/files/patch-config.m4
@@ -0,0 +1,119 @@
+--- config.m4.orig 2007-09-14 08:03:08.000000000 +0200
++++ config.m4 2007-09-14 08:14:21.000000000 +0200
+@@ -101,7 +101,7 @@
+ dnl
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(adabas,,
+-[ --with-adabas[=DIR] Include Adabas D support [/usr/local]])
++[ --with-adabas[=DIR] Include Adabas D support [/usr/local]], no, no)
+
+ if test "$PHP_ADABAS" != "no"; then
+ AC_MSG_CHECKING([for Adabas support])
+@@ -128,7 +128,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(sapdb,,
+-[ --with-sapdb[=DIR] Include SAP DB support [/usr/local]])
++[ --with-sapdb[=DIR] Include SAP DB support [/usr/local]], no, no)
+
+ if test "$PHP_SAPDB" != "no"; then
+ AC_MSG_CHECKING([for SAP DB support])
+@@ -146,7 +146,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(solid,,
+-[ --with-solid[=DIR] Include Solid support [/usr/local/solid]])
++[ --with-solid[=DIR] Include Solid support [/usr/local/solid]], no, no)
+
+ if test "$PHP_SOLID" != "no"; then
+ AC_MSG_CHECKING(for Solid support)
+@@ -171,7 +171,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(ibm-db2,,
+-[ --with-ibm-db2[=DIR] Include IBM DB2 support [/home/db2inst1/sqllib]])
++[ --with-ibm-db2[=DIR] Include IBM DB2 support [/home/db2inst1/sqllib]], no, no)
+
+ if test "$PHP_IBM_DB2" != "no"; then
+ AC_MSG_CHECKING(for IBM DB2 support)
+@@ -208,7 +208,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(ODBCRouter,,
+-[ --with-ODBCRouter[=DIR] Include ODBCRouter.com support [/usr]])
++[ --with-ODBCRouter[=DIR] Include ODBCRouter.com support [/usr]], no, no)
+
+ if test "$PHP_ODBCROUTER" != "no"; then
+ AC_MSG_CHECKING(for ODBCRouter.com support)
+@@ -229,7 +229,7 @@
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(empress,,
+ [ --with-empress[=DIR] Include Empress support [\$EMPRESSPATH]
+- (Empress Version >= 8.60 required)])
++ (Empress Version >= 8.60 required)], no, no)
+
+ if test "$PHP_EMPRESS" != "no"; then
+ AC_MSG_CHECKING(for Empress support)
+@@ -253,7 +253,7 @@
+ PHP_ARG_WITH(empress-bcs,,
+ [ --with-empress-bcs[=DIR]
+ Include Empress Local Access support [\$EMPRESSPATH]
+- (Empress Version >= 8.60 required)])
++ (Empress Version >= 8.60 required)], no, no)
+
+ if test "$PHP_EMPRESS_BCS" != "no"; then
+ AC_MSG_CHECKING(for Empress local access support)
+@@ -291,7 +291,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(birdstep,,
+-[ --with-birdstep[=DIR] Include Birdstep support [/usr/local/birdstep]])
++[ --with-birdstep[=DIR] Include Birdstep support [/usr/local/birdstep]], no, no)
+
+ if test "$PHP_BIRDSTEP" != "no"; then
+ AC_MSG_CHECKING(for Birdstep support)
+@@ -346,7 +346,7 @@
+ running this configure script:
+ CPPFLAGS=\"-DODBC_QNX -DSQLANY_BUG\"
+ LDFLAGS=-lunix
+- CUSTOM_ODBC_LIBS=\"-ldblib -lodbc\"])
++ CUSTOM_ODBC_LIBS=\"-ldblib -lodbc\"], no, no)
+
+ if test "$PHP_CUSTOM_ODBC" != "no"; then
+ AC_MSG_CHECKING(for a custom ODBC support)
+@@ -366,7 +366,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(iodbc,,
+-[ --with-iodbc[=DIR] Include iODBC support [/usr/local]])
++[ --with-iodbc[=DIR] Include iODBC support [/usr/local]], no, no)
+
+ if test "$PHP_IODBC" != "no"; then
+ AC_MSG_CHECKING(for iODBC support)
+@@ -387,7 +387,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(esoob,,
+-[ --with-esoob[=DIR] Include Easysoft OOB support [/usr/local/easysoft/oob/client]])
++[ --with-esoob[=DIR] Include Easysoft OOB support [/usr/local/easysoft/oob/client]], no, no)
+
+ if test "$PHP_ESOOB" != "no"; then
+ AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
+@@ -407,7 +407,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(unixODBC,,
+-[ --with-unixODBC[=DIR] Include unixODBC support [/usr/local]])
++[ --with-unixODBC[=DIR] Include unixODBC support [/usr/local]], no)
+
+ if test "$PHP_UNIXODBC" != "no"; then
+ AC_MSG_CHECKING(for unixODBC support)
+@@ -428,7 +428,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(dbmaker,,
+-[ --with-dbmaker[=DIR] Include DBMaker support])
++[ --with-dbmaker[=DIR] Include DBMaker support], no, no)
+
+ if test "$PHP_DBMAKER" != "no"; then
+ AC_MSG_CHECKING(for DBMaker support)
diff --git a/devel/Makefile b/devel/Makefile
index 536f96f34d1d..24033984b7db 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2472,6 +2472,7 @@
SUBDIR += php52-gettext
SUBDIR += php52-json
SUBDIR += php52-ncurses
+ SUBDIR += php52-pcntl
SUBDIR += php52-pcre
SUBDIR += phpbt
SUBDIR += phptags
diff --git a/devel/php52-pcntl/Makefile b/devel/php52-pcntl/Makefile
new file mode 100644
index 000000000000..5500996cde44
--- /dev/null
+++ b/devel/php52-pcntl/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-pcntl
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -pcntl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/Makefile b/security/Makefile
index 74e4b5834b54..c5d358b4124c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -633,6 +633,7 @@
SUBDIR += php52-hash
SUBDIR += php52-mcrypt
SUBDIR += php52-mhash
+ SUBDIR += php52-openssl
SUBDIR += phpdeadlock
SUBDIR += phpmyid
SUBDIR += phpsecinfo
diff --git a/security/php52-openssl/Makefile b/security/php52-openssl/Makefile
new file mode 100644
index 000000000000..291cd2dda8b2
--- /dev/null
+++ b/security/php52-openssl/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-openssl
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -openssl
+
+.include "${MASTERDIR}/Makefile"