aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2012-09-05 14:01:31 +0800
committernivit <nivit@FreeBSD.org>2012-09-05 14:01:31 +0800
commitb651050d6a56d9eafea490c8afbc5c77e948e3ba (patch)
tree31f6ada47aaab42d0b79f30ffac0b4e2a31e9f02
parentccca516cd984478bc6a78fbdef651226b6a67782 (diff)
downloadfreebsd-ports-gnome-b651050d6a56d9eafea490c8afbc5c77e948e3ba.tar.gz
freebsd-ports-gnome-b651050d6a56d9eafea490c8afbc5c77e948e3ba.tar.zst
freebsd-ports-gnome-b651050d6a56d9eafea490c8afbc5c77e948e3ba.zip
- Update to 1.8.1
- Build docs with devel/py-sphinx - Convert to the new options framework - Move code, that fix pkg-plist when Python ver >= 3.2, to a separate file (files/py3k-fix-pkg-plist.inc) - Update WWW: field in pkg-descr BuildLog: http://goo.gl/QCpX6 Changes&News: http://goo.gl/OqbDH
-rw-r--r--devel/py-virtualenv/Makefile41
-rw-r--r--devel/py-virtualenv/distinfo4
-rw-r--r--devel/py-virtualenv/files/py3k-fix-pkg-plist.inc14
-rw-r--r--devel/py-virtualenv/pkg-descr4
-rw-r--r--devel/py-virtualenv/pkg-plist31
5 files changed, 67 insertions, 27 deletions
diff --git a/devel/py-virtualenv/Makefile b/devel/py-virtualenv/Makefile
index a768eb01910c..a3380a485a70 100644
--- a/devel/py-virtualenv/Makefile
+++ b/devel/py-virtualenv/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= virtualenv
-PORTVERSION= 1.7.2
+PORTVERSION= 1.8.1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,6 +16,9 @@ COMMENT= Virtual Python Environment builder
LICENSE= MIT
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+OPTIONS_DEFINE= DOCS
+
PLIST_SUB= PYVER=${PYTHON_VER} PIPVER=${PIPVER} DISTRIBUTEVER=${DISTRIBUTEVER} \
PY2X=${PY2X}
@@ -23,37 +26,31 @@ PLIST_SUB= PYVER=${PYTHON_VER} PIPVER=${PIPVER} DISTRIBUTEVER=${DISTRIBUTEVER} \
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
-PIPVER= 1.1
-DISTRIBUTEVER= 0.6.27
+PIPVER= 1.2
+DISTRIBUTEVER= 0.6.28
+
+.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS)
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= ${PKGNAMEPREFIX}sphinx>=1.1.3:${PORTSDIR}/textproc/py-sphinx
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+PYDISTUTILS_BUILD_TARGET+= build_sphinx
post-install:
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/docs && ${INSTALL_DATA} index.txt ${DOCSDIR}/
+ @cd ${WRKSRC}/build/sphinx/html && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} >= 320
+.if ${PYTHON_REL} >= 310
PY2X= "@comment "
-# When Python version is 3.2+ we rewrite all the filenames
-# of TMPPLIST that end with .py[co], so that they conform
-# to PEP 3147 (see http://www.python.org/dev/peps/pep-3147/)
-PYMAGICTAG= ${PYTHON_CMD} -c 'import imp; print(imp.get_tag())'
-add-plist-post:
- @${AWK} '\
- /\.py[co]$$/ && !($$0 ~ "/" pc "/") {id = match($$0, /\/[^\/]+\.py[co]$$/); if (id != 0) {d = substr($$0, 1, RSTART - 1); dirs[d] = 1}; sub(/\.py[co]$$/, "." mt "&"); sub(/[^\/]+\.py[co]$$/, pc "/&"); print; next} \
- /^@dirrm / {d = substr($$0, 8); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
- {print} \
- END {if (sp in dirs) {print "@dirrm " sp "/" pc}} \
- ' \
- pc="__pycache__" mt="$$(${PYMAGICTAG})" sp="${PYTHON_SITELIBDIR:S,${PYTHONBASE}/,,g}" \
- ${TMPPLIST} > ${TMPPLIST}.pyc_tmp
- @${MV} ${TMPPLIST}.pyc_tmp ${TMPPLIST}
.else
PY2X= ""
.endif
+.if ${PYTHON_REL} >= 320
+.include "${FILESDIR}/py3k-fix-pkg-plist.inc"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/py-virtualenv/distinfo b/devel/py-virtualenv/distinfo
index cbb54083749d..2e4fdb423035 100644
--- a/devel/py-virtualenv/distinfo
+++ b/devel/py-virtualenv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (virtualenv-1.7.2.tar.gz) = 8cbbe308ab0f446a4ceacf24b2656bedd33ea22825b0750fd079766cc6e91bf4
-SIZE (virtualenv-1.7.2.tar.gz) = 2156615
+SHA256 (virtualenv-1.8.1.tar.gz) = 524813074d043b5786f45e04912f7eba814defda53ba6d72460b77c704c6b8f4
+SIZE (virtualenv-1.8.1.tar.gz) = 2160621
diff --git a/devel/py-virtualenv/files/py3k-fix-pkg-plist.inc b/devel/py-virtualenv/files/py3k-fix-pkg-plist.inc
new file mode 100644
index 000000000000..93acb972e248
--- /dev/null
+++ b/devel/py-virtualenv/files/py3k-fix-pkg-plist.inc
@@ -0,0 +1,14 @@
+# When Python version is 3.2+ we rewrite all the filenames
+# of TMPPLIST that end with .py[co], so that they conform
+# to PEP 3147 (see http://www.python.org/dev/peps/pep-3147/)
+PYMAGICTAG= ${PYTHON_CMD} -c 'import imp; print(imp.get_tag())'
+add-plist-post:
+ @${AWK} '\
+ /\.py[co]$$/ && !($$0 ~ "/" pc "/") {id = match($$0, /\/[^\/]+\.py[co]$$/); if (id != 0) {d = substr($$0, 1, RSTART - 1); dirs[d] = 1}; sub(/\.py[co]$$/, "." mt "&"); sub(/[^\/]+\.py[co]$$/, pc "/&"); print; next} \
+ /^@dirrm / {d = substr($$0, 8); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
+ {print} \
+ END {if (sp in dirs) {print "@dirrm " sp "/" pc}} \
+ ' \
+ pc="__pycache__" mt="$$(${PYMAGICTAG})" sp="${PYTHON_SITELIBDIR:S,${PYTHONBASE}/,,g}" \
+ ${TMPPLIST} > ${TMPPLIST}.pyc_tmp
+ @${MV} ${TMPPLIST}.pyc_tmp ${TMPPLIST}
diff --git a/devel/py-virtualenv/pkg-descr b/devel/py-virtualenv/pkg-descr
index 7d96f393b1ff..b1da722410d0 100644
--- a/devel/py-virtualenv/pkg-descr
+++ b/devel/py-virtualenv/pkg-descr
@@ -1,9 +1,9 @@
``virtualenv`` is a tool to create isolated Python environments.
-
+
It creates an environment that has its own installation directories,
that doesn't share libraries with other virtualenv environments
(and optionally doesn't use the globally installed libraries either).
Usage: virtualenv YOUR_NEW_PYTHON_ENV
-WWW: http://pypi.python.org/pypi/virtualenv
+WWW: http://www.virtualenv.org/
diff --git a/devel/py-virtualenv/pkg-plist b/devel/py-virtualenv/pkg-plist
index 389fe8548447..4328b302bff4 100644
--- a/devel/py-virtualenv/pkg-plist
+++ b/devel/py-virtualenv/pkg-plist
@@ -16,7 +16,36 @@ bin/virtualenv-%%PYVER%%
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/virtualenv_support/distribute-%%DISTRIBUTEVER%%.tar.gz
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/virtualenv_support/pip-%%PIPVER%%.tar.gz
%%PY2X%%%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/virtualenv_support/setuptools-0.6c11-py%%PYVER%%.egg
-%%PORTDOCS%%%%DOCSDIR%%/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/.buildinfo
+%%PORTDOCS%%%%DOCSDIR%%/_sources/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/news.txt
+%%PORTDOCS%%%%DOCSDIR%%/_static/ajax-loader.gif
+%%PORTDOCS%%%%DOCSDIR%%/_static/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment-bright.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment-close.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/doctools.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/down-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/down.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/file.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/minus.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/nature.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/plus.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/pygments.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/underscore.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/up.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
+%%PORTDOCS%%%%DOCSDIR%%/genindex.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/news.html
+%%PORTDOCS%%%%DOCSDIR%%/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/search.html
+%%PORTDOCS%%%%DOCSDIR%%/searchindex.js
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/_static
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/_sources
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/virtualenv_support
@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO