aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-02-17 18:54:05 +0800
committervs <vs@FreeBSD.org>2005-02-17 18:54:05 +0800
commitb6c11b27c983b0376634501b383b8120fb71768d (patch)
treea9094ddf4b13ef0677f14cea4dc7dabcadd601fd
parent3933ae80320f5ac47635c5cb28d5ac99301409df (diff)
downloadfreebsd-ports-gnome-b6c11b27c983b0376634501b383b8120fb71768d.tar.gz
freebsd-ports-gnome-b6c11b27c983b0376634501b383b8120fb71768d.tar.zst
freebsd-ports-gnome-b6c11b27c983b0376634501b383b8120fb71768d.zip
Fix gzip namespace pollution (bump PORTREV)
PR: ports/70922 Submitted by: Eric P. Scott Approved by: maintainer timeout
-rw-r--r--palm/pose/Makefile2
-rw-r--r--palm/pose/files/patch-gzip-conflict9
2 files changed, 10 insertions, 1 deletions
diff --git a/palm/pose/Makefile b/palm/pose/Makefile
index 8db639ee79f9..f240b2f6e5b5 100644
--- a/palm/pose/Makefile
+++ b/palm/pose/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pose
PORTVERSION= 3.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= palm emulators
MASTER_SITES= http://www.palmos.com/dev/tools/emulator/sources/ \
http://www.palmos.com/dev/tools/emulator/:skins
diff --git a/palm/pose/files/patch-gzip-conflict b/palm/pose/files/patch-gzip-conflict
new file mode 100644
index 000000000000..5cfe41242e66
--- /dev/null
+++ b/palm/pose/files/patch-gzip-conflict
@@ -0,0 +1,9 @@
+--- ../SrcShared/Gzip/gzip.h.orig Thu Feb 17 11:34:23 2005
++++ ../SrcShared/Gzip/gzip.h Thu Feb 17 11:34:50 2005
+@@ -320,4 +320,6 @@
+ //extern voidp xmalloc OF((unsigned int size)); // POSER
+
+ /* in inflate.c */
++#define inflate POSE_inflate
++#define inflate_codes POSE_inflate_codes
+ extern int inflate OF((void));