aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-02-16 16:42:53 +0800
committermarino <marino@FreeBSD.org>2014-02-16 16:42:53 +0800
commitb6d15e443c1d759e53f753e476c8856c35161434 (patch)
treebbbb1e7c214355a2851c8dd9cf70274a848ff5d5
parent69ae9111c8f8dcd6a5bf3f42b754e074e50c4161 (diff)
downloadfreebsd-ports-gnome-b6d15e443c1d759e53f753e476c8856c35161434.tar.gz
freebsd-ports-gnome-b6d15e443c1d759e53f753e476c8856c35161434.tar.zst
freebsd-ports-gnome-b6d15e443c1d759e53f753e476c8856c35161434.zip
lang/modula3: Add custom DEC/CM3 license
It doesn't appear possible to have two custom licenses combined, so I had to get creative and concatenate them into one combined document. Also, the auto-generated plist had to be modified to add the three new entries. There may be a better way to do this (e.g. use >> ${TMPPLIST} instead of > ${TMPPLIST} on first line) but at least the awk method works durably.
-rw-r--r--lang/modula3/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/modula3/Makefile b/lang/modula3/Makefile
index d745b77c1628..f33e22aab0ff 100644
--- a/lang/modula3/Makefile
+++ b/lang/modula3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= modula3
PORTVERSION= 5.8.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= https://modula3.elegosoft.com/cm3/releng/ \
http://downloads.dragonlace.net/m3/ \
@@ -13,6 +13,11 @@ DISTFILES= ${SRCDISTFILE} ${BOOTDIST}
MAINTAINER= marino@FreeBSD.org
COMMENT= Critical Mass Modula-3 compiler
+LICENSE= DECM3
+LICENSE_FILE= ${WRKSRC}/COM_LICENSE
+LICENSE_NAME= CM3 License defined by DEC and Critical Mass copyrights
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/libiodbc
NEWBOOTDIR= ${WRKDIR}/new-bootstrap/bootstrap
@@ -73,6 +78,7 @@ do-extract:
@${MKDIR} ${WRKSRC}
@(cd ${WRKSRC} && tar -xf ${DISTDIR}/${SRCDISTFILE})
@(cd ${WRKDIR} && tar -xf ${DISTDIR}/${BOOTDIST:C/:[^:]+$//})
+ @(cd ${WRKSRC} && ${CAT} COPYRIGHT-DEC COPYRIGHT-CMASS > COM_LICENSE)
post-patch:
# Use sed -i instead of ${REINPLACE_CMD} because we don't want .bak files
@@ -138,6 +144,7 @@ post-install:
cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
${SORT} | ${SED} -e 's/^man\/man[1578]\/.*[1578]$$/&.gz/' \
> ${TMPPLIST}
+ @echo ${PLIST_FILES} | awk '{print $$1}' RS=' ' >> ${TMPPLIST}
cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${SORT} -r | \
${SED} -e '/^bin$$/d' -e '/^lib$$/d' -e '/^pkg$$/d' \
-e '/^share\/examples$$/d' -e '/^share\/doc$$/d' -e '/^share$$/d' \